Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Note: To change your forum username: login, click your avatar icon (top right?), Edit Profile. Change the "full name" field to your preferred username.

Quick Links


ROCM-SMI - AMD Tool


  • Beta Team

    In order to set clock/memory frequency and volts along with the fans on AMD using the ROCM-SMI tool I have found the following command to work.
    rocm-smi -d 0 --autorespond Y --setperflevel manual --setsclk 5 --setslevel 5 1025 820 --setmclk 2 --setmlevel 2 2025 820 --setfan 60%

    There are a couple of things I needed to do to get some of the numbers to use in this.

    First, run the rocm-smi command and see what GPUs it is seeing and what their numbers are. You will need to run the above command and change the number for the -d setting for each gpu. I'm not sure if you can run designated multiple gpus with the -d command as my test board only has 1 gpu in it.

    Start up your miner for a minute and then run rocm-smi -c
    This should show you an output like
    GPU[0] : mclk clock level: 2 (2025Mhz)
    GPU[0] : pcie clock level: 1 (8.0GT/s, x16)
    GPU[0] : sclk clock level: 5 (1025Mhz)

    Write down the clock levels for each gpu for the mclk and the sclk. (In this case it is 2 and 5).
    STOP THE MINER! (Seriously!).

    Change the --setsclk and --setmclk numbers to the ones you wrote down for you the gpu you are going to issue the command for.

    Change the --setslevel to reflect the same number for the setsclk as well as the Core Clock and the mvolts you want to set. In the case above 1025 core clock and 820 mvolt.

    Change the --setmlevel to reflect the same number for the setmclk as well as the Memory clock and mvolts you want to set. In the case above 2025 for the Memory clock and 820 mvolt.

    Change the --setfan to the percentage you want to run your fans on.

    Remove any tt flag from your miner or your fans will revert to auto mode.

    Run the command and it should show everything set correctly.

    Run the miner again and then verify via the rocm-smi command by itself.

    Repeat for all gpus or make it into one bash script.

    *** Do not run the command setting the clocks while the miner is running or you will probably crash your shit! ****
    The info commands like rocm-smi and rocm-smi -c is fine to run while miner is running.


  • Beta Team


  • Staff

    Preface:

    rocm-smi is really just a user friendly TUI wrapper for echoed system writes.

    Example (Set Performance Level to "manual"):

    # echo "manual" > /sys/class/drm/card0/device/power_dpm_force_performance_level
    

    is the same (assuming that rocm-smi sees -d 1 the same as /card0/) as:

    # rocm-smi -d 1 --setperflevel manual
    

    Okay, with that said, here's what I've learned:

    Basic:

    The main command(s) I use for quickly monitoring what is going on is the following:

    Summary
    Command rocm-smi -l && rocm-smi -s && rocm-smi
    Result 1e4ef80d-641d-4fe0-a5f8-e71a06a1746a-image.png
    • First, this let's me see all Compute Profiles and their attributes along with which one is currently set. (rocm-smi -l)
    • Next, I can see all supported GPU and Memory Clocks along with which one is currently set. (rocm-smi -s)
    • Last, I just run a standard rocm-smi as sort of a quick reference sanity check... it also shows power usage along with fan speeds as a bonus. (rocm-smi)

    Special Note: The asterisks (marked with the red lines in the above pic) indicate current values.

    Another good reference command is the "Show supported GPU and Memory Clocks and Voltages" (rocm-smi -S), as this one will show you each of the P-States along with their associated voltages. Only downside is that it doesn't show what is currently set.

    Show Supported GPU and Memory Clocks and Voltages
    Command rocm-smi -S
    Result 51747150-6997-46a4-87fc-d7d6a427c642-image.png

    rocm-smi numbers all detected GPU's by whole numbers (starting with #1) and can be viewed with the base rocm-smi command:

    Device Numbers
    Command rocm-smi
    Result 7961a709-2eb7-49ab-ab7e-1d45c87b6159-image.png

    If you have more than one GPU and need to better identify a GPU, you can use rocm-smi --showbus to show PCI bus IDs.

    Show PCI bus number
    Command rocm-smi --showbus
    Result c1047263-5d5d-4e75-996b-1a1516ab3cc6-image.png

    Once we know what device numbers we are dealing with, we will want to use the Device Flag (-d <#>) with our rocm-smi commands to specify which GPU the command should be applied to.

    Device Flag Example
    Command rocm-smi -d 1 --showvoltagerange
    Result 5999c3f2-9998-4f44-b3fc-a3d2f10a5863-image.png

    Leaving out this flag, rocm-smi will attempt to apply the command to all of the GPU's that were detected. This may or may not cause you problems, however, using multiple commands to address each GPU specifically will always work, so use your best judgement with this flag.

    Note: For the rest of this post, I will not be using the Device Flag, but just remember that it can be added to any of the commands if desired.

    Performance Mode:

    There are 4 different Performance Modes:

    • Auto - Automatic adjustment based upon GPU load (full BIOS control)
    • High - Attempt to maintain highest performance regardless of GPU load
    • Low - Attempt to maintain lowest performance regardless of GPU load
    • Manual - Attempt to maintain user defined settings regardless of GPU load

    By default, the BIOS puts the GPU into Auto mode. This allows the BIOS to control all aspects of the GPU's performance (i.e. power, core, mem, bus, voltages, etc...) as needed depending upon the GPU load.

    Auto Manual Low High
    Command rocm-smi --setperflevel auto rocm-smi --setperflevel manual rocm-smi --setperflevel low rocm-smi --setperflevel high
    Result 51d6f3a3-b656-423c-b60b-242de793868f-image.png 76d66e3f-85e0-4887-a707-f83bf5708251-image.png 01f78353-0103-4f23-87e5-59a03be39267-image.png c6b5f86f-9be1-46ff-847c-a9ce8d38dbec-image.png
    Verification 496c2dc9-15d0-4929-99b4-775c7af58f75-image.png 78843216-9c85-4683-a52a-9fb63aa37e5d-image.png 6f48417f-6ba2-4c79-8741-37120bcbb5b9-image.png b61a9815-2e9a-42c6-b9aa-9f0fd01bce03-image.png
    • Note1: Before you can apply any user defined settings, the GPU must be set to "manual" Performance Mode.
    • Note2: If "manual" Performance Mode isn't set, other commands may do one of the following: 1. Ignore the command issued (with or without an error output) or 2. Automatically force the GPU into "manual" Performance Mode. This could cause problems and/or confusion down the road, so placing the GPU into "manual" Performance Mode should be the first command run prior to making all other adjustments.

    Set Power State (P-State) [Specific or Range]

    One of the easiest changes that can be made is to force the GPU into a specific P-State or limit which P-States are available for the BIOS to auto adjust through.

    P-States are just pre-configured Core/Voltage and combos held within the BIOS. By default, the GPU will auto select a p-state based upon the load (along with other factors like power usage) being detected by the BIOS.

    Under a "no-load" or idle condition, the BIOS will auto select P-State 0. As the load increases, so will the selected P-State

    To see these combos, just run the following command: rocm-smi -S

    51747150-6997-46a4-87fc-d7d6a427c642-image.png

    • Note1: The number of P-States (and the associated values) are not identical across all GPU's. You'll need to check under your specific GPU to be sure.
    • Note2: SCLK = Core clock, MCLK = Memory clock

    In my example, you can see my RX570 has 8 P-States (0 through 7)

    Still In Work...


  • Beta Team


  • Beta Team

    This is just a collection of my adventures to get a couple of Sapphire RX 5600 XT GPUs running under PiMP mining eth at an amazing speed.

    Hopefully it can help others playing with ROCM-SMI to work out how to use it in the best way.

    I had great help from "Todd" and "docdrydenn" writing in following post,
    ROCM-SMI - AMD Tool great stuff.


    Sep 13, 2020:
    I did some testing on my 5600 XT and a bit of succes.

    Noticed some odd things like the power levels.

    [/root]:# rocm-smi -c
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: dcefclk clock level: 0 (506Mhz)
    GPU[0] 		: fclk clock level: 2 (1266Mhz)
    GPU[0] 		: mclk clock level: 3 (875Mhz)
    GPU[0] 		: pcie clock level: 1 (5.0GT/s, x1 619Mhz)
    GPU[0] 		: sclk clock level: 2 (1780Mhz)
    GPU[0] 		: socclk clock level: 2 (1266Mhz)
    ================================================================================ 
    

    Show that mclk is on level 3 and sclk is on level 2.
    But if I look att all the frequencies and voltage it looks different.

     [/root]:# rocm-smi --showclkvolt
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: OD_SCLK:
    GPU[0] 		: 0: 800Mhz
    GPU[0] 		: 1: 1300Mhz
    GPU[0] 		: OD_MCLK:
    GPU[0] 		: 1: 875MHz
    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 708mV
    GPU[0] 		: 1: 1290MHz @ 760mV
    GPU[0] 		: 2: 1780MHz @ 983mV
    GPU[0] 		: OD_RANGE:
    GPU[0] 		: SCLK:     800Mhz       1820Mhz
    GPU[0] 		: MCLK:     625Mhz        930Mhz
    GPU[0] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[1] 		: OD_SCLK:
    GPU[1] 		: 0: 800Mhz
    GPU[1] 		: 1: 1780Mhz
    GPU[1] 		: OD_MCLK:
    GPU[1] 		: 1: 875MHz
    GPU[1] 		: OD_VDDC_CURVE:
    GPU[1] 		: 0: 800MHz @ 705mV
    GPU[1] 		: 1: 1290MHz @ 752mV
    GPU[1] 		: 2: 1780MHz @ 969mV
    GPU[1] 		: OD_RANGE:
    GPU[1] 		: SCLK:     800Mhz       1820Mhz
    GPU[1] 		: MCLK:     625Mhz        930Mhz
    GPU[1] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    

    Now we se that mclk is on level 1, not 3 and sclk is on level 1, not 2.

    That also looks like the case when I try to set the clock/voltage settings.
    It does not work with lever 3 and 2, but 1 and 1 is OK.

    Time to change some clocks.

    Run following.
    rocm-smi -d 0 --autorespond Y --setperflevel manual --setsclk 1 --setslevel 1 1300 810 --setmclk 1 --setmlevel 1 830 810

    Got some warnings about clock level.

    [/root]:# rocm-smi --autorespond Y --setperflevel manual --setsclk 1 --setslevel 1 1300 810 --setmclk 1 --setmlevel 1 830 810
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Successfully set sclk frequency mask to Level 1
    GPU[1] 		: Successfully set sclk frequency mask to Level 1
    GPU[0] 		: Successfully set mclk frequency mask to Level 1
    GPU[1] 		: Successfully set mclk frequency mask to Level 1
    
              ******WARNING******
    
              Operating your AMD GPU outside of official AMD specifications or outside of
              factory settings, including but not limited to the conducting of overclocking,
              over-volting or under-volting (including use of this interface software,
              even if such software has been directly or indirectly provided by AMD or otherwise
              affiliated in any way with AMD), may cause damage to your AMD GPU, system components
              and/or result in system failure, as well as cause other problems.
              DAMAGES CAUSED BY USE OF YOUR AMD GPU OUTSIDE OF OFFICIAL AMD SPECIFICATIONS OR
              OUTSIDE OF FACTORY SETTINGS ARE NOT COVERED UNDER ANY AMD PRODUCT WARRANTY AND
              MAY NOT BE COVERED BY YOUR BOARD OR SYSTEM MANUFACTURER'S WARRANTY.
              Please use this utility with caution.
              
    Unable to write to sysfs file /sys/class/drm/card0/device/pp_od_clk_voltage
    WARNING: IO or OS error
    ERROR: GPU[0] 		: Unable to set sclk clock to Level s 1 1300 810
    
              ******WARNING******
    
              Operating your AMD GPU outside of official AMD specifications or outside of
              factory settings, including but not limited to the conducting of overclocking,
              over-volting or under-volting (including use of this interface software,
              even if such software has been directly or indirectly provided by AMD or otherwise
              affiliated in any way with AMD), may cause damage to your AMD GPU, system components
              and/or result in system failure, as well as cause other problems.
              DAMAGES CAUSED BY USE OF YOUR AMD GPU OUTSIDE OF OFFICIAL AMD SPECIFICATIONS OR
              OUTSIDE OF FACTORY SETTINGS ARE NOT COVERED UNDER ANY AMD PRODUCT WARRANTY AND
              MAY NOT BE COVERED BY YOUR BOARD OR SYSTEM MANUFACTURER'S WARRANTY.
              Please use this utility with caution.
              
    Unable to write to sysfs file /sys/class/drm/card1/device/pp_od_clk_voltage
    WARNING: IO or OS error
    ERROR: GPU[1] 		: Unable to set sclk clock to Level s 1 1300 810
    
              ******WARNING******
    
              Operating your AMD GPU outside of official AMD specifications or outside of
              factory settings, including but not limited to the conducting of overclocking,
              over-volting or under-volting (including use of this interface software,
              even if such software has been directly or indirectly provided by AMD or otherwise
              affiliated in any way with AMD), may cause damage to your AMD GPU, system components
              and/or result in system failure, as well as cause other problems.
              DAMAGES CAUSED BY USE OF YOUR AMD GPU OUTSIDE OF OFFICIAL AMD SPECIFICATIONS OR
              OUTSIDE OF FACTORY SETTINGS ARE NOT COVERED UNDER ANY AMD PRODUCT WARRANTY AND
              MAY NOT BE COVERED BY YOUR BOARD OR SYSTEM MANUFACTURER'S WARRANTY.
              Please use this utility with caution.
              
    GPU[0] 		: Successfully set GPU memory clock frequency mask to Level m 1 830 810
    
              ******WARNING******
    
              Operating your AMD GPU outside of official AMD specifications or outside of
              factory settings, including but not limited to the conducting of overclocking,
              over-volting or under-volting (including use of this interface software,
              even if such software has been directly or indirectly provided by AMD or otherwise
              affiliated in any way with AMD), may cause damage to your AMD GPU, system components
              and/or result in system failure, as well as cause other problems.
              DAMAGES CAUSED BY USE OF YOUR AMD GPU OUTSIDE OF OFFICIAL AMD SPECIFICATIONS OR
              OUTSIDE OF FACTORY SETTINGS ARE NOT COVERED UNDER ANY AMD PRODUCT WARRANTY AND
              MAY NOT BE COVERED BY YOUR BOARD OR SYSTEM MANUFACTURER'S WARRANTY.
              Please use this utility with caution.
              
    GPU[1] 		: Successfully set GPU memory clock frequency mask to Level m 1 830 810
    ================================================================================
    GPU[0] 		: Successfully set current Performance Level to manual
    GPU[1] 		: Successfully set current Performance Level to manual
    ================================================================================
    WARNING: One or more commands failed
    ==============================End of ROCm SMI Log ==============================
    

    Interesting is that if I do not use -d it write to both GPUs.

    But if I check the table with rocm-smi --showclkvolt it looks like the core clock have been accepted, that also look like the case when I start the miner and 1300 is reported in minerfarm.

    [/root]:# rocm-smi --showclkvolt
    
    
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: OD_SCLK:
    GPU[0] 		: 0: 800Mhz
    GPU[0] 		: 1: 1300Mhz
    GPU[0] 		: OD_MCLK:
    GPU[0] 		: 1: 830MHz
    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 708mV
    GPU[0] 		: 1: 1290MHz @ 758mV
    GPU[0] 		: 2: 1780MHz @ 979mV
    GPU[0] 		: OD_RANGE:
    GPU[0] 		: SCLK:     800Mhz       1820Mhz
    GPU[0] 		: MCLK:     625Mhz        930Mhz
    GPU[0] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[1] 		: OD_SCLK:
    GPU[1] 		: 0: 800Mhz
    GPU[1] 		: 1: 1300Mhz
    GPU[1] 		: OD_MCLK:
    GPU[1] 		: 1: 830MHz
    GPU[1] 		: OD_VDDC_CURVE:
    GPU[1] 		: 0: 800MHz @ 706mV
    GPU[1] 		: 1: 1290MHz @ 749mV
    GPU[1] 		: 2: 1780MHz @ 965mV
    GPU[1] 		: OD_RANGE:
    GPU[1] 		: SCLK:     800Mhz       1820Mhz
    GPU[1] 		: MCLK:     625Mhz        930Mhz
    GPU[1] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    

    But when I start the miner and take a look at the core voltage it looks like it not have been set to 810.

    [/root]:# rocm-smi --showvoltage
    
    
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: Voltage (mV): 775
    GPU[1] 		: Voltage (mV): 775
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    

    At start minerfarm report core 1300 and mem 830. Start mining at 36.2 Mh/s, significant lower then 40,0 I get in win pretests.

    After a few min mining speed drop to under 20 Mh/s.

    Rebot rigg and try to set voltage with phoenixminer flag.

    That looks like it worked!

    
    
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: Voltage (mV): 806
    GPU[1] 		: Voltage (mV): 806
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    

    But after a few minutes has drop under 20 Mh/s and voltage drop as well.

    [/root]:# rocm-smi --showvoltage
    
    
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: Voltage (mV): 793
    GPU[1] 		: Voltage (mV): 793
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    

    I suspect it can have to do with

    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 708mV
    GPU[0] 		: 1: 1290MHz @ 758mV
    GPU[0] 		: 2: 1780MHz @ 979mV
    

    That due to my low core clock 1300 it automatical set voltage very low 758 mV and mining crash.

    Will try later on.

    Long post, and bad English, but I hope it can help to spread som light over rocm-smi.

    Thank you and happy mining!


    Sep 14, 2020

    GPU: Two, Sapphire RX 5600 XT Pulse 6GB
    GPU core voltage I set with phoenixminer flag in miner config file.
    Miner: Phoenix Miner 5.1c Linux/gcc

    I could successfully set sclk and mclk mask like this.

    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Successfully set sclk frequency mask to Level 2
    GPU[1] 		: Successfully set sclk frequency mask to Level 2
    GPU[0] 		: Successfully set mclk frequency mask to Level 3
    GPU[1] 		: Successfully set mclk frequency mask to Level 3
    ================================================================================
    GPU[0] 		: Successfully set current Performance Level to high
    GPU[1] 		: Successfully set current Performance Level to high
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    

    That I think show that rocm-smi -s show correct P-States.

    [/root]:# rocm-smi -s
    
    
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 1085Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz 
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 830Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 800Mhz 
    GPU[0] 		: 2: 1300Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 1085Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz 
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 830Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 800Mhz 
    GPU[1] 		: 2: 1300Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz *
    GPU[1] 		: 
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    

    and rocm-smi -S the wrong one.

    [/root]:# rocm-smi -S
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: OD_SCLK:
    GPU[0] 		: 0: 800Mhz
    GPU[0] 		: 1: 1300Mhz
    GPU[0] 		: OD_MCLK:
    GPU[0] 		: 1: 830MHz
    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 708mV
    GPU[0] 		: 1: 1290MHz @ 760mV
    GPU[0] 		: 2: 1780MHz @ 983mV
    GPU[0] 		: OD_RANGE:
    GPU[0] 		: SCLK:     800Mhz       1820Mhz
    GPU[0] 		: MCLK:     625Mhz        930Mhz
    GPU[0] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[1] 		: OD_SCLK:
    GPU[1] 		: 0: 800Mhz
    GPU[1] 		: 1: 1300Mhz
    GPU[1] 		: OD_MCLK:
    GPU[1] 		: 1: 830MHz
    GPU[1] 		: OD_VDDC_CURVE:
    GPU[1] 		: 0: 800MHz @ 705mV
    GPU[1] 		: 1: 1290MHz @ 753mV
    GPU[1] 		: 2: 1780MHz @ 972mV
    GPU[1] 		: OD_RANGE:
    GPU[1] 		: SCLK:     800Mhz       1820Mhz
    GPU[1] 		: MCLK:     625Mhz        930Mhz
    GPU[1] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    

    above there is no P-State with sclk level 2 and no P-State with mclk level 3.

    I managed to get it running rather stable using.

    [/root]:# rocm-smi --autorespond Y --setperflevel manual --setsclk 2 --setmclk 1

    That should use P-State 2 for SCLK, and P-State 1 for MCLK.
    Looks like it works as expected.

    But hashrate very, very slow, understandable when mem only 500Mhz (1500)

    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz 
    GPU[0] 		: 1: 500Mhz *
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 830Mhz 
    

    Then I try to change the P-State leval for the memory.

    [/root]:# rocm-smi --autorespond Y --setperflevel manual --setsclk 2 --setmclk 3

    Hovever this setting give problem with P-State for the SCLK that fall down to P-State 1 from P-State 2.

    Summary: core clock jumping down a P-State. P-States reported by rocm-smi -s looks like the correct one not the one from rocm-smi -S. Or I have misunderstood what it is.

    To be continued.



  • Beta Team

    Did some more testing 2020-09-15.

    GPU: Two, Sapphire RX 5600 XT Pulse 6GB
    GPU core voltage I set with phoenixminer flag in miner config file, 810 mV.
    Miner: Phoenix Miner 5.1c Linux/gcc

    Started with setting the performance level to manual. Give the commands individual after advice from DocDrydenn writing about rocm-smi ROCM-SMI - AMD Tool

    [/root]:# rocm-smi -d 0 --setperflevel manual
    ========================ROCm System Management Interface========================
    GPU[0] 		: Successfully set current Performance Level to manual
    ==============================End of ROCm SMI Log ==============================
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:37 AM][Uptime: 0d 0:03][root@pimp3(192.168.10.161)]
    [/root]:# rocm-smi -d 1 --setperflevel manual
    ========================ROCm System Management Interface========================
    GPU[1] 		: Successfully set current Performance Level to manual
    ==============================End of ROCm SMI Log ==============================
    

    Then take a look at P-states.

    [/root]:# rocm-smi -S
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: OD_SCLK:
    GPU[0] 		: 0: 800Mhz
    GPU[0] 		: 1: 1780Mhz
    GPU[0] 		: OD_MCLK:
    GPU[0] 		: 1: 875MHz
    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 707mV
    GPU[0] 		: 1: 1290MHz @ 759mV
    GPU[0] 		: 2: 1780MHz @ 983mV
    GPU[0] 		: OD_RANGE:
    GPU[0] 		: SCLK:     800Mhz       1820Mhz
    GPU[0] 		: MCLK:     625Mhz        930Mhz
    GPU[0] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[1] 		: OD_SCLK:
    GPU[1] 		: 0: 800Mhz
    GPU[1] 		: 1: 1780Mhz
    GPU[1] 		: OD_MCLK:
    GPU[1] 		: 1: 875MHz
    GPU[1] 		: OD_VDDC_CURVE:
    GPU[1] 		: 0: 800MHz @ 705mV
    GPU[1] 		: 1: 1290MHz @ 752mV
    GPU[1] 		: 2: 1780MHz @ 969mV
    GPU[1] 		: OD_RANGE:
    GPU[1] 		: SCLK:     800Mhz       1820Mhz
    GPU[1] 		: MCLK:     625Mhz        930Mhz
    GPU[1] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV 
    ==============================End of ROCm SMI Log ==============================
    

    Change the setting for core P-State 1 and mem P-state 1, then show the result.
    Goal to set core to 1300 Mhz and mem to 810 ( 1810? ).

    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:38 AM][Uptime: 0d 0:04][root@pimp3(192.168.10.161)]
    [/root]:# echo "s 1 1300" > /sys/class/drm/card0/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:43 AM][Uptime: 0d 0:09][root@pimp3(192.168.10.161)]
    [/root]:# echo "s 1 1300" > /sys/class/drm/card1/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:43 AM][Uptime: 0d 0:09][root@pimp3(192.168.10.161)]
    [/root]:# echo "m 1 810" > /sys/class/drm/card0/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:44 AM][Uptime: 0d 0:10][root@pimp3(192.168.10.161)]
    [/root]:# echo "m 1 810" > /sys/class/drm/card1/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:44 AM][Uptime: 0d 0:10][root@pimp3(192.168.10.161)]
    [/root]:# echo "c" > /sys/class/drm/card0/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:44 AM][Uptime: 0d 0:10][root@pimp3(192.168.10.161)]
    [/root]:# echo "c" > /sys/class/drm/card1/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:44 AM][Uptime: 0d 0:10][root@pimp3(192.168.10.161)]
    [/root]:# rocm-smi -S
    
    
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: OD_SCLK:
    GPU[0] 		: 0: 800Mhz
    GPU[0] 		: 1: 1300Mhz
    GPU[0] 		: OD_MCLK:
    GPU[0] 		: 1: 810MHz
    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 707mV
    GPU[0] 		: 1: 1290MHz @ 759mV
    GPU[0] 		: 2: 1780MHz @ 983mV
    GPU[0] 		: OD_RANGE:
    GPU[0] 		: SCLK:     800Mhz       1820Mhz
    GPU[0] 		: MCLK:     625Mhz        930Mhz
    GPU[0] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[1] 		: OD_SCLK:
    GPU[1] 		: 0: 800Mhz
    GPU[1] 		: 1: 1300Mhz
    GPU[1] 		: OD_MCLK:
    GPU[1] 		: 1: 810MHz
    GPU[1] 		: OD_VDDC_CURVE:
    GPU[1] 		: 0: 800MHz @ 705mV
    GPU[1] 		: 1: 1290MHz @ 752mV
    GPU[1] 		: 2: 1780MHz @ 969mV
    GPU[1] 		: OD_RANGE:
    GPU[1] 		: SCLK:     800Mhz       1820Mhz
    GPU[1] 		: MCLK:     625Mhz        930Mhz
    GPU[1] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:46 AM][Uptime: 0d 0:12][root@pimp3(192.168.10.161)]
    [/root]:#
    

    Looks OK.

    Start mining as see what happen. Voltage is set as flag in PhoenixMiner.

    Before start.

    [/root]:# rocm-smi -s
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz *
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 810Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 800Mhz *
    GPU[0] 		: 2: 1300Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz *
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 810Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 800Mhz *
    GPU[1] 		: 2: 1300Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    ==============================End of ROCm SMI Log ==============================
    

    Indicated by * sclk is in P-state 1 800 Mhz mckl is in P-state 0 100 Mhz

    Miner started

    [/root]:# rocm-smi -s
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz 
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 810Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 800Mhz 
    GPU[0] 		: 2: 1300Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz *
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz 
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 810Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 800Mhz 
    GPU[1] 		: 2: 1300Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz *
    GPU[1] 		: 
    ==============================End of ROCm SMI Log ==============================
    [Agent: R52308 (Running) Total HR: [60.90Mh/s] Miners running [1] GPUs [AA]]
    [06:50 AM][Uptime: 0d 0:16][root@pimp3(192.168.10.161)]
    [/root]:# rocm-smi --showvoltage
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Voltage (mV): 806
    GPU[1] 		: Voltage (mV): 806
    ==============================End of ROCm SMI Log ==============================
    [Agent: R52308 (Running) Total HR: [70.70Mh/s] Miners running [1] GPUs [AA]]
    [06:50 AM][Uptime: 0d 0:16][root@pimp3(192.168.10.161)]
    [/root]:# 
    

    Looks OK, hasing at 35 MH/s core 1300 mem 810, Power 98 watts. Core V 806 mV

    However after a few minutes the miner crash! :-(

    Take a look at the P-states and voltage.

    [/root]:# rocm-smi -s && rocm-smi --showvoltage
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 844Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz 
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 810Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 520Mhz *
    GPU[0] 		: 2: 1300Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 844Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 844Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz 
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 810Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 525Mhz *
    GPU[1] 		: 2: 1300Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 844Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    ==============================End of ROCm SMI Log ==============================
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Voltage (mV): 793
    GPU[1] 		: Voltage (mV): 793
    ==============================End of ROCm SMI Log ==============================
    

    Not good, it have drope a P-state.

    Try to lock to high powerstate.

    /root]:# rocm-smi -d 0 --setsclk 2 --setmclk 3
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Successfully set sclk frequency mask to Level 2
    GPU[0] 		: Successfully set mclk frequency mask to Level 3
    ==============================End of ROCm SMI Log ==============================
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [06:58 AM][Uptime: 0d 0:24][root@pimp3(192.168.10.161)]
    [/root]:# rocm-smi -d 1 --setsclk 2 --setmclk 3
    
    
    ========================ROCm System Management Interface========================
    GPU[1] 		: Successfully set sclk frequency mask to Level 2
    GPU[1] 		: Successfully set mclk frequency mask to Level 3
    ==============================End of ROCm SMI Log ==============================
    

    Before starting the miner.

    [/root]:# rocm-smi -s && rocm-smi
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 844Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz 
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 810Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 800Mhz 
    GPU[0] 		: 2: 1300Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 844Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 844Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz 
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 810Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 800Mhz 
    GPU[1] 		: 2: 1300Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 844Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    ==============================End of ROCm SMI Log ==============================
    

    Start mining and se what happen

    [/root]:# rocm-smi -s && rocm-smi --showvoltage
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 1085Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz 
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 810Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 800Mhz 
    GPU[0] 		: 2: 1300Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 1085Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 1085Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz 
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 810Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 800Mhz 
    GPU[1] 		: 2: 1300Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 1085Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    ==============================End of ROCm SMI Log ==============================
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Voltage (mV): 806
    GPU[1] 		: Voltage (mV): 806
    ==============================End of ROCm SMI Log ==============================
    [Agent: R52308 (Running) Total HR: [70.69Mh/s] Miners running [1] GPUs [AA]]
    [07:03 AM][Uptime: 0d 0:29][root@pimp3(192.168.10.161)]
    [/root]:# rocm-smi -s && rocm-smi --showvoltage
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz 
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 810Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 845Mhz *
    GPU[0] 		: 2: 1300Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz *
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 1085Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz 
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 810Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 805Mhz *
    GPU[1] 		: 2: 1300Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 1085Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    ==============================End of ROCm SMI Log ==============================
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Voltage (mV): 793
    GPU[1] 		: Voltage (mV): 793
    ==============================End of ROCm SMI Log ==============================
    [Agent: R52308 (Running) Total HR: [70.69Mh/s] Miners running [1] GPUs [AA]]
    [07:03 AM][Uptime: 0d 0:30][root@pimp3(192.168.10.161)]
    [/root]:# 
    

    Start OK, but after just a minute or so core clock jump down to P-State 2 and mining chrashes.

    For some reason the core and mem cloxk were back to default, set new
    [/root]:# rocm-smi -S

    ========================ROCm System Management Interface========================
    GPU[0] 		: OD_SCLK:
    GPU[0] 		: 0: 800Mhz
    GPU[0] 		: 1: 1780Mhz
    GPU[0] 		: OD_MCLK:
    GPU[0] 		: 1: 875MHz
    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 707mV
    GPU[0] 		: 1: 1290MHz @ 759mV
    GPU[0] 		: 2: 1780MHz @ 983mV
    GPU[0] 		: OD_RANGE:
    GPU[0] 		: SCLK:     800Mhz       1820Mhz
    GPU[0] 		: MCLK:     625Mhz        930Mhz
    GPU[0] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[1] 		: OD_SCLK:
    GPU[1] 		: 0: 800Mhz
    GPU[1] 		: 1: 1780Mhz
    GPU[1] 		: OD_MCLK:
    GPU[1] 		: 1: 875MHz
    GPU[1] 		: OD_VDDC_CURVE:
    GPU[1] 		: 0: 800MHz @ 705mV
    GPU[1] 		: 1: 1290MHz @ 752mV
    GPU[1] 		: 2: 1780MHz @ 969mV
    GPU[1] 		: OD_RANGE:
    GPU[1] 		: SCLK:     800Mhz       1820Mhz
    GPU[1] 		: MCLK:     625Mhz        930Mhz
    GPU[1] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    ==============================End of ROCm SMI Log ==============================
    

    Set the clocks again

    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [07:11 AM][Uptime: 0d 0:37][root@pimp3(192.168.10.161)]
    [/root]:# echo "s 1 1300" > /sys/class/drm/card0/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [07:11 AM][Uptime: 0d 0:38][root@pimp3(192.168.10.161)]
    [/root]:# echo "s 1 1300" > /sys/class/drm/card1/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [07:11 AM][Uptime: 0d 0:38][root@pimp3(192.168.10.161)]
    [/root]:# echo "m 1 810" > /sys/class/drm/card0/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [07:12 AM][Uptime: 0d 0:38][root@pimp3(192.168.10.161)]
    [/root]:# echo "m 1 810" > /sys/class/drm/card1/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [07:12 AM][Uptime: 0d 0:38][root@pimp3(192.168.10.161)]
    [/root]:# echo "c" > /sys/class/drm/card0/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [07:12 AM][Uptime: 0d 0:38][root@pimp3(192.168.10.161)]
    [/root]:# echo "c" > /sys/class/drm/card1/device/pp_od_clk_voltage 
    [Agent: R52308 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]
    [07:12 AM][Uptime: 0d 0:38][root@pimp3(192.168.10.161)]
    [/root]:# rocm-smi -S
    

    Check so that the clocks for core and mem are set.

    ========================ROCm System Management Interface========================
    GPU[0] 		: OD_SCLK:
    GPU[0] 		: 0: 800Mhz
    GPU[0] 		: 1: 1300Mhz
    GPU[0] 		: OD_MCLK:
    GPU[0] 		: 1: 810MHz
    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 707mV
    GPU[0] 		: 1: 1290MHz @ 759mV
    GPU[0] 		: 2: 1780MHz @ 983mV
    GPU[0] 		: OD_RANGE:
    GPU[0] 		: SCLK:     800Mhz       1820Mhz
    GPU[0] 		: MCLK:     625Mhz        930Mhz
    GPU[0] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[1] 		: OD_SCLK:
    GPU[1] 		: 0: 800Mhz
    GPU[1] 		: 1: 1300Mhz
    GPU[1] 		: OD_MCLK:
    GPU[1] 		: 1: 810MHz
    GPU[1] 		: OD_VDDC_CURVE:
    GPU[1] 		: 0: 800MHz @ 705mV
    GPU[1] 		: 1: 1290MHz @ 752mV
    GPU[1] 		: 2: 1780MHz @ 969mV
    GPU[1] 		: OD_RANGE:
    GPU[1] 		: SCLK:     800Mhz       1820Mhz
    GPU[1] 		: MCLK:     625Mhz        930Mhz
    GPU[1] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    ==============================End of ROCm SMI Log ==============================
    

    Trying to set the voltage cureve in an attempt to prevent it from dropping P-state.

    Set the OD_VDDC_CURVE:

    rocm-smi -d 0 --setvc 0 800 800
    rocm-smi -d 0 --setvc 1 1050 805
    rocm-smi -d 0 --setvc 2 1300 810
    rocm-smi -d 1 --setvc 0 800 800
    rocm-smi -d 1 --setvc 1 1050 805
    rocm-smi -d 1 --setvc 2 1300 810
    
    [/root]:# rocm-smi -S
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: OD_SCLK:
    GPU[0] 		: 0: 800Mhz
    GPU[0] 		: 1: 1300Mhz
    GPU[0] 		: OD_MCLK:
    GPU[0] 		: 1: 810MHz
    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 800mV
    GPU[0] 		: 1: 1050MHz @ 805mV
    GPU[0] 		: 2: 1300MHz @ 810mV
    GPU[0] 		: OD_RANGE:
    GPU[0] 		: SCLK:     800Mhz       1820Mhz
    GPU[0] 		: MCLK:     625Mhz        930Mhz
    GPU[0] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[1] 		: OD_SCLK:
    GPU[1] 		: 0: 800Mhz
    GPU[1] 		: 1: 1300Mhz
    GPU[1] 		: OD_MCLK:
    GPU[1] 		: 1: 810MHz
    GPU[1] 		: OD_VDDC_CURVE:
    GPU[1] 		: 0: 800MHz @ 800mV
    GPU[1] 		: 1: 1050MHz @ 805mV
    GPU[1] 		: 2: 1300MHz @ 810mV
    GPU[1] 		: OD_RANGE:
    GPU[1] 		: SCLK:     800Mhz       1820Mhz
    GPU[1] 		: MCLK:     625Mhz        930Mhz
    GPU[1] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    ==============================End of ROCm SMI Log ==============================
    

    before Start mining.

    [/root]:# rocm-smi -s
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz *
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 810Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 800Mhz *
    GPU[0] 		: 2: 1300Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz *
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 810Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz *
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 800Mhz *
    GPU[1] 		: 2: 1300Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    ==============================End of ROCm SMI Log ==============================
    

    start miner

    [/root]:# rocm-smi -s && rocm-smi --showvoltage
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz 
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 810Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 800Mhz 
    GPU[0] 		: 2: 1300Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz *
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz 
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 810Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 800Mhz 
    GPU[1] 		: 2: 1300Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz *
    GPU[1] 		: 
    ==============================End of ROCm SMI Log ==============================
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Voltage (mV): 812
    GPU[1] 		: Voltage (mV): 806
    ==============================End of ROCm SMI Log ==============================
    

    Looks OK at start. 13:21

    Chrash!!!!!!!!!!!!!!!! no god. After 3 minutes.

    [/root]:# rocm-smi -s && rocm-smi --showvoltage
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Supported dcefclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz *
    GPU[0] 		: 1: 886Mhz 
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported fclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 844Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported mclk frequencies on GPU0
    GPU[0] 		: 0: 100Mhz 
    GPU[0] 		: 1: 500Mhz 
    GPU[0] 		: 2: 625Mhz 
    GPU[0] 		: 3: 810Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported pcie frequencies on GPU0
    GPU[0] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[0] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[0] 		: 
    GPU[0] 		: Supported sclk frequencies on GPU0
    GPU[0] 		: 0: 300Mhz 
    GPU[0] 		: 1: 515Mhz *
    GPU[0] 		: 2: 1300Mhz 
    GPU[0] 		: 
    GPU[0] 		: Supported socclk frequencies on GPU0
    GPU[0] 		: 0: 506Mhz 
    GPU[0] 		: 1: 844Mhz *
    GPU[0] 		: 2: 1266Mhz 
    GPU[0] 		: 
    GPU[1] 		: Supported dcefclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz *
    GPU[1] 		: 1: 886Mhz 
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported fclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 844Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported mclk frequencies on GPU1
    GPU[1] 		: 0: 100Mhz 
    GPU[1] 		: 1: 500Mhz 
    GPU[1] 		: 2: 625Mhz 
    GPU[1] 		: 3: 810Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported pcie frequencies on GPU1
    GPU[1] 		: 0: 2.5GT/s, x1 81Mhz 
    GPU[1] 		: 1: 5.0GT/s, x1 619Mhz *
    GPU[1] 		: 
    GPU[1] 		: Supported sclk frequencies on GPU1
    GPU[1] 		: 0: 300Mhz 
    GPU[1] 		: 1: 555Mhz *
    GPU[1] 		: 2: 1300Mhz 
    GPU[1] 		: 
    GPU[1] 		: Supported socclk frequencies on GPU1
    GPU[1] 		: 0: 506Mhz 
    GPU[1] 		: 1: 844Mhz *
    GPU[1] 		: 2: 1266Mhz 
    GPU[1] 		: 
    ==============================End of ROCm SMI Log ==============================
    
    
    ========================ROCm System Management Interface========================
    GPU[0] 		: Voltage (mV): 793
    GPU[1] 		: Voltage (mV): 793
    ==============================End of ROCm SMI Log ==============================
    

  • Staff

    You can't test with variables all over the place. You're mixing and matching miner flags and rocm settings... maybe even gputool settings.

    Before you start messing around with clocks and voltages, you need to verify the GPU can mine at stock settings.

    1. Disable gputool command from /root/startup.sh (and the pimp --start 1 command as well)
    2. Remove any and all GPU settings flags from the miner config file (including any fan settings)
    3. Reboot (this will ensure your GPU will be 100% stock)
    4. Test miner for default stock stability.

    If you are unable to mine in this condition, there is almost no hope of being able to mine with any tweaks applied. If the GPU won't mine under it's own automatic BIOS control, it is very doubtful that any user changes will make it work.

    If you can mine stable (no crashes) at stock, then you can move on to the fine tuning balancing act. Don't go "balls to the wall" and change everything... Make small, single variable changes, and keeping track of what you changed and what the effects were.

    Avoid mixing tool usage (miner flags, rocm, gputool, etc...) if possible. Stick to one tool at a time. These tools have the potential of "un-doing" tasks that you may have set with a different tool... and they won't even tell you they did it.


  • Beta Team

    Thank you very much doc!
    I have given it a clean start.

    I verified that gputool as well as pimp --start 1 was disabled in /root/startup.sh so that was not the problem.
    Removed voltage flags from phoenixminer config file.

    Rebooted and restarted.

    Same thing, crash after just a few minutes.

    After dropping the whole thing for a while I thought I would try a different miner.

    BANG! that was it! with claymoredual miner and all default it run great! Took rather lot of power but it run.

    I let it run like that over night to see so it was stable. It was, it run ok for like 12 houres.
    Now it feels like I have a working baseline.

    Re-imaged the SSD with PiMP beta 2.17, to get a clean start.
    Run pimpup, updated claymoredual, miner nr10. rebooted.

    using echo "s 1 1300" > /sys/class/drm/card2/device/pp_od_clk_voltage and echo "m 1 1300" > /sys/class/drm/card2/device/pp_od_clk_voltage followed by echo "c" > /sys/class/drm/card2/device/pp_od_clk_voltage to apply the clock speed for core and mem.
    Does it for all the cards.

    In that way I could gradually take the speed up to the same as I had under win 10.

    But voltage I could not set this way.

    Voltage I had to set by altering the frequency / V curve.

    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 800mV
    GPU[0] 		: 1: 1150MHz @ 805mV
    GPU[0] 		: 2: 1550MHz @ 810mV
    

    curve above is made with following comands.
    rocm-smi -d 0 --setvc 0 800 800
    rocm-smi -d 0 --setvc 1 1150 805
    rocm-smi -d 0 --setvc 2 1550 810
    then I run echo "c" > /sys/class/drm/card2/device/pp_od_clk_voltage to apply the new values ( not sure I need ).

    Work great!

    Now it looks like this, GPU[0] is the ASUS card, GPU[1] and GPU[2] Sapphire. (with system mining.)

    ================================================================================
    GPU[0] 		: OD_SCLK:
    GPU[0] 		: 0: 800Mhz
    GPU[0] 		: 1: 1500Mhz
    GPU[0] 		: OD_MCLK:
    GPU[0] 		: 1: 820MHz
    GPU[0] 		: OD_VDDC_CURVE:
    GPU[0] 		: 0: 800MHz @ 800mV
    GPU[0] 		: 1: 1150MHz @ 805mV
    GPU[0] 		: 2: 1550MHz @ 810mV
    GPU[0] 		: OD_RANGE:
    GPU[0] 		: SCLK:     800Mhz       1820Mhz
    GPU[0] 		: MCLK:     625Mhz        930Mhz
    GPU[0] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[0] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[0] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[1] 		: OD_SCLK:
    GPU[1] 		: 0: 800Mhz
    GPU[1] 		: 1: 1300Mhz
    GPU[1] 		: OD_MCLK:
    GPU[1] 		: 1: 915MHz
    GPU[1] 		: OD_VDDC_CURVE:
    GPU[1] 		: 0: 800MHz @ 800mV
    GPU[1] 		: 1: 1050MHz @ 805mV
    GPU[1] 		: 2: 1350MHz @ 810mV
    GPU[1] 		: OD_RANGE:
    GPU[1] 		: SCLK:     800Mhz       1820Mhz
    GPU[1] 		: MCLK:     625Mhz        930Mhz
    GPU[1] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[1] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[1] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    GPU[2] 		: OD_SCLK:
    GPU[2] 		: 0: 800Mhz
    GPU[2] 		: 1: 1300Mhz
    GPU[2] 		: OD_MCLK:
    GPU[2] 		: 1: 915MHz
    GPU[2] 		: OD_VDDC_CURVE:
    GPU[2] 		: 0: 800MHz @ 800mV
    GPU[2] 		: 1: 1050MHz @ 805mV
    GPU[2] 		: 2: 1350MHz @ 810mV
    GPU[2] 		: OD_RANGE:
    GPU[2] 		: SCLK:     800Mhz       1820Mhz
    GPU[2] 		: MCLK:     625Mhz        930Mhz
    GPU[2] 		: VDDC_CURVE_SCLK[0]:     800Mhz       1820Mhz
    GPU[2] 		: VDDC_CURVE_VOLT[0]:     800mV        1050mV
    GPU[2] 		: VDDC_CURVE_SCLK[1]:     800Mhz       1820Mhz
    GPU[2] 		: VDDC_CURVE_VOLT[1]:     800mV        1050mV
    GPU[2] 		: VDDC_CURVE_SCLK[2]:     800Mhz       1820Mhz
    GPU[2] 		: VDDC_CURVE_VOLT[2]:     800mV        1050mV
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    
    
    ========================ROCm System Management Interface========================
    ================================================================================
    GPU[0] 		: Voltage (mV): 800
    GPU[1] 		: Voltage (mV): 806
    GPU[2] 		: Voltage (mV): 806
    ================================================================================
    ==============================End of ROCm SMI Log ==============================
    

    with this settings I get:
    ASUS 35.2 Mh/s @ 95 watts
    Sapphire 39.3 Mh/s @ 100 watts

    It have at the time of writing run stable for 2 hours.

    It this runs OK over night again, it remain to put it all into a start script.

    Thanks again docdrydenn for reminding how important it is to find/verify that you have a stable baseline to start from. And then not to mix a lot of variables. Stick with one thing at a time.

    Fantastic PiMP community helping!


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



© 2014-2021 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC