<- Return to getpimp.org

No GUI after 7th gpu installation

  • Hello,
    My rig boots on a start "info" screen and not the linux desktop if I install a 7th GPU independently of which pci-e slot I use or which GPU is the 7th. I need to use ALT-F2 to get a command line.
    I have followed the motherboard specific guide and the GUI works with 6 GPUs.
    Motherboard : Asrock H110 pro btc+
    CPU : G3940
    Ram : 4Gb - also tried it with 8Gb (2x4), same result
    GPUs : Saphire 5xRX580 nitro+, 2xRX580 nitro+ SE.
    Latest PiMP image with updates (>pimpup --auto) that runs of an SSD.
    Please note that in Win10 with latest AMD drivers the rig works fine.
    Any ideas/things to try?

  • If you run "top" is there an agetty process using a large % of the CPU?

  • Thanks for replying.
    Didn't check that. Will do first thing tomorrow.

  • @catch22
    Yes, it does...

  • Hmm that's interesting. My rig does the same when the GUI doesn't load. I haven't found a fix yet however knowing this seems to be a consistent problem will hopefully get us some help. If you are fine only using the terminal to interface with the rig you can press Ctrl+Alt+F2 to get into a terminal or you can just use SSH. I would recommend as a temporary fix to the 100% CPU utilization you run these commands:

    systemctl stop getty@tty1
    systemctl disable getty@tty1

    This will disable the GUI from ever loading. You can run: "systemctl enable getty@tty1" to re-enable it if there is a fix later but for right now I just disabled it so I wasn't dealing with having to kill the agetty process after every reboot.

    Hope this helps some at least. Happy mining!

  • @catch22
    Thanks for the workaround.
    Pity, I liked the desktop with the conky window (even though it doesn't anchor correctly on my 4:3 monitor).
    Guess we'll have to wait and see...

Log in to reply

Want 10% more hash from your rigs?

We promise to keep your email safe and never spam you.

Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.