Welcome to the PiMP OS and Miner.farm forum.

Can't set fan speed.



  • Trying to get Pimp up and running. I have a claymore mining profile setup which works. I can't seem to control fan speed on my rx580's though. At first when I fired up claymore the fans would all just stop and the cards would get really hot and the rig would reboot.

    I removed the fan control lines in the claymore profile. I used GPUtool and set fanspeed to "75", I set temptarget to "0" per the guide. I run gputool -- config and it says it sets the speed to 100% no matter what I change the fanspeed value to. The fan's stay at a static 38%...

    I've tried removing and re-adding the gputool profile a few times, same thing.

    Ideas?



  • In this case, it is more appropriate to use Claymore's flags:

    -tt set target GPU temperature. For example, "-tt 80" means 80C temperature. You can also specify values for every card, for example "-tt 70,80,75".
    You can also set static fan speed if you specify negative values, for example "-tt -50" sets 50% fan speed. Specify zero to disable control and hide GPU statistics.
    "-tt 1" (default) does not manage fans but shows GPU temperature and fan status every 30 seconds. Specify values 2..5 if it is too often.
    Note: for NVIDIA cards only temperature monitoring is supported, temperature management is not supported.
    Note: for Linux gpu-pro drivers, miner must have root access to manage fans, otherwise only monitoring will be available.

    -fanmax set maximal fan speed, in percents, for example, "-fanmax 80" will set maximal fans speed to 80%. You can also specify values for every card, for example "-fanmax 50,60,70".
    This option works only if miner manages cooling, i.e. when "-tt" option is used to specify target temperature. Default value is "100".
    Note: for NVIDIA cards this option is not supported.

    -fanmin set minimal fan speed, in percents, for example, "-fanmin 50" will set minimal fans speed to 50%. You can also specify values for every card, for example "-fanmin 50,60,70".
    This option works only if miner manages cooling, i.e. when "-tt" option is used to specify target temperature. Default value is "0".
    Note: for NVIDIA cards this option is not supported.



  • This post is deleted!


  • @blackice

    Thanks, I'll give it a shot!



  • ayuda tengo el mismo problema y no puedo solucionarlo


  • Staff

    @ORLANDIXTO said in Can't set fan speed.:

    ayuda tengo el mismo problema y no puedo solucionarlo

    Hello orlandixto,

    We will do our best to help you. Haremos todo lo posible para ayudarlo.

    For now: Por ahora:
    if you use gputool --config to set fans, you must remove -tt and -tstop from FLAGS=
    Puedes controlar los ventiladores desde la herramienta o desde el minero, pero no desde ambos.

    For more help: Para más ayuda:
    We have Spanish speakers on the Beta team that maybe can assist you better. Lets try to make the connection on Discord.
    Tenemos hispanohablantes en el equipo Beta. podemos encontrarnos en el chat de Discord.

    Thank you for your support orlandixto :) Gracias por su apoyo orlandixto :)


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2019 Portable Instant Mining Platform LLC. All rights Reserved.