Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Quick Links

Teamviewer 13 on PimP v2.4.1-all

  • i installed several PiMP servers using v2.4.1-all where try run teamviewer 13.0.6634 (DEB) . when i start it i get Segmentation fault (core dumped) and teamviewer GUI can't start.

    i tried do it on 3-4 servers but same result.

    here are teamviewer /var/log/teamviewer13 log files :
    teamviewer.log files are avaiaible on: http://gofile.me/2UdS2/GFtYR4tiy

    • [/root]:# /usr/bin/teamviewer /etc/teamviewer

    CheckCPU: SSE2 support: yes
    Checking setup...
    Launching TeamViewer ...
    Launching TeamViewer GUI ...
    Segmentation fault (core dumped)

    • [/root]:# teamviewer -info

    TeamViewer 13.0.6634 (DEB)

    TeamViewer ID:
    Try restarting the TeamViewer daemon (e.g. teamviewer --daemon restart)

    teamviewerd status ● teamviewerd.service - TeamViewer remote control daemon
    Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)
    Active: active (running) since Mon 2018-01-01 01:53:00 EST; 3min 33s ago
    Process: 748 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
    Main PID: 786 (teamviewerd)
    CGroup: /system.slice/teamviewerd.service
    └─786 /opt/teamviewer/tv_bin/teamviewerd -d

    Jan 01 01:52:58 pimp2 systemd[1]: Starting TeamViewer remote control daemon...
    Jan 01 01:52:59 pimp2 systemd[1]: teamviewerd.service: PID file /var/run/teamviewerd.pid not readable (yet?) after start: No such file or directory
    Jan 01 01:53:00 pimp2 systemd[1]: Started TeamViewer remote control daemon.

  • I had the same problem where Teamviewer was stating to restart the deamon. What I figured out it that you have to set the password and then restart the deamon to get the ID . Try "teamviewer --passwd newPassword" and then you will get your ID.
    After that I ran into another one where I had to accept the license however the screen has some kind of bug and doesn t display anything.
    Fix is to stop the deamon "teamviewer --daemon stop"
    Edit the global.conf file located under /opt/teamviewer/config and add these lines :
    [int32] EulaAccepted = 1
    [int32] EulaAcceptedRevision = 6
    Start the daemon again "teamviewer --daemon start"

    Last remaining issue I still haven't figured out is that now Teamviewer opens up, I can see the Pimp desktop but I can't interact with it.
    Troubleshooting still going on


  • thats cool, i repro'd your changes and only had to add the second EulaAcceptedRevision line.

    I also did teamviewer setup via shell to add my login account
    then i did a teamviewer passwd [mypass] to set the pass
    when i logged in and used the local pass i set, it worked and im able to interact with the desktop with no issues. i just cant see the toolbar with the start menu

  • Hi,
    is there an solution for the "can't intact problem" - i'm able to connect to three machines, but can't interact with on.

  • @igorkolla said in Teamviewer 13 on PimP v2.4.1-all:

    teamviewer --daemon restart)

    I am having the same problem. Were you able to figure it out?

  • Have you taken a look at this page and tried to follow the steps including step 9 where you make some edits in a file. Have you done that and did it help?


  • Staff

    Your voices were heard! pimp 2.5.1 and newer have teamviewer installed.


Want 10% more hash from your rigs?

We promise to keep your email safe and never spam you.

© 2014-2020 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC