<- Return to getpimp.org

New install no GUI / sgminer stability issues (8 RX580 on Asus Z270-P)



  • New install 2.4.1 Azus prime Z270-P with 8 x rx580's. The rig boots and sees all the cards etc. Once it gets to the IP address it just flashes a cursor below that and doesn't continue to GUI.

    I can SSH to it and ran the update commands etc, it says its all up to date.

    What next? the rig works fine on simpleminer OS so I know it's not a hardware issue. I also went back through the motherbaord guide to make sure it was all up to snuff, looks good.



  • Also forgot to add that on boot, I get tons of lines of PCIe bus receiver errors. Again, this setup works fine with other miners. BIOS on the moboard is up to date too.



  • how are you connecting the monitor? if you can shell and run miners, it's all there. are you using the integrated graphics which would need to be disabled to run your miners?



  • Got rid of the PCIE errors and got it to boot into the GUI, setup a miner etc. But, I can only get PIMP to see 6 of my 8 cards on the board. It doesn't seem to like the M.2 to PCIe cards. When I have those plugged in no GUI.... Anyone have a solution for that? I have the M.2 to PCIE set static to PCIE mode.



  • Well ... After spending a majority of 3 full days trying to get PIMP to run, I gave up and went back to Simplemining OS. I could never get 8 RX580's on the Asus Z270-P to work. Only 6 and it would boot into the GUI. All 8, no GUI, it would just stop after getting a IP, SSH still worked. I could get mining profiles setup VIA SSH with 6 or 8 cards but it would lock up randomly. I was getting a AMDGPU driver PCI error on boot too, maybe that's part of the whole issue but I'm tired of digging through the forums and discord support has been of no help.

    Fan control also would not work for me. I followed the overclocking guide to a "T" using gputool and never could control fan speed. Temp target set to "0" and fanspeed set to "75". gputool --update and they would all report " set to 100%" with no actual change. I also removed the claymore flags as in the guide, no change.

    I really wanted PIMP to work out! maybe if support can address some of these issues I'll give it another shot.



  • Also, quick side note. I did follow the "setting up your motherboard guide for mining". This same rig runs fine in other OS's.


  • Support

    Try to reset the BIOS and change all settings again. https://forum.getpimp.org/topic/9/setting-up-motherboards-for-mining



  • If you run "top" do you happen to have an agetty process using nearly 100% CPU?



  • Any chance before you bail completely I can help you and maybe you can help me? I have 8 RX 580s successfully running on an ASUS H270 board and don't have fan issues the way I have gone about it.

    Let me say this though. I do have the exact same issue with the GUI. The damn thing does not work at all with 8 cards. However I may be on to something with that not 100% certain yet. Planning to test tonight.

    So my first question would by why are you using claymore? Are you trying to dual mine? If not ditch claymore. The dev fee is dumb and even dual mining really isn't that profitable. Now if you ditch claymore you enter the lovely world of SGMiner :D. We will come back to this in a second. So next thing to address, are you using GPUTool just to set fan speeds or are you doing overclocks with it as well? If you are doing overclocks with it please stop and take the time to modify your bios with the clocks you want. Its much more stable and much less of an hassle. So this leaves us with a new miner and still no control over the fan speeds.

    SGMiner should fix all these problems including stability. So if you run "nano /opt/confs/sgminer.eth.conf" as root you will see the default config PiMP has. Using the default as a template (I recommend just coping it and editing it "cp /opt/confs/sgminer.eth.conf /opt/confs/sgminer.my.eth.conf") you can tweak for your specific application. So update the config with your pool(s) and wallet address. Then if you scroll down there is a section that will allow you to configure thermal limits and fan speeds! Hurray another problem solved!

    Once you have done that there is plenty of documentation to get you the rest of the way. I'll keep you posted if I can fix the GUI issue but if you could do me a favor and see if your rig has 100% CPU utilization from an "agetty" process that would be awesome!

    Happy new year!


  • Staff

    @Catch22 Thank you friend for this great post, you are a true miner and we are glad to have you in our community. Hope to see you in the discord chat. Also, your miner.farm account has been raised to the Pro level for a month. Check out the email alerts and remote reboot capability. Hope that you like this.

    That being said, I have a few rigs where after 5 or more GPU then it did not output video, but I run them headless. You can access GUI via RDP if you like, but I mostly use minerfarm and SSH only. Hope this helps!

    (Merged duplicate topics)



  • Thank you very much @melt! I really appreciate it! Can't wait to see the full features the system has to offer. I know how frustrating it can be to set up hardware when things aren't working so if I can reduce that for someone I'm happy. I'll get the discord chat set up on my phone later today so maybe I can offer a hand there as well.

    P.S. I run my rigs headless as well so most of the time I don't care but that agetty process that maxes my CPU out when the GUI doesn't start bugs me. For right now I just kill it and continue on but that's what is motivating me to try to find a fix haha



  • @catch22

    Thanks for the awesome post. After cooling off for a day, I'll try and make time this week to fire it back up and check the processes. I was so damn frustrated last weekend I had to walk away yesterday.

    I do dual mine Eth and DEC on claymore. It was the one I was familiar with so I went with it on PIMP also. I will check out SGMiner though. I don't have to dual mine, I just did because, well, I could.

    The cards are BIOS modded and pull in 30MHs, so all I really need to do is set fan speed. I also need something stable as 6 of my rigs I'm building next week will be remote.

    Like I've said in my other posts. I love the idea of PIMP. I was just frustrated about the GUI, Fan and lockup issues.



  • @jeff

    Not a problem! Keep me posted and if you have discord we can find each other so maybe when you start messing with it I can give live support. I think PiMP can do exactly what you want and then some. Sounds like you are on the right track at least!

    Cheers!


Log in to reply
 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Support Forum was lost, please wait while we try to reconnect.