Welcome to the PiMP OS and Miner.farm forum.

Things to try when gputool --config throws errors or wont set the clocks


  • Staff

    "they mine just fine. it just wont let me adjust the clock speeds"

    You may have already tried this, but this is one solution that worked for me, start off with one riser and a 1060 gpu plugged in, then see if by running “gputool status” then error goes away. If the error go away, then plug the next 1060 gpu and check again. If all works' then plug in your 580's one at a time, and check again. Another option that worked for me is, If you have a spare ssd, and time of course, might be worth re-imaging to 2.8.6, once key validated and PiMP OS running, don’t update the pimp OS version to latest or run “apt update” nor “apt upgrade”, keep everything to default, then run “gputool —status”, and see if all gpu’s and their current settings are displayed, if not try with again just one 1060 gpu plugged in. Hope this helps, and let us known how you get on.

    My next thought as a fellow mixed rig user, is are you using in the BIOS settings Gen1 or Gen2, reason being is I had some issues using Gen2 and known for my mixed 1070/570 rig it prefered Gen1.

    Lastly, once the error is resolved, might be worth looking at phoenixminer.pcfg, as it has 0.65% dev fee, and although it's a "copy" of claymore.dual in many ways, has some performance improvements, and allows miner.farm to display more of the states apart from Power watts, which is being looked at by the dev team. Also, once "gputool --status" displays the AMD GPU states, might be worth using the default "gputool --config" values for the AMD GPU", just in case your own modified values, cause an issue with gputool, might not but trying to cover all bases. Again let us know how you get on, and your not alone :smiley:

    You could also try removing the current "gpu-config.json" file by running command "rm gpu-config.json", and then re-creating the file by running command "gputool --config". Then once the new "gpu-config.json" file is created, commit it by running again "gputool --config", and see whether the default values for your 1060's are applied without error's like they currently being displayed without any errors for your 3 580's.

    gputool --reset will also regenerate a new gpu-config.json.


    Credit: Louis, PIMP OS Support Team


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2018 PiMP LLC. All rights Reserved.