<- Return to getpimp.org

Trouble with install AFTER putting my Validation key in.

  • Hi all,

    First let me say im new here so a big HELLO to people. Appologies if this is in wrong section.

    Im versed in linux and have a decent understanding of debian. I was mining back in 2010 and came back recently as NiceHash made things 'easy'. Well.... We all know about that now so have been trying get Claymore working under 10+ linux's. I've had Ethminer working and claymores ZCash miner (v12) but never got 9/10 mining eth due to segmentation error. So... I bit the bullet!

    I purchased PIMP as the devs have a good track record. I've been able to put it onto an SSD and booted into PIMP. It loads the screen and asks for Key.

    I've put the key in and then it reboots and It loads and shows:

    amdgpu 0000:1:00.0: Invaled PCI ROM signiture: expected 0xaa55, got 0xffff

    for about 5-10 seconds. then something else shows but pause/break does not stop it or slow it so i can not read what it says.

    The screen then goes black and then the monitor says NO CONNECTION and goes in standby mode.

    CTRL + ALT +Delete does not work but the keyboard still works (caps lock etc) so it has not pooped a brick but its hung.

    I've gone through all the Motherboard settings and they are all correct.

    I'm using a Gigabyte GA-H110-G3A Mining motherboard with 6x AMD RX580's already firmware modded and confirmed all working fine. All with USB Risers.

    PSU is a EVGA 1600W (overkill)

    Kingston 120GB SSD

    Not sure if anything else is relivent/needed.

    Thanks in advance

  • Oh yes, Monitor is

    BenQ BL2420-T 1440p Monitor but im sure thats not the issue here and its drivers.

    1 Curious question, Are the new 17.5 (or 4...) drivers with Pimp 2.4.1?


  • Yes it should work with that setup please read "setting up motherboards" also see if you can simplify the rig by boot off one or two GPU first and then add. This will help you find bad riser/cable/etc and/or problem. Thanks

  • Also, Make sure you reimage and clean eject, and SSH the key in: https://forum.getpimp.org/topic/268/can-not-validate-license-key/7 and https://forum.getpimp.org/topic/14/entering-the-key-for-the-first-boot
    PiMP Support Forum

  • Hi, Thanks for the reply.

    I've managed to get to the Pimp screen and add the Activation key. It takes a moment then says 'Rebooting system into verified mode'. Tried it wil all 6 GPU's individually and all yield same failed boot result. These cards have been mining zcash and using ethminer just fine on ubuntu server 16.04 (nicehash on win10 too) but could not get claymore work. Underclocking was a pain to sort out so ended up paying for this only to find i can't even load the OS up.

    The problem happens after that autherisation reboot. I've used it enough to know the settings are fine in the bios (although i have tried a million combinations now with same result) and it seems to lock up very shortly after boot. As i say, the only bit of information i can possibly read in time is the above error which is a AMDGPU error.

    I've got to say, this program is by no means EASY by any stretch of the imagination. I know why 'noobs' get stuck at the installation which should be simple. This is not for everyone, thats for sure.

    Alas, Im a persistent person and want to get this to work for ease of use but it wont even boot into authorized mode. There is not much else i can fiddle with, I've tried everything. I even have my friend here who is extremely technical but the way you do things make it impossible to even look/check anything to fix. It just locks up as soon as it boots after its verified, its NOT a verification issue as it pass's no issues there.

    Stumped at the moment, Do not know what else to try :(

  • Staff

    Have you insured your onboard video is off? As well, can you ssh into the system?

  • Hi,

    I can get in SSH. After running 'helpme' i got this result.


    Thanks for the help, Appreciated

  • Staff

    Are you running a stock BIOS? The messages seem to indicate perhaps not? Can you dump the bios and attach it? Do:

    atiflash -s 0 bios0.rom
    /opt/pimp/go/bin/atitool show bios0.rom

    And cut and paste the output into a reply here.

  • I can not copy and paste so going write it....


    SubVendorID: 0x1462
    Firmware signature: 0x4d4f5441

    Im hoping thats all you need. Or explain how i copy and paste from within putty as im using that program.

    It is a personally modified i did myself so it will be different. I have 6 cards that all worked with ethminer and claymore 12. Jst had issues with 9 & 10. Worked for nicehash too. 30mh+ eth

    Thanks for helping out. Sorry about dicord, not my thing and not noticing it

  • Staff

    there is a lot more info than just a couple lines. One of the issues with doing BIOS modification is that you must sign the BIOS properly. The driver checks the hash of the BIOS against a value saved in the BIOS, if they do not match, it will have issues. As well, the community here shares a lot of information on BIOS mods, and then its validated against lots of miners, rigs, etc. Perhaps a good place to start is using the BIOS mods vetted by the community. Regardless, please post the whole output from atitool. Read the manual page for Putty to get the information you need to support cut and paste. Thanks!

  • Right.... i've gotten the miner to work fine through SSH so all is well there. Got the Eth only miner up with 6 cards but its only pulling 90 MH which is half of what i would be expecting (30x6=180ish).

    Not modified anything yet but that is low . Are compute drivers enabled? Are they latest drivers (17)? Getting the hang of this system you've got here :)

    Thanks again

  • Staff

    If you are using 2.4.1 version of pimp, you will have access to both the AMDGPU-DC and AMDGPU-PRO 17.40 drivers. You can pick and choose the bits you want in your driver stack. The OS is based on 4.15 rc2 and has the current AMDGPU-DC drivers built in. I would start by putting the stock BIOS back though, just to see what the hashing rates are.

  • Got it, In linux, not sure why i was using putty. Ha


    SubID: 0x3418
    SubVendorID: 0x1462
    Firmware signature: 0x4d4f5441


    Max GPU freq (Mhz): 2000
    Max memory freq (Mhz): 2250
    Power control limit (%%): 50


    TDP (W): 145
    TDC (A): 132
    Max Power Limit (W): 135
    Max Temp. (C): 90
    Shutdown Temp. (C): 94
    Hotspot Temp. (C): 105


    Temp. Hysteresis: 3
    Min Temp. (C): 40
    Med Temp. (C): 65
    High Temp. (C): 85
    Max Temp. (C): 109
    Legacy or Fuzzy Fan Mode: 1
    Min PWM (%): 20
    Med PWM (%): 40
    High PWM (%): 60
    Max PWM (%): 1
    Max RPM: 3000
    Sensitivity: 4836
    Acoustic Limit (MHz): 918


    300 Mhz: 750 mV
    600 Mhz: 65282 mV
    918 Mhz: 65283 mV
    1167 Mhz: 65284 mV
    1239 Mhz: 65285 mV
    1282 Mhz: 65286 mV
    1326 Mhz: 65287 mV
    1366 Mhz: 65288 mV


    Part num: K4G80325FB
    VendorID: Samsung
    Size (MB): 8192
    Density: 4M x 32
    Type: GDDR5

    Part num: H5GC8H24MJ
    VendorID: Hynix
    Size (MB): 8192
    Density: 4M x 32
    Type: GDDR5

  • Wow, it's all falling into place now using linux's ssh.

    My bad leaving the XMR miner running, Getting 160mh and have not even configured cards yet.

    Seems im all good but this error is stoppin the monitor loading on the rig? Not sure but im happier in ssh anyways.

    Drivers are working fantastic, will go through all the forum threads and tips and tricks i briefly saw scanning through when i have some spare time.

    Thanks for everything :)

  • Staff

    Awesome possum. Thats what we like to hear! We what our users to have the most reliable rigs, remote managed, and the fastest consistent hashing rates period. Would love it if you had the time to write up a review about your experience with hashing speeds. Thanks!

  • I will do for sure. With so many different setups/levels of experience i would just say it's not ALWAYS the easiest thing to get up and running but i do like the layout.

    1 thing before i get my settings dialed in, are these commands correct for sgminer?

    73 "gpu-engine":"1250,1250,1250,1250,1250,1250"
    74 "gpu-memclock":"2150,2150,2150,2150,2150,2150"
    75 "gpu-vddc":"990,990,990,990,990,990"

    There under whats possible but a safe starting point. Also, Is there a command for changing the memory voltage? i could only see core voltage.

    Thanks again :)

  • It was the comma missing from end of line :)

    The thing is, its showing in miner farm its changed the clocks but its still only doing 150mh (25 per card) instead of 180 (30 per card) that i got from windows (woefully unstable) and 170 from standard xubuntu using ethminer with no clocking (couldnt get to work) which showed my Modded bios works fine.

    Plus, the settings are doing nothing to the hashrate, not sure why....

  • Staff

    Unstable is bad M'Kay! So why try to reach unstable places? Keep the cards in a safe work zone, better for the cards, better for the rig, and in the end... better for the hashing :)

  • Hi, I'm having the same problem with 2.4.1, however I'm unable to SSH the machine. The mobo is Gigabyte AX370 Gaming 5 and I'm testing it with a single card only. Same results for R9 390 and RX570. The screen goes blank on boot. Please note that with 2.3 everything worked, however I'm hoping for better hashrates with the new AMD GPU driver in 2.4.1 and hence the switch. Basically 2.4.1 booted up, I've managed to enter the key, then the system rebooted and after a short while all I could see was Loading initial ramdisk and a blank screen after that. Please advise. Yes, I've read everything, I believe. Recommended mobo settings, proper image creation in Windows, etc. And the cards have a stock BIOS.

Log in to reply

Want 10% more hash from your rigs?

We promise to keep your email safe and never spam you.

Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.