<- Return to getpimp.org

Newbie Trouble H81 Pro BT r2.0

  • Hello Everyone -
    Looking for some help for a newbie. I have an Asrock H81 Pro BT r2.0 mb with UEFI Bios P1.20 and I cannot get it see the GPUs. I am using Nvidia 1050ti with Pimp version 2.3.30. I burned it to an SSD and it boots I an interact with the OS via Putty but I cannot get it recognize my GPU (ony using 1 now do have 5 more to add).

    I am thinking it's a bios setting. I have followed the guide here on Pimp and even tried a couple of youtube videos for settings and nothing is working. I've tried the GPU's in different PCI slots and still no go. One thing I notice in the Pimp guide was to set the Advanced -> Chipset settings -> change TOLUD to 3.5GB, I cannot find TOLUD in my bios.

    Any ideas on what I could be missing? Any help would be appreciated.

    Kind regards,

  • Support

    You must perform a number of settings. Read more here https://forum.getpimp.org/topic/9/setting-up-motherboards-for-mining
    Pay attention to each of the settings.

  • Thank blackice. I will follow the steps and report back.

  • I went through the guide very methodically and here is what I found. Please, any feedback is welcome.


    Set VT-d INTEL VIRTUALIZATION to DISABLED. - Not supported on my motherboard. I did set the one Intel Virtualization Technology I found to disabled.
    Set ONBOARD AUDIO/SOUND (AZALIA) to DISABLED. - I disabled all the sound.
    Set IEEE1394 to DISABLED. - I cannot find this setting in my BIOS.
    Set PCI-E SUBSYSTEM/LANES to x8/x4/x4 - I don't think this applies as I have a x16 PCI-E slot.
    Set ONBOARD GRAPHICS to DISABLED. - IPGU multi monitor set to disabled.
    Set PCI-E GENERATION to GEN2. - Set to GEN2

    ASROCK Motherboards (all)
    Advanced -> Chipset settings -> change TOLUD to 3.5GB - I cannot find this setting in the BIOS.
    Set all PCI-E settings to AUTO tried Gen 2 - I set this to Gen 2.

    When I boot with the GPU directly plugged into the board I get nothing. I can't SSH into it, just a black screen. If I take the GPU out I can get to the BIOS and even boot to PiMP. I am thinking there is another onboard graphics I need to disable but I cannot for the life of me find it. Does anyone have any suggestions? I am getting really frustrated as I have had the cards for months and just cannot get them to work. I did briefly on a Windows set up but then I found PiMP and I want to run PiMP.

    Any feedback would be welcome. Thank you in advance.

    Kind regards

    I am still not getting the board to see my GPU, even with it directly plugged, no riser, into the board.

  • Staff

    Are you using the right version of pimp for the GPU you have?

  • Thanks for the reply. Good question, I downloaded the Nvidia 2.3.30 version. Is there an older version I should try? The cards are GTX 1050 ti.

    Kind regards,

  • Support

    @doctoreaz its a last version. It works perfect with all nvidia cards.

    Your motherboard required to connect the PCIe power connector to PSU.
    Please make sure all the connected power connectors are on the same PSU.
    No. Description
    4 ATX 12V Power Connector (ATX12V1)
    7 ATX Power Connector (ATXPWR1)
    18 PCIe Power Connector (PCIE_PWR2)
    24 PCIe Power Connector (PCIE_PWR1)

    In the BIOS:
    Primary Graphics Adapter -> PCI-E
    PCIE2 Link Speed -> GEN2
    IGPU Multi-Monitor -> Disable
    Onboard HD Audio -> Disable

  • Thanks for the reply, I apologize for the delay. Stupid real life got in the way. I'm going to tear it down and rebuild it, closely following your the instructions you posted. I'm also going to try the new OS update too.

    Thanks again for your help and patience. I will get back with an update soon.

    Kind regards,

  • Thank you. That did seem to work. I was able to get a GPU attached to the board to mine. Now on to the next issue. I put it on the riser now when I start the MB it starts the GPU PSU ( I have a separate PSU for the MB) but the PSU doesen't run at full speed. So confused right now.

  • Staff

    Separate PSU are tricky. You will have to configure your hardware properly first, and then the software will work. Maybe simplify your rig until you are ready to run dual-PSU, and maybe research how to do that properly in the meantime.

  • Thanks for the tips, I will do exactly that. I had not considered how much the hardware impacts the ability of the software to work. I am on the research path now.

    You guy rock!

    Kind regards,

  • You advice helped. I am up and running! Thank you again and have a Happy Holiday season.

    Kind regards,

  • Support

    Thank you for your support, DoctoreAz! Good luck and happy holydays ;)

Log in to reply

Want 10% more hash from your rigs?

We promise to keep your email safe and never spam you.

Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.