Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Quick Links

GPUTool error with GTX980ti

  • Developer

    Good morning Bryan,

    I do apologize that you haven't received a reply to your post, usually all posts are replied to, but it appears on this occasion your post slipped through the net, I'm so sorry for this.

    A 'pimpup' to the latest release as of yesterday should hopefully resolve this. Always good though to check the seating of your 4 gpu's to your riser card's as they can move over time, and also all power and data cables. If that fails, I would be recommend re-imaging to the latest PiMP OS version 2.6, as their have been updates to drivers, etc.

    Please do let us know how you get on Bryan, and of course you can always chat with us on Discord.

    Best, Louis

  • Louis- Thank you for the reply. The behavior is the same after running pimpup and checking the power/data cables. I will give 2.6 a try in the near future.

  • Developer

    Good Evening Bryan,

    Yes, please do give 2.6 a try when time permits, and see if this resolve the issue, also please do keep us informed as well.

    Best Louis

  • I've the same problem. 2.6 didn't fix it.

  • I've upgraded to 2.8.6 and switched out the riser card. Exact same behavior.

  • Staff

    Thanks, bryan for letting us know. Unfortunately, gputool asks the driver to set the setting, and the driver is not doing it. Newer drivers did not help. So, it may not be possible to set those particular settings for that particular GPU. We are not able to ask the GPU or the drivers to do things they are not able to do - but hopefully some of the settings do work for you. Best Wishes!

  • Staff

    " (it is a read-only attribute)." is the big clue here. It appears the driver is unable to set these values on these cards. Why that is I cannot say.

  • So strange - that's a change in behavior. You used to be able to set all the GPU vars without issue. Thanks for your help!

  • Beta Team

    I ran into the very same problem with gputool today when configurating my old GTX970.

    [/root]:# gputool --config
    PIMP GPU Tool v20191007
    GPUs type: NVI
    Conf file loaded, configuring 6 GPUs..
    GPU 0: NVI, busid 01:00.0
    GPU 0: Fan Speed set to 70%
    GPU 0: PowerLimit set to 150 W
    GPU 0: !
    ERROR: The attribute 'GPUGraphicsClockOffsetAllPerformanceLevels' specified in assignment '[gpu:0]/GPUGraphicsClockOffsetAllPerformanceLevels=0' cannot be assigned (it is a read-only attribute).
    GPU 0: !
    ERROR: The attribute 'GPUMemoryTransferRateOffsetAllPerformanceLevels' specified in assignment '[gpu:0]/GPUMemoryTransferRateOffsetAllPerformanceLevels=0' cannot be assigned (it is a read-only attribute).

    I found this post:

    where it looks like NVIDIA changed there syntax.

    "It looks that with recent nvidia video drivers there was a change in naming. ArchWiki has this:"

    Exec=nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=n"

    and the correct name according to nvidia developer zone is this

    Exec=nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUTargetFanSpeed=n"

    Maybe can be helpful,
    All the best, Agkbill

  • Staff

    Hi all, we have since updated gputool to reflect nvidia's driver changes. Current version of gputool should work for that card now. Thanks!!


Want 10% more hash from your rigs?

We promise to keep your email safe and never spam you.

© 2014-2020 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC