<- Return to getpimp.org

gputool ( gpu-config.json )



  • hello users and Pimp
    I noticed that when several graphics cards are connected that gputool is not working properly.

    1. System with Pimp 2.4.1
    • Asrock h81
    • 8 gp ram
    • 60 GB ssd
      2 x Shappier Rx 470 8gb mining Edit
      2x Gigabayte gtx 1070 ti 8gb
    • cleymore miner

    -> screw me too much at the memory or the GPU has a GTX 0.00mh / s

    ------ Settings gpu-config.json
    {
    5 "gpu_id": "0",
    6 "NVCOffset": "0",
    7 "NVMOffset": "0",
    8 "NVPLimit": "100",
    9 "fanspeed": "60",
    10 "temptarget": "70"
    11},
    12 {
    13 "gpu_id": "1",
    14 "NVCOffset": "0",
    15 "NVM offset": "0",
    16 "NVPLimit": "100",
    17 "fanspeed": "60",
    18 "temptarget": "70"
    19}
    {
    21 "gpu_id": "2",
    22 "AMDCoreClk": "1200",
    23 "AMDMemClk": "1800",
    24 "AMDPtune": "7",
    25 "fanspeed": "0",
    26 "temptarget": "70"
    27},
    28 {
    29 "gpu_id": "3",
    30 "AMDCoreClk": "1200",
    31 "AMDMemClk": "1800",
    32 "AMP tune": "7",
    33 "fanspeed": "0",
    34 "temptarget": "70"
    35}

    more is not possible.

    System 2 pimp 2.4.1

    • Asrock h110
      --8gb Ram
      --60gb ssd
    • 11 x Gtx 1070 ti 8gb
    • 1x Gtx 1080 ti 11gb
      --cleymore

    ------------ Settings gpu-config.json

    {
    5 "gpu_id": "0",
    6 "NVCOffset": "100",
    7 "NVM offset": "1000",
    8 "NVPLimit": "100",
    9 "fanspeed": "90",
    10 "temptarget": "70"
    11},

    the same for all gpu

    but now at gputool --status

    Fanseed 96% up to 98%

    Unfortunately, I find no errors and all the information is properly written.

    does anyone know advice?

    THANK YOU



  • I'm not an AMD guy (yet), so I can only assist with the nVidia stuff.

    Anyway, double check your power limits on those 1070's... I thought 125 was the minimum...

    $ nvidia-smi -i 1 -q -d POWER
    

    *change the number after the '-i #' to one of your nVidia 1070 GPU ID's.

    The output will tell you the MIN and MAX for the card. Edit your gpu-config.json and change the power limit to no less than the MIN value.

    Also, sometimes, on machines with multiple GPU's, gputool --config can error out. Make your changes in the gpu-config.json file, save it, and reboot. Pimp will apply the settings, usually without any errors, automatically at login. It can be a little slow, but you can check that your settings are being applied by running the following a couple of times.

    $ nvidia-smi
    


  • Hello and thanks

    GTX 1070 ti nvidia-smi -i 0 -q -d POWER

    ============= NVSMI LOG ==============

    Timestamp: Fri May 18 10:08:33 2018
    Driver Version: 384.98

    Attached GPUs: 12
    GPU 00000000: 01: 00.0
    Power Readings
    Power Management: Supported
    Power Draw: 94.57 W
    Power Limit: 100.00 W
    Default Power Limit: 180.00 W
    Enforced Power Limit: 100.00 W
    Min power limit: 90.00 W
    Max power limit: 217.00 W
    Power samples
    Duration: 2.37 sec
    Number of Samples: 119
    Max: 105.98 W
    Min: 88.45 W
    Avg: 99.52 W

    GTX 1080 ti

    ============= NVSMI LOG ==============

    Timestamp: Fri May 18 10:10:00 2018
    Driver Version: 384.98

    Attached GPUs: 12
    GPU 00000000: 0B: 00.0
    Power Readings
    Power Management: Supported
    Power Draw: 132.84 W
    Power Limit: 130.00 W
    Default Power Limit: 250.00 W
    Enforced Power Limit: 130.00 W
    Min power limit: 125.00 W
    Max power limit: 375.00 W
    Power samples
    Duration: 2.37 sec
    Number of Samples: 119
    Max: 137.42 W
    Min: 100.73 W
    Avg: 129.74 W

    I now have power limit at 1080 to 130W and the 1070 are still set 100W.



  • @hzumbach Did that fix the problem or are there still issues?



  • Unfortunately it is not possible to give more power to the power of mermory, gpu or power.

    the attempt to work with the original brings the miner to a standstill, the two Nvidia do not run after 10 sec.

    attempt :

    • rm gpu-config.json
      -gputool --config

    everything as calm as it is. After a few seconds, I get red entries, achting temp line 15 and then if I can

    • gputool --status macht, are the two nvidia out (!)

    it is not possible to put the power on 150W, the miner dies immediately.

    the solution is now stop running at low speed (mh / s).

    GTX 1070 ti instead of 30mh / s now at 24mh / s
    amd 470 instead of 31mh / s now at 26mh / s


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.