Can not validate license key



  • Hello,

    I'm attempting to boot my machine for the first time and get the following message.

    "Your key will be verified in just a moment............
    Key failed validation:"

    I have verified that I have network connectivity on the Pimp OS machine. I am able to connect to my Pimp OS machine via SSH. From SSH I am able to ping miner.farm and traceroute to it. I am also able to connect to IRC from the console.

    The one thing that I did notice is that during initial startup there is a message about the miner.farm service not having started.

    I have checked my registration key several times. I am not adding an hidden spaces. It seems as though there maybe something wrong with my key.


  • Staff

    Edit: The next images will have more helpful error output, but this is quickly solved by reimaging. When there is a problem with the disk in Linux it goes to read-only. This is preventing you from being able to write service processes and such things to the disk to proceed. Simply re-write the image to the disk and try validation via SSH again.

    Thank you very much for supporting PIMP and we look forward to getting you all mining happily!



  • I bought a new motherboard today. I am going to attempt using it in order to rule this out. Will update you soon.



  • I swapped out to another motherboard and it failed to validate my key. Motherboard being used is an Asus z270-AR.
    Boots up, I am able to get internet access, ping outside my network etc.
    I am still seeing an error about the miner.farm service not being able to start during the boot process.

    However, I am able to ping miner.farm and traceroute to it.



  • AnjinMeili suggested that I may have had an issue when I dismounted my USB drive after creating my SSD image. I went ahead and re-formated my SSD drive and re-downloaded the Pimp Image file. I then re-imaged the drive and made sure to properly dismount the USB drive from windows. For all I know the first time I may have just disconnected the drive before properly dismounting it from the operating system.

    After doing the above I was successfully able to successfully validate my license key and reboot into a functional PimpOS desktop. I hope this helps anyone that encounters this issue in the future.

    Thank you AnjinMeili for your assistance on this matter. I am excited to get things setup now. :)


  • Staff

    Do not forget to unmount, eject, close that drive!

    Remember that you want a CLEAN image. That means close the drive out before removing it from the imaging machine. Normally, you would use the OS tools to 'Eject' or ''Unmount' the drive from your operating system. This closes up device, flushes the buffers, and makes sure its all nice and tidy. We have noted a number of folks with license key issues after a fresh image because the drive is dirty on boot. So take the extra step here and make sure you 'Eject' and/or 'Unmount' the imaged drive!


  • Staff

    Edited original answer above: Reimage and do a clean eject

    Example on Windows 10 for USB connected devices (SATA need clean shutdown and power off)

    0_1513216815266_pimp-clean-eject-for-good-validation.png



  • Hello, I tried to enter key after installation it says “seems good…” and after a while it gives me the error Key Unknown after that i tried with SSH and copied it exactly from email and i am getting same error: Keys Unknown0_1513801748347_pimp.png



  • Had same problem, [edited for negativity]


  • Staff

    Sorry you guys are having trouble. Dear desfletc Please Don't be negative on the forum. The image works well for many many people and yet we are also looking for alternate installation methods but this will take time.

    Meanwhile, Make sure you reimage and clean eject, and SSH the key in: https://forum.getpimp.org/topic/268/can-not-validate-license-key/7 and https://forum.getpimp.org/topic/14/entering-the-key-for-the-first-boot and double check networking. Hope to see you mining soon!!!



  • I'm just getting continual 'Key Failed Validation' when entering my PiMP Key.

    This is not a great start, PiMP....

    Please urgently help me..



  • I'm really struggling to digest this info. My second computer is a Mac, please could you tell me how to activate my Key, I just purchased it today. Regards



  • When I try to activate my software I get invalid key. I also cut and paisted through SSH. Can you verify my key.


  • Staff


  • Staff


  • Staff



  • Hi, I have reimaged, shh the key in, and it said, 'key accepted or successful and rebooting or something in green letters. Now screen on rig gone black.. been 30 minutes.. is this normal? Or now another problem?...



  • @matnicolson Doesn't sound normal... Can you SSH into the rig? Does the bios screen come up before it goes to the black screen?



  • I have been having the same "Key validation failed" issue for days. There is a lot of talk here about clean installs and ejected USBs, but I installed mine on an SSD (from Windows) according to the instructions on the site. Nothing is mentioned there about ejecting anything. I can ping miner.farm and resolve the proxy without issue (Lilly helped me there). I have also ruled out my powerline network (Netgear PLP1200 - all green lights/string signal). I can find my rig on the network without issue from Windows via MobaXterm and can SSH and log in fine - it just won't validate. I am going to try to reimage the SSD one more time. Then I am on to something that will actually let me mine.



  • UPDATE. I reimaged using the same process. BUT since Windows could not write to the SSD either, the HDDRawCopy image write failed. I wiped the SSD and created a new GPT partition (instead of MBR) and it worked the second time. Since Windows never mounted the disk I did not have to eject (which is only required for USB). My PiMP key is now validated.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2018 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.