Welcome to the PiMP OS and Miner.farm forum.

Pimp 2.3.30 boot problem, 2.1 gpu issues, 1.9 freezing



  • Hi everyone !

    Firstly i really appreciate everybody behind pimp for creating something great, smth different.

    That was the Reason i bought a license a few days ago.
    But i am running into several issues i can´t really narrow down.

    I wen´t thru all the manuals as well searched on the forum (and if i missed smth i am sorry in advance) as well did the recommend settings on each motherboard.

    So my problems: (I downloaded all AMD based versions and tried them)

    2.3.30 ... Used raw copy tool on Windows and recovered the image to three different drives and tried it on three different motherboards (old P5Q Deluxe, Gigabyte 990FX UD5, Asrock H81 Btc R2.0. Each mb only gives me a blinking light on boot.
    Doesn´t matter which gpu i use (or if i use only one/two/three).

    Out of curiosity i looked at the Partitions and saw it has GPT/EFI partitions so maybe my boards are just to old and won´t support EFI booting.

    So i basically gave up on that Version for now.

    2.1 RC3 ... Boots can set everything up (configs, minerfarm etc.) added 6 GPU´s to the rig in total (MB Gigabyte 990FX) all recognized. But if i list the GPU´s via GPUtool it says memory and clock speeds are unknown but lists the type of cards in that rig i use 3x 7950 / 1x R9 290 / 1x R9 290x. But i can´t start any miner, i set up the configs on claymore, optiminer, sgminer. And i each miner can´t be started if i test it via the pimp test on console. It just tries to launch shows me my wallet key and after that stops even on debug without any real error beside the miner couldn´t be started.

    I did try it on my P5B Deluxe as well no luck.

    I am wondering if it´s an Radeon Driver Issue.

    1.9 RC16... Boots as well, but gives me a starting stopping light display manager, tries several times falls back to console i can SSH it no problem. But i can´t RDP it cause of fglrx seems to not run correctly (Just a guess since X isn´t starting as well). As well doesn´t matter if i use one or five gpu´s same issue. Swapped around boards again, tried all my three boards i use for mining. Each showed me the same result.

    If i need to send any logs, i can gladly try every version again.

    More Specs:

    Mining rig one .... Gigabyte 990FX UD5, athlon 620 quad core, 4 gigs DDR3 1333mhz Ram. 3x 7950 / 1x R9 290 / 1x R9 290x

    Mining rig owo .... Asus P5B Deluxe, E4600 cpu, 4 gigs 1066 DDR2 ram
    2x RX480, 1x R9/270

    Mining rig three ... Asrock H81 BTC R2.0, i5 4430 CPU, 4 gigs DDR 1333mhz ram.
    No GPU´s yet just swapping around from the other mining rigs (just got the board recently for cheap just for trying.

    I use powered risers on all systems, HP PSU´s (1000Watt-1200Watt 5PCS) give the GPU´s power. The boards are powered by 700 Watt Sharkoon bronze psu´s. (Basically only power the risers and the board´s)

    Basically i just wan´t to get one Version running.

    My plan was to use an older Build because i read about the hashrate beeing better on older builds for the 7950/R9 cards. And the newer build(s) for the RX Series with the Blockchain drive.

    Any help would be gladly appreciated, i am playing around since i bought the license now. And after a couple of long nights and energy drinks i do need some help.

    Please don´t mind my grammar, english isn´t my native tung.

    Thanks
    Ronald



  • Hello Ronald. Thank you very much for the details of your issue. Your cards only supported by PiMP 2.3.30 and 1.9 RC16. But in your case with old motherboards we recommend using 1.9 RC16. And also in the PiMP some useful commands are built in, such as pimpup (updates system and software components to the latest versions) and helpme (displays all the diagnostics that can be useful to you and us to determine the problem) Always pimpup. Always look at helpme first. To start do it. Then come check out PiMP Discord: a 24/7 Real time Mining Community with hundreds of miners around the world sharing tips and tricks and having fun with mining crypto currency, and the best mobile app https://discord.me/pimp



  • Hello blackice ! Thanks for your response. I forgot to add that i used pimpup on every version i got running and updated basically everything. As well i am already on the Discord Server, but i thought i post here first. Will boot the 1.9 RC16 again and try pimpup and than use the helpme commands for now. I´ll than post back on Discord if that´s fine.

    Thanks again
    Ronald



  • So will the detailed logs of what happens when you run the miner. It's ideal to use the pimp --debug command to see everything that happens. A helpme is best used when the miner is working to see more details. And by the way, 470, 480, 570, 580 works perfectly on 2.3.30 :)



  • Hi again ! Yep i read the RX´s work best under 2.3.30 but i don´t get this version booting on any of my mining mb´s. I will try to boot the image on my gaming rig later on which has an Z170 Board in there. If that works, the issue are my old boards. I am just doing a pimpup on the harddrive with the 1.9 on there. As i stands, it runs but can´t get the light manager to start just console. Maybe the updates solve it fingers crossed.

    After that i´ll move forward setting up gpu´s and miners again.

    Thanks for the support btw !

    .... UPDATE .... Even after the pimpup on RC1.9 with an R9 270X (and tried a 280x now as well) card in the system i don´t get a display manager and fglrx seems not to be loaded. If i do an gputool --list i get an unknow GPUs type. Exiting..


  • Staff

    What does the system tell you about itself using 'lspci' perhaps?



  • Do: echo AMD > /tmp/gputype for AMD and then pimpup --force to force update.
    And show your helpme



  • Hi again ! I will start from scratch now again with a fresh install. After tinkering thru the whole night i managed to get 1.9 into the graphical interface but it froze after 10 seconds. Maybe my install is just broken, before that it was running only in console but i could lspci it anyway (which i tried yesterday) and every gpu showed up. (I did boot the system(s) with either one or multiplie cards btw.

    Will do a new install now and do again an lspci as well the forced updated and echo command.

    Thanks for all your help !

    Ronald



  • The graphical interface can be frozen during a hashing. We recommend using SSH.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2018 PiMP LLC. All rights Reserved.