<- Return to getpimp.org

minerfarm.service will not start after GPU driver updates (nvidia)



  • Re: Miner.Farm service

    When I run the systemctl command, noted above, I see this response:

    Job for minerfarm.service failed because a configured resource limit was exceeded. See "systemctl status minerfarm.service" and "journalctl -xe" for details.

    And running the systemctl status command returns:

    [/root]:# systemctl status minerfarm.service
    ● minerfarm.service - Service process for miner.farm agent
    Loaded: loaded (/etc/systemd/system/minerfarm.service; enabled; vendor preset: enabled)
    Active: activating (auto-restart) (Result: resources) since Wed 2018-03-14 00:38:53 EDT; 852ms ago
    Process: 30236 ExecStart=/opt/minerfarm/minerfarm_svc (code=exited, status=0/SUCCESS)

    Mar 14 00:38:53 pimp2 systemd[1]: Failed to start Service process for miner.farm agent.
    Mar 14 00:38:53 pimp2 systemd[1]: minerfarm.service: Unit entered failed state.
    Mar 14 00:38:53 pimp2 systemd[1]: minerfarm.service: Failed with result 'resources'.

    No matter what I try, I cannot start the agent and thus cannot mine.
    This began after using APT to get the nvidia-390 drivers so I could mine off of the ethhash profile. Previously when attempting to start it I was informed that my drivers weren't up to date. So I updated them. Now nothing mining related appears to work.
    Am I going to have to re-install my pimp image?



  • Is this a new image? What kind of disk is it? If it's new, I suggest reimage without spending too much time. If it's old then you probably want to look there is a new version and create a new image anyways.



  • Thumbs up for the topic... Me and a couple of mates are experiencing the same thing on our Nvidia rigs... Minerfarm stopped working after last pimpup.



  • Although minerfarm service does work for me, this is what I see when I login to miner.farm web:

    0_1522049224448_89317bb4-ed05-4e38-8a14-b059e096f5a3-image.png

    [/root]:# systemctl status minerfarm
    ● minerfarm.service - Service process for miner.farm agent
    Loaded: loaded (/etc/systemd/system/minerfarm.service; enabled; vendor preset: enabled)
    Active: active (running) since Mon 2018-03-26 09:18:12 CEST; 6min ago
    Process: 556 ExecStart=/opt/minerfarm/minerfarm_svc (code=exited, status=0/SUCCESS)
    Main PID: 647 (minerfarm_svc)
    CGroup: /system.slice/minerfarm.service
    ├─ 647 /usr/bin/perl /opt/minerfarm/minerfarm_svc
    ├─12224 sh -c curl -s -H "Content-Type: application/json" -d '{"Miners":{"1":{"Agent":"SHYL57934","IP":"127.0.0.1","Pools":"POOL=0,URL=x://eu1-zcash.flypool.org :3333,Priority=0,User=t1eXaemeNoTFe7NkuLU
    └─12225 curl -s -H Content-Type: application/json -d {"Miners":{"1":{"Agent":"SHYL57934","IP":"127.0.0.1","Pools":"POOL=0,URL=x://eu1-zcash.flypool.org :3333,Priority=0,User=t1eXaemeNoTFe7NkuLUrSNHGpMWs

    Mar 26 09:18:11 IOTAG-Nvidia_1 systemd[1]: Starting Service process for miner.farm agent...
    Mar 26 09:18:12 IOTAG-Nvidia_1 systemd[1]: minerfarm.service: PID file /var/run/minerfarm_svc.pid not readable (yet?) after start: No such file or directory
    Mar 26 09:18:12 IOTAG-Nvidia_1 systemd[1]: Started Service process for miner.farm agent.


  • Staff

    miner.farm is running ( Active: active (running) since Mon 2018-03-26 09:18:12 CEST; 6min ago ), it is not seeing your miner running. Did you reboot after pimpup? You may also need to delete and readd the miner from the agent on the rig.



  • Tried rebooting and readding ewbf, it didn't help... miner.farm still shows the miner as stopped. Web says this:

    0_1522137163506_22936bc7-e7a5-4a81-bb34-f3c7112268af-image.png

    via shell:
    0_1522137579022_11407b9f-a0ee-4af1-b655-262badaaa426-image.png



  • Did pimpup again this morning:
    0_1522222534324_427214c4-e02f-44da-8c69-c99f9835e39f-image.png

    Deleted EWBF profile and readded it, tried rebooting the rig as well... Still the same:
    0_1522222630018_a7c5288e-b270-4a96-bbfd-8aaadadfc3e0-image.png

    Any advice would be helpful.


  • Staff

    While we have done our very best to support this miner, it is unfortunately of poor quality. Specifically, it does not start the API interface consistently. You can check this yourself by starting the miner with 'pimp --test' and watching the miner output at the start for "API Bind error". In my testing, it fails about 50% of the time, randomly.

    We have recently integrated Bminer, and it is of much better quality. Please give it a try! We think you will appreciate a better built miner.

    Lily



  • I'm experiencing the same issue, understand about ewbf but bminer is no better.

    https://helpme.getpimp.org/PimpRig2-1522366764.html

    And yes, I have the onboard GPU enabled. this particular B85 board won't post without it, no matter what I've tried. It is heading for the shelf as soon as I can swap it out, however.


  • Staff

    Pimp v2.4.2-all should be retired. Simply use 2.5-all or 2.5.1. We had to make some changes to the server side management of how miner.farm handles connection pools.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.