<- Return to getpimp.org

Agent faulty reported dead, minerfarm restart on rigg restore connection.



  • Hi,

    have for some time experienced problem with that agents are reported dead.

    In picture below, agen "RX-480 Clare P2.5" is reported dead, but if I SSH to the rigg and look in minerfarm all is OK. This is confirmed if I look at the mining pool that Clare is connected to.

    Restart of minerfarm (first press 'x' and then 'o') agent start to report OK again.

    0_1520795366207_82352b96-f302-427f-9fe3-8dbbc9b7e7b7-image.png

    Any ideas how to troubleshoot or solve this would be fantastic.

    All the best you you all!
    Christer


  • Staff

    Please ensure the time on the rig is current. Offset by more than a minute will cause agent reporting issues.



  • On one of my riggs I have.

    [/root]:# timedatectl status
    Local time: Mon 2018-03-12 16:47:14 EDT
    Universal time: Mon 2018-03-12 20:47:14 UTC
    RTC time: Mon 2018-03-12 20:47:14
    Time zone: America/New_York (EDT, -0400)
    Network time on: yes
    NTP synchronized: yes
    RTC in local TZ: no
    [Agent:

    Looks quite OK, but timezone is all off, I'm in Stockholm/Europe Zone. will change that and se what happen.


  • Staff

    In general, you should not need to change any of the time settings on your pimp rig. However, sometimes the time drifts on a rig. ntpd is a time daemon that should keep it in sync but if the gap is too large it will sometimes refuse to update things. In the event that your rig is at the wrong time, you can do:

    'sytemctl stop ntp; ntpdate time.nist.gov; systemctl start ntp'

    This series of three commands stops the ntp service, updates your clock to time.nist.gov then restarts the ntp service.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.