Gputool --config Loading very slow



  • Hello, i am having problem with new update 2.5. after update the gputool --config commands take about 4 to 6 minutes to load all settings. Before update all was fine. This is happening with 3 rigs other 2 are ok as they are still not updated. I dont know what i am doing wrong. I am posing my helpme file.
    I have the internal gpu activted as otherwise the gpu0 produce less hashes. But that should not make any difference as it was ok before the update. Please send some help as i am stuck here with this.

    I also get this error lots of time when i run the dame command.
    Use of uninitialized value $newfan in numeric le (<=) at (eval 2) line 627.
    i have tried pimpup --force and rm gpu-config.json.

    Thanks

    https://miner.farm/farmer/3523/farmstatus
    https://helpme.getpimp.org/-1520707842.html
    https://helpme.getpimp.org/-1520707926.html
    https://helpme.getpimp.org/-1520708527.html


  • Staff

    I believe you have some strange data in the cpu-config.json.

    "gpuSettings": [ 
    { 
    "gpu_id": "20", 
    "fanspeed": "90", 
    "temptarget": "70" 
    }, 
    

    This block is not correct for AMD or NVIDIA. And since you do not have 20 GPUs in the system, simply wrong.

    I would copy your gpu-config.json out of the way, and recreate it.

    mv /root/gpu-config.json /root/gpu-config.json.old
    gputool --update
    # Edit the file if you desire..
    gputool --update
    # You run it twice.  First time recreates the file with defaults, second time applies it.
    

    Good luck!



  • Hello, Thanks for the reply. The GPU20 is normally created gpu0 as for intel internal card. but i change it to gpu20 and then i change the gpu12 to gpu0. Check the original created file after rm gpu-config.json and my modified.

    if i turn off the internal card then it does not create the first extra gpu in gpu-config.json. but my gpu0 produces very less hash rate. so i have the internal card on.
    after running --update nothing change.
    [/root]:# gputool --update
    PIMP GPU Tool v20180220
    GPUs type: Mixed

    WARNING: Intel GPUs are not currently supported for mining
    NOTE: At least one miner appears to be running.
    GPU count matches config, no changes made.

    Modified Gpu-config.json

    {
    2 "comment": "Please see https://forum.getpimp.org for information about configuring this file",
    3 "gpuSettings": [
    4 {
    5 "gpu_id": "20",
    6 "temptarget": "70"
    7 },
    8 {
    9 "gpu_id": "1",
    10 "NVCOffset": "120",
    11 "NVMOffset": "600",
    12 "NVPLimit": "200",
    13 "fanspeed": "90",
    14 "temptarget": "70"
    15 },
    16 {
    17 "gpu_id": "2",
    18 "NVCOffset": "90",
    19 "NVMOffset": "500",
    20 "NVPLimit": "130",
    21 "fanspeed": "90",
    22 "temptarget": "70"
    23 },
    24 {
    25 "gpu_id": "3",
    26 "NVCOffset": "120",
    27 "NVMOffset": "60",
    28 "NVPLimit": "200",
    29 "fanspeed": "90",
    30 "temptarget": "70"
    31 },
    32 {
    33 "gpu_id": "4",
    34 "NVCOffset": "80",
    35 "NVMOffset": "400",
    36 "NVPLimit": "110",
    37 "fanspeed": "90",
    38 "temptarget": "70"
    39 },
    40 {
    41 "gpu_id": "5",
    42 "NVCOffset": "80",
    43 "NVMOffset": "400",
    44 "NVPLimit": "110",
    45 "fanspeed": "90",
    46 "temptarget": "70"
    47 },
    48 {
    49 "gpu_id": "6",
    50 "NVCOffset": "90",
    51 "NVMOffset": "500",
    52 "NVPLimit": "150",
    53 "fanspeed": "90",
    54 "temptarget": "70"
    55 },
    56 {
    57 "gpu_id": "7",
    58 "NVCOffset": "90",
    59 "NVMOffset": "500",
    60 "NVPLimit": "130",
    61 "fanspeed": "90",
    62 "temptarget": "70"
    63 },
    64 {
    65 "gpu_id": "8",
    66 "NVCOffset": "120",
    67 "NVMOffset": "600",
    68 "NVPLimit": "200",
    69 "fanspeed": "90",
    70 "temptarget": "70"
    71 },
    72 {
    73 "gpu_id": "9",
    74 "NVCOffset": "90",
    75 "NVMOffset": "500",
    76 "NVPLimit": "130",
    77 "fanspeed": "90",
    78 "temptarget": "70"
    79 },
    80 {
    81 "gpu_id": "10",
    82 "NVCOffset": "80",
    83 "NVMOffset": "400",
    84 "NVPLimit": "110",
    85 "fanspeed": "90",
    86 "temptarget": "70"
    87 },
    88 {
    89 "gpu_id": "11",
    90 "NVCOffset": "90",
    91 "NVMOffset": "500",
    92 "NVPLimit": "130",
    93 "fanspeed": "90",
    94 "temptarget": "70"
    95 },
    96 {
    97 "gpu_id": "0",
    98 "NVCOffset": "120",
    99 "NVMOffset": "600",
    100 "NVPLimit": "200",
    101 "fanspeed": "90",
    102 "temptarget": "70"
    103 }
    104 ]
    105 }
    106

    Original created after rm gpu-config.json

    {
    2 "comment": "Please see https://forum.getpimp.org for information about configuring this file",
    3 "gpuSettings": [
    4 {
    5 "gpu_id": "0",
    6 "fanspeed": "90",
    7 "temptarget": "70"
    8 },
    9 {
    10 "gpu_id": "1",
    11 "NVCOffset": "0",
    12 "NVMOffset": "0",
    13 "NVPLimit": "150",
    14 "fanspeed": "90",
    15 "temptarget": "70"
    16 },
    17 {
    18 "gpu_id": "2",
    19 "NVCOffset": "0",
    20 "NVMOffset": "0",
    21 "NVPLimit": "150",
    22 "fanspeed": "90",
    23 "temptarget": "70"
    24 },
    25 {
    26 "gpu_id": "3",
    27 "NVCOffset": "0",
    28 "NVMOffset": "0",
    29 "NVPLimit": "150",
    30 "fanspeed": "90",
    31 "temptarget": "70"
    32 },
    33 {
    34 "gpu_id": "4",
    35 "NVCOffset": "0",
    36 "NVMOffset": "0",
    37 "NVPLimit": "150",
    38 "fanspeed": "90",
    39 "temptarget": "70"
    40 },
    41 {
    42 "gpu_id": "5",
    43 "NVCOffset": "0",
    44 "NVMOffset": "0",
    45 "NVPLimit": "150",
    46 "fanspeed": "90",
    47 "temptarget": "70"
    48 },
    49 {
    50 "gpu_id": "6",
    51 "NVCOffset": "0",
    52 "NVMOffset": "0",
    53 "NVPLimit": "150",
    54 "fanspeed": "90",
    55 "temptarget": "70"
    56 },
    57 {
    58 "gpu_id": "7",
    59 "NVCOffset": "0",
    60 "NVMOffset": "0",
    61 "NVPLimit": "150",
    62 "fanspeed": "90",
    63 "temptarget": "70"
    64 },
    65 {
    66 "gpu_id": "8",
    67 "NVCOffset": "0",
    68 "NVMOffset": "0",
    69 "NVPLimit": "150",
    70 "fanspeed": "90",
    71 "temptarget": "70"
    72 },
    73 {
    74 "gpu_id": "9",
    75 "NVCOffset": "0",
    76 "NVMOffset": "0",
    77 "NVPLimit": "150",
    78 "fanspeed": "90",
    79 "temptarget": "70"
    80 },
    81 {
    82 "gpu_id": "10",
    83 "NVCOffset": "0",
    84 "NVMOffset": "0",
    85 "NVPLimit": "150",
    86 "fanspeed": "90",
    87 "temptarget": "70"
    88 },
    89 {
    90 "gpu_id": "11",
    91 "NVCOffset": "0",
    92 "NVMOffset": "0",
    93 "NVPLimit": "150",
    94 "fanspeed": "90",
    95 "temptarget": "70"
    96 },
    97 {
    98 "gpu_id": "12",
    99 "NVCOffset": "0",
    100 "NVMOffset": "0",
    101 "NVPLimit": "150",
    102 "fanspeed": "90",
    103 "temptarget": "70"
    104 }
    105 ]
    106 }
    107



  • Problem right now is that even the freshly created gpu-config.json is loading setting very slowly. I had all the same setting and all was working fine with 2.4 its just after the update to 2.5 version. I have a rig with the internal card turned off as well but there also the gputool --config command takes 4-6 minutes to finish loading on startup and also when run manually.

    Please check the video.
    https://www.dropbox.com/s/eg92e07ocsdvorp/Video 3-12-18%2C 11 59 47 AM.mov?dl=0



  • @chowhan

    Your NVCOffset and NVMOffset should be a value like +XXX or -XXX. This may have changed recently, but this works for me.

    For example I want to make my core run 150(MHz??) faster:
    "NVCOffset": "+150",

    Same for Memory (500 (MHz??) faster):
    "NVMOffset": "+500",

    Likewise, if you want to reduce the core and memory frequency:
    "NVCOffset": "-100",
    or
    "NVMOffset": "-200",

    And you really should disable the onboard video card. It causes more issues than it solves, and it confuses the PiMP scripts sometimes.

    After you set the over-clocks, can you post the output of the "nvidia-smi" command? This will show if they are being set properly.

    Try shutting down the miner before trying to apply the config. e.g. run "ms 1", wait for he miner to stop, and then run gputool --config. The video shows the miner running and you are trying to change the settings during active usage, which will be slower.

    Think of changing the values during use is like shifting gears in a car without using a clutch.

    -MAL


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.