Welcome to the PiMP Mining Community Forum.


Coin/crypto news, miner.farm and getpimp.org announcements, guides, and tips.


Pimp doesn’t boot on Biostar TB250 BTC Pro



  • Hello! PiMP is designed to work with SSD. USB stick does not fit.



  • Hi

    Thx for your answer.

    I do not use USB stick, but USB disk (if this is of any importance in this case).

    Are you sure that my problem is connected to wrong disk? I mean, I do not want to buy SSD and see that I have the same problem.



  • Another thing

    I saw someone asked if the licence is connected to one MB.

    I made bootable disk on one computer and then i took it to another. Do you think this could be a problem?


  • Staff

    The boot media is not correct. First, understand that tens of thousand users make this image just fine. A few have issues, and most times we find those issues are resolved by the user changing the procedure when burning the pimp boot media.

    Using your normal OS, with the PIMP media attached, run a disk testing tool to insure its a good drive. I use a bit reader to do a disk test. Look at tools like 'testdisk'.

    Make sure you sync and close all cache buffers to the pimp boot media. Windows does not like to allow the hot removal of internal SATA drives. Most of us will use a USB to SATA converter and attach an SSD to a host computer. Windows handles caching differently on drives intended for removal. This is dynamic in Windows, and you can configure it as needed. But I am not the guy to walk you through Windows removable media management. Google can help you though :)

    The boot failure though is telling you clearly 'This image is busted dude', so you need to change up how you are making that pimp imaged boot drive up. Can you give us a rundown from start to finish of what you are doing todo that?



  • Thx for the answer.

    I have made some bootable media and this is first time I am encountering problems. But I will google as you suggested and see if there is more ...

    I will chek the disk again.

    Anyway. Is SSD a must or can i use external portable disk with USB connection?


  • Staff

    When you create the media, you can use an external portable disk with a usb connection.





  • I have a problem to boot up pimp-2.3.30-amd on my miner pc (motherboard Biostar TB250-BTC & 6x Asus Strix RX 580 8GB). The boot process just stops & only black screen & nothing more. If I enable integrated Intel gfx PIMP is able to boot up. But there is also intel gfx there so I cannot execute mining at all. I do not have problem with this PC on Windows 10 or SMOS. What do you think where is the problem? I configured uefi but it does not help:
    Set VT-d INTEL VIRTUALIZATION to DISABLED.
    Set ONBOARD AUDIOto DISABLED.
    Set ONBOARD GRAPHICS to DISABLED.
    Set PCI-E GENERATION to GEN2.


  • Staff

    Have you attempted to fire it up with just one GPU installed?



  • Yes, only one RX580 GPU in PCI-E 16x but no change.
    Then changed bios settings for PCI-E 16x slot from gen2 to auto & was able to boot up. But the screen is blurry & boot process stops on something I cannot read. Not able to connect via ssh from other PC.
    Have the latest bios installed B25CF710.BSS.


  • Staff

    Merged topics about TB250


  • Developer

    Hello hai- I don't have a Biostar TB250 motherboard, but I had the same problem that you are describing on my Asus STRIX B250F motherboard, whereby it would boot straight into BIOS, and the boot options in BIOS didn't show the PIMP OS drive to boot from. However, I found that if you switch off and then turn on the rig and press for me on my motherboard the F12 button this will preempt the motherboard from going straight into the BIOS screen, and instead will show you the boot screen, where for me it showed finally the Pimp drive, which I selected and thus was able to boot the PIMP OS system.
    Hope this may help, Best Louis.



  • Hi have found disabling mining mode in bios helps



  • I just installed a tb250 btc + and im unable to get past initial ramdisk. Has anybody seen this? This was before and after updating bios. Also freshly imaged pimp as well as prior one acts the same way.



  • I had this problem as well. Did "disable mining mode" in bios not do the trick? Worked for me



  • @jonathan-olivier No, it did not help. Turns out, pimp was booting up, but not showing on the screen. I was able to ssh in though.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2019 Portable Instant Mining Platform LLC. All rights Reserved.