Welcome to the PiMP OS and Miner.farm forum.

Pimp doesn’t boot on Biostar TB250 BTC Pro



  • I am building my second Pimp rig.

    The first works on a MSI B250 gaming mb.

    My first attempt was to take the ssd from the working rig and use it on the new Biostar TB250 BTC Pro motherboard and second I tried using a fresh Pimp image.

    On both situations the system doesn’t boot and goes straight into BIOS. When I am in the bios I do see the drive recognised but it doesn’t appear in the boot priority menu.

    I have successfully been able to install and boot windows 10 on this motherboard, but I want to use Pimp.



  • Your board is trying to find UEFI ssd. Try to disable the support for windows 10 WHQL in BIOS or enable the Legacy boot type instead of UEFI.



  • Thank you I found the setting in BIOS called "CSM" the allowed the selection of UEFI or Legacy, and this allowed Pimp to boot. I have managed to get Pimp working with 3 x MSI RX570 Gaming 4Gb + 1 Sapphire RX570 Nitro+ 4Gb. I am successfully mining with 4 GPUs.

    The problem I now have is that when I try to add a 5th card or when I change where I plug in the cards from the first 4 slots (physically closest to the CPU), after selecting Pimp from the boot menu, I get a rapid and continuous stream of error text, too fast to read but I can see some text with PCI at the start of the errors.

    I've tried to play around with BIOS settings, currently the Pci-e 1x is set to 2nd Gen, but I have also tried auto.
    For the pci-e-16x if I set it to 2nd gen I get screen corruption straight after the bios screen, so I have to leave that at auto
    I've tried enabling "mining mode" in the bios, and that also results in screen corruption after the bios screen.



  • Come to the discord, there we will repair you faster https://discord.gg/XfcTEYH



  • @blackice thanks for inviting to Discord, I in between looking after my son so I can't go onto chat.

    I've had pretty much the same problem with EthOS too, so I swapped out the Biostar TB250 BTC Pro and plugged in a Asrock H110 BTC+ Pro and with works perfectly with 5GPUs on both Pimp and EthOS.

    Does anyone have any experience setting up the TB250? I would still like to use it as I still have 15 more GPUs to install and they won;t all fit on the Asrock



  • I have the bio star tb250 BTC pro running PiMP now and was running ethOS before. The pci error is from a riser. I have 10 gtx 1070’s on mine. Hit me up if you have issues. Just replaced my processor after a defect also.


  • Staff

    Wow!!! Thank you very much for your reply @leighton.bingham, is there any way you can tell us the BIOS settings and/or make some quick pictures of the screens of the settings so other pimps can use this board? Would really help out some of these pimps!



  • Of course I’ll take some bios pictures tonight a do a write up tonight. By far PiMP is the best mining software I have used and the support makes it even better!


  • Staff

    Wow thanks! We are proud to help you earn a nice income as a miner and be one of the pioneers of the future of money. And I hope we can quote you on the getpimp.org website reviews section, leighton! :)



  • @leighton-bingham Thanks! I've swapped the risers out, didn't help. what helped was swapping out the motherboard for an Asrock H110 Pro BTC+

    Works perfectly with the Asrock MB. But when I put in my new Asus B250 Mining Expert, back to problems again. Any card connected to the Pci-16x on the Asus B250 gets about 1/2 the hash rate as when the same card and riser is in a Pci-1x slot!

    I'm not having any luck except with the Asrock mobo :-( .



  • After contacting Biostar regarding this problem their response was:

    "Dear Customer,

    We would recommend using windows or ethOS for mining OS, please try to disable CSM support in BIOS if you can not display through overclocked GPU. Thank you.

    Harry
    2017-11-01 10:19:47"


  • Staff

    Yes, setting up the motherboard is a prerequisite for all of the OS and also for PiMP. Also, can you reply to them and tell them about PiMP? They may not know about our awesome product and community somehow! (Even though we are the originals :) )



  • @hai So they don’t what the issue is? Lol
    can you boot of the internal display adapter? This is how I boot my system after every fresh install of PiMP. Without a doubt the biostar board is the best I have used. My Asrock caught fire and my msi just died on me lol.


  • Staff

    Oh no! Sorry to hear of that , fire is a bad word to miners. No, onboard GPU is not supported. TB250 is supported, there are many rigs running PiMP with it, hopefully someone can share some tips.



  • I'm running ethos the TB250 as per Biostar's suggestion and it's purring along with 10 GPUs 275MH/s. Gave up on Pimp after the response from Biostar



  • @hai here is my tb250 farm page. https://miner.farm/farmer/2652/farmstatus?node=4 If you are only getting 275MH/s you are missing out on $$$ lol



  • What cards u using?



  • Gtx 1070-5 EVGA SC and 5 gigabyte g1.



  • I'm using RX570. the 1070's are faster I think, my Asus GTX 1070 turbo does 27 MH/s stock, the Rx570's were doing 21MH/s stock, got them stable at 28MH/s. Considering the Rx570 is about 60% of the price of the 1070, I think it's better value for money



  • Sorry it must have been someone else I was chatting with that had 1070’s also.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2018 PiMP LLC. All rights Reserved.