Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Note: To change your forum username: login, click your avatar icon (top right?), Edit Profile. Change the "full name" field to your preferred username.

Quick Links

Problem with RDP/VNC

  • I'm unable to complete remote desktop connection correctly to the server. After the RDP client connects, I get the prompt to login to xrdp, but when I click ok, it starts connecting but gives an error.

    I am still able to ssh into the machine.

    When I check at the command line, systemctl reports that the pimpvnc service is unable to start.

    I've tried to reimage the disk several times. I've tried to remove and reinstall the vnc services. Nothing seems to work; any advice would be much appreciated.

  • Support

    Hello me5,
    Sorry to hear this - which versions of Pimp OS are you using, as the latest version 2.5-all was released last week which has correcting the rdp connection error problem that you are experiencing. Would it be possible to upgrade to the latest 2.5-all version?

    Best Louis

  • Yes, this is 2.5-all freshly downloaded about 36 hours ago. If this helps, I have another symptom: even with a connected monitor, I don't get the GUI. The screen stops at the point where it says there's a valid key. Background processes are obviously running, however, since I can actually shell in and set up mining profiles.

  • Support

    Sounds like either onboard gpu enabled and or uefi not enabled, could you check on your BIOS please?
    Many thanks

  • Support


    Could you upload or explain what the error message says in detail?
    Thank you

  • @ldemorgan the onboard gpu is definitely disabled.

    0_1519542974435_2018-02-25 15.11.45.jpg

    I do get some errors at the start of boot, don't know if this is one of the root causes.

    0_1519543018392_2018-02-25 14.27.19.jpg

  • For further info, I am experiencing exactly the same problem when I have AMD cards installed, tried both Saphhire RX580 8GB and Asus RX570 4GB mining, same symptoms. If I remove the AMD cards and use 2 x Nvidia 1050Ti, I have a GUI, and RDP.

  • Support


    Is this using the latest Pimp OS version 2.5-all?
    Many thanks

  • Support


    Thank you Me.

    For the 'Cannot RDP (error connecting to 5900)", there is a workaround that worked for previous version of Pimp OS. Could you ssh in and run the following command please "systemctl start lightdm && systemctl start --user pimpvnc" - then RDP in.

    Let me know if this helps.


  • @ldemorgan
    command line returns:

    Job for pimpvnc.service failed because the control process exited with error code. See "systemctl --user status pimpvnc.service" and "journalctl -xe" for details.

    systemctl --user status pimpvnc.service gives:

    Loaded: loaded (/etc/systemd/user/pimpvnc.service; enabled; vendor preset: enabled)
    Active: inactive (dead) (Result: exit-code) since Sun 2018-02-25 09:08:16 EST; 40s ago
    Process: 4174 ExecStart=/usr/bin/x11vnc -v -display :0 -auth /var/run/lightdm/root/:0 -nopw -logappend /var/log/pim
    Main PID: 4174 (code=exited, status=1/FAILURE)

    Feb 25 09:08:16 pimp2 systemd[3967]: pimpvnc.service: Service hold-off time over, scheduling restart.
    Feb 25 09:08:16 pimp2 systemd[3967]: Stopped PiMP VNC Service.
    Feb 25 09:08:16 pimp2 systemd[3967]: pimpvnc.service: Start request repeated too quickly.
    Feb 25 09:08:16 pimp2 systemd[3967]: Failed to start PiMP VNC Service.

    journalctl -xe gives:

    Feb 25 09:10:46 pimp2 systemd[3967]: pimpvnc.service: Main process exited, code=exited, status=1/FAILURE
    Feb 25 09:10:46 pimp2 systemd[3967]: pimpvnc.service: Unit entered failed state.
    Feb 25 09:10:46 pimp2 systemd[3967]: pimpvnc.service: Failed with result 'exit-code'.
    Feb 25 09:10:48 pimp2 systemd[3967]: pimpvnc.service: Service hold-off time over, scheduling restart.
    Feb 25 09:10:48 pimp2 systemd[3967]: Stopped PiMP VNC Service.
    -- Subject: Unit UNIT has finished shutting down

  • Support

    @me5 said in Problem with RDP/VNC:

    pimpvnc.service failed because the control process exited with error code

    Thank you Me for running the command and pasting the error output, I will pass this onto dev team to look into.

  • @ldemorgan . Yes, downloaded the latest from the site, and ran "pimpup" immediately.

  • @ldemorgan. I am very much Noob on Pimp, I downloaded it a few days ago, and see I downloaded V2.4.2-all, and then ran pimpup.....not sure if that updates to 2.5.

    I will download 2.5-all this evening and try that and confirm.

  • Support


    We here to help where we can Slvorester - yes please try 2.5-all and let us know how you get on.

  • I'm having the same issue. Just updated PiMP to the most recent as of today. Tried the command above but nothing changed.

  • Support


    Hello Ryen,

    What error message do you receive? - Is it the "error connecting to 5900"?

    Many thanks

  • @ldemorgan. Ok. I have re-imaged my drive with a fresh copy of 2.5-all. I first ran it in a small nvidia rig, and can access the directly connected GUI, a RDP GUI, and SSH. I have taken that same drive to my AMD rig. it starts up and then stops at the following screen, with multiple "Invalid PCI ROM Header".

    0_1519756082077_amd error.jpg

    . I cannot access the RDP either, but I can access via SSH, and start a miner successfully....

    Any guidance will be appreciated.

  • Hello @ldemorgan -
    “Error connecting to 5900”. Any help is greatly appreciated!

  • Support


    Hello Slvorster,

    Sorry for my late reply - yes dev team have been notified, and when I receive an update, I will let you know via this forum thread.

    Thanks for your continued support.
    Best, Louis

  • Thank you Louis

    I will wait for your reply before I try again.

    Kind regards


Want 10% more hash from your rigs?

We promise to keep your email safe and never spam you.

© 2014-2021 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC