Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Note: To change your forum username: login, click your avatar icon (top right?), Edit Profile. Change the "full name" field to your preferred username.

Quick Links


CPU Soft lockup Hardware or Kernel issue?



  • CPU Soft lockup CPU #1 stuck for 23s...
    Then a ton of other script after this

    So, I've been doing extensive reading on this that is could be 1. A driver issue or 2. a faulty CPU Hardware issue.
    Here are my specs

    As for the drivers I tried to avoid the watchdog kernel by pressing "e" on "PimpOS" at Pimp OS boot sreen option. In the /boot command line the second from the bottom I added in nouvea.modeset=0 then F10 then "CPU Soft lockup CPU #2 stuck for 23s..." I mean serious!

    TB350-BTC Ver. 6.x
    AMD A8-9600
    Crucial 4GB DIOMM (support by motherboard manufacture)
    Asus RX 580 in PCIE 16x slot no riser
    BIOS AGESA 1.0.0.6b updateAGESA 1.0.0.6b update (Was running their updated and beta bios and was having PCI bus issues with IRQ conflicts).

    Here is my question:
    Does Pimp OS support this CPU or should I purchase a Ryzen 3 or Athlon X4?
    What CPU's are supported by Pimp OS?
    Does Pimp OS support this Motherboard? I don't think it's the Mobo. Biostar claims they ran and test EthOS on this model.
    http://www.biostar.com.tw/app/en/news/news.php?S_ID=320



  • P.s. I tried every solution on Linux furoms. i.e.: Trying different BIOS's 2. upping the voltage on the CPU to stabilize it 3. Resetting hardware 4. Swearing at the machine


  • Staff

    My first guess is that the power supply is not enough. But only one GPU should be ok. Try firing it up with the kernel options "acpi=off noapic nolapic", and then do some investigative work using sensors, dmesg, and cpuinfo. Google about getting all the info the OS knows about the CPU and MB working together. The above options should at least get you booted up and let you get more diagnostics. You might also double check every BIOS setting related to clock speeds, spread spectrum, over clocking, etc. Try first resetting the bios to factory defaults, then follow the guides here for setting up that BIOS.



  • @anjin To answer the first solution the PSU is 1000 watt and 1200 watt peak. I could try another PSU my mind would be blown if that's the problem. Hey it could be it's made in China! Could be a faulty PSU I'll try that next and will keep you posted.

    I tried running kernel option "acpi=off noapic nolapic" I was able to get into command, BUT the usb failed to enumerate, so I was unable to get my keyboard to function at this point, so I tried:
    1.Plugging in a new keyboard 2.setting IOOMU to enable in BIOS(for some reason that helped someone in one forum) 3.XHCI is also enabled in BIOS![0_1519017642488_cpu0 failed to setup threshold interrupt.gif](Uploading 100%)
    So I was unable to run a diagnostics at this point.

    As far as BIOS I tried every option known to work for people. Tried every BIOS from Biostar and re-configuring it. Tried disabling powernow, nx, svm, c6, and etc. disable onboard crap and etc. disabled COM ports, enabled mining mode. All the basic and known options I tried. tried running tpm disabled. I tried to up the voltage to the cpu V-core and the other voltage.
    More detailed hardware specs:
    TB350-BTC Ver. 6.x
    AMD A8-9600
    Crucial 4GB DIOMM (support by motherboard manufacture)
    Asus RX 580 in PCIE 16x slot no riser
    Adata 16GB SSD SATA
    AeroCool KCAS 1000W 80Plus Bronze Noise Reducing Components Black
    https://www.amazon.com/gp/product/B077MD8F48/ref=oh_aui_detailpage_o07_s00?ie=UTF8&psc=1
    BIOS AGESA 1.0.0.6b updateAGESA 1.0.0.6b update (Was running their updated and beta bios and was having PCI bus issues with IRQ conflicts).
    After doing more research on the PSU. Come to find out people were having problems with the 1200 watt series.


  • Staff

    Clean power is needed for clean clocks. Would you have another one you an try?



  • I'll purchase a Gold or better PSU tonight and name brand!



  • @anjin Just purchased a Enermax 1200 watt Platinum series PSU. https://www.amazon.com/gp/product/B074ZCVVB8/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1
    This hasn't solved my problem. I wonder how the compatibility of linux is with AMD CPU's. I've read some forums stating AMD isn't completely reliable in Linux. Another website indicated the soft lockup maybe due to poor drivers. Thoughts on this?


  • Staff

    I have both Ryzen and FX series GPUs without any issues. Could you link some of your references though? AMD is very popular in the Linux world due to deep threading.




  • Staff

    To validate anything in those links, would require more details.

    Can you capture the debug output when it locks up? In ASCII is preferred, so I can use the data to search on myself.

    But yes, it could be any number of things having issues with compatibility. Dosnt that GPU have an onboard GPU also?


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



© 2014-2021 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC