Rigs Disconnects from Network (Asrock H110 Btc+)



  • Hello everybody, i am running into a strange problem with my rigs.
    I have 5 rigs, 4 at my stop(Rig 1,3,4,5) and 1 at home (Rig2)
    All have 2.4 versions and have 1070/1070ti Cards with Asrock H110 Btc+ 13GPU Motherboard and 1000w Gaming PSU for every 3 gpus.
    The Rig 2 at home runs like charm without any problem.
    All the rigs at my shop also run great but only for 12 hours to 2-3 days.
    In between this time rig 4 or rig 5 get disconnected from internet and right after 20-30 mintues all other rigs get disconnected also internet. Even my Pc which is connected on the the same switch also looses internet. This has happned a lot starting from rig 4 or 5 and never with rig 1 or 3. I have tried changing swtich and cables. The rigs are connected with a 24 port switch(before with 5 and also with 8 port) with same result. The switch then is directly connected with the router. While the internet stops on the rigs, the pcs connected with the same router works fine. I have a lot of items at my shop (about 10-25) connected to the router with switches all setup with automatic ips.

    I dont know how to explain this more but i need help with this matter. I know that there is no problem with PimpOS but i need find and solve this problem.

    I am posting helpme for all 4 rigs and my farm link. Any help will be appreciated. Thanks for your time.

    https://miner.farm/farmer/3523/farmstatus

    https://helpme.getpimp.org/RIG1-1518004763.html
    https://helpme.getpimp.org/RIG3-1518004795.html
    https://helpme.getpimp.org/RIG4-1518004774.html
    https://helpme.getpimp.org/RIG5-1518004776.html
    alt text



  • you say other machines on the network are still working, but may not rule entirely that network is working. ive seen cables and ports act weird. try rotating the cables just to be sure. if there are gpu faults, i looked at rig4 and you could put the 1070s next to each other. currently they have a few 1070tis in between. best to seggregate models into PCIe-ID chains (like kind in order)

    your screenshot shows miner.farm not reporting them, but are the boxes in the air and just disappearing from miner.farm? confirm that first.

    you may want to consider using a third party server monitoring tool such as nagios or cacti.
    https://geekflare.com/best-open-source-monitoring-software/

    not that this is a problem, but you have some weird sleep gputool --config in your startup.sh, why do you hit it multiple times over 900 seconds? i dont think that should be necessary



  • Hi, my rig at home also have some Ti cards and runs fine for days but i will try to aline them on all rigs.
    In alert view all i see is this,
    Miner RIG5.1 is stopped!
    Agent RIG5 has not checked in. and then followed by other rigs.
    But the Rigs are working, after a manual restart everything seems to back online.
    yes, i had some issues with the gpu-config on boot before so i tried adding this but i am sure this can be removed now.
    This problem has to do sometihng with network as my pc on the same switch also disconnects.
    Do you think making the IP static will help resolve this?
    Right now all is working fine but in next few hours to 1-2 days it will happen again.


  • Beta Team

    Hello @chowham. I had this same issue previously. I had a few rigs setup and after some time they would disconnect from minerfarm and then totally go down. They would also affect the internet speed of the other machines connected to the network (non rigs). The only thing I could do to fix this issue was to download a VPN service (torguard) and install it on the rigs and make sure that it starts up automatically on reboot. It seemed as though my ISP was blocking certain ports related to mining and that was causing the issue. Assuming you are having the same problem, this should work for you. You may have to increase the sleep time in startup.sh for gputool to something around 45-60 after adding this. Hope this helps!



  • Hi nick, thanks for the reply. I don´t think that should be the problem but i have just purchased TorVPN and going to install it. Will post the results soon.

    cheers



  • I have done the pimpup last friday for claymore 10,6.

    Now I have the same issue with my rig. Minerfarm said Agent down, Miner pool is not updated.
    But, I can connect to pimp (with ssh), Pimp -- list gives Miner is running.

    The network issue arrives between 1hour to 3hour running.



  • @nick Hi Nick, I am also having the same issue with agents showing as not checked in but when I SSH to them they show as mining. Could this suggest that my ISP is blocking a port? Or if that was the case would I not be able to SSH onto it?



  • Hi, same problem here. I know it is caused by the Asrock H110 Btc+ motherboard because it is flooding the network in some way. If I switch of the miner with this motherboard al of my other miners with PimpOs (and a different type of motherboard, are coming directly back online. After switching of this miner and a reboot everything works fine for aproximately 46 - 60 hours. In my case It is not an ISP issue.

    (There are more reports on this issue i.e.: https://github.com/nanopool/ewbf-miner/issues/67, do a Google search with Asrock H110 Btc+ network flooding)

    At this moment I am figuring out what causes it. An update to the latest Bios version (version 1.6) does not fix the issue for me. I'll keep you posted.


  • Support

    This might be an obvious question, but let me ask it anyway... You do have a paid subscription to miner.farm, right?


  • Support

    @docdrydenn

    Hello Doc,

    No you can use miner.farm for free for up to 2 miners. For more then 2 miners, or for extra features then their are 3 additional paid for plans, which you can view here: https://miner.farm/#features

    Hope this helps,
    Best Louis


  • Support

    That's my point. He's showing 5 rigs. If he doesn't have a paid subscription for 5 (or more) miners and loads all 5 rigs with his API keys (short & long), then miner.farm will randomly start dropping and upping rigs.

    I know this, because I made the mistake of adding my 3rd rig to my 2 miner limited miner.farm account. The rigs mined just fine, it was miner.farm that didn't like more than my 2 rig limited account.



  • I have a paid subscription for 15 miners (using 6 at this moment).


  • Support

    Anyone have any luck with getting this sorted out?

    If you did, please post what you did to fix it for other Pimps that might be suffering the same problem. Thanks.



  • The problem ocurred again after aprox 4 days. I am using Bminer. After several restarts of the miner (not the rig and not the agent), with a shortening interval first 1 day and then approx 4 hours and then 2 hours Bminer stops and rig totally 'freezes' failing to reboot. Then the network problem occurs. Al other mining rigs aren't able to connect to the mining pools (and miner farm). Only shutdown of the power of the rig causing the problems, makes the other rigs directly connect to the pools (and miner farm). The rig causing the problems has 12 GPU in it. (On the internet there are several reports that this prblem occurs when having more than 6 GPUś on the Asrock H110 Btc+. The mining rigs has an IP4 and IP6 ip-address assigned by the router.

    No solution yet.



  • I'm wondering if this is my issue as well. It says my miner has disconnected from the network but in my case it is still mining on the pool. I cant get and logs off the miner itself either. I have this same exact board. This rig was running strong for 2 months. No reboots or restarts. A solid 2 months of mining. What could have changed?



  • [/root]:# pimp --test 1
    Preparing to test mining on Miner ID 1...
    Another miner is running on port 4028 - not starting.

    [/root]:# pimp --list
    Miners:
    ID 1 localhost:4028 ethdcrminer64 claymore.dual.pcfg (Stopped)
    [Agent: D81000 (Running) Total HR: [0.00Kh/s] Miners running [0] GPUs [none active]]

    But, it is mining...



  • Could an external nic fix this issue ?


  • Staff

    If you can, this would be an excellent troubleshooting step, @devinmosher. Try disabling the onboard NIC in the BIOS of the motherboard (aka UEFI setup) and use a PCI or USB NIC and see if that changes the behavior. Perhaps it's something with the way H110 did things with their bus, and this can help find out.



  • I am having the same issue, has anyone resolved this? Has using an external NIC been successful?


  • Staff

    Yes, external nic or using a Layer3 switch will work until we develop a more robust fix. Thanks!


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.