No AMDopenClGPUs found with RX550



  • I've got my rig up and running with 4 nVidia cards, but I've tried adding a RX550 and can't get any of the miners to work with it, although i can get the card to mine in windows. I've disconnected everything but the single 550 and am still returning the same error through pimp --debug.

    AMD opencl platform not found.
    No AMDOpenCLGPUS found, exit.

    The card is detected with gputool. It is also opencl compatible. I've tried reinstalling various drivers but can't get them to install as there is already an amd uninstall file being detected, but trying to uninstall amd drivers does nothing.



  • Make sure your NVIDIA cards call register on the PICe bus first. ie IDs 0, 1, 2, 3, AMDs at 4 and above. Play with the placement of the slots. When I'm messing with this I copy paste this line each time I boot (or press up to get last command run)

    rm /root/gpu-config.json && yes | gputool --config



  • Got the NVIDIAs first, I'll try different slots and see what happens. The ID of the AMD was something weird like 0:00:2b when it was plugged in after the NVIDIAs. Maybe the BIOS needs a look at again.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2018 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.