<- Return to getpimp.org

gpu-config.json not loading correctly on boot



  • Hello, I am suffering from this problem from many days that on reboot the gpu-config settings are not loaded correctly, power setting are loaded correctly but core and memoryare not loaded thats why after 10 minutes the cards starts to get hot and restarts. if i run the command manually then the things go fine. this is happing with my 3 of 5 rigs, all rigs have same settings. I have tried coping the startup.new to startup.sh and also i have extanded the sleep time but not working, also tried adding extra line on startup.sh after startup, sleep 300 && /opt/pimp/gpu-config.json. Any help on this please. thanks

    https://helpme.getpimp.org/RIG4-1516713180.html



  • https://helpme.getpimp.org/RIG1-1516714929.html
    Another Rig with same problem.



  • first issue is that your gpu-config.json shows your onboard GPU is enabled still. you need to disable in mobo bios

    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 610 (rev 04) (prog-if 00 [VGA controller])
    {
    "gpu_id": "20",
    "fanspeed": "90",
    "temptarget": "70"
    },

    second issue is you should run for a while with the default gpu-config json because right now you have OC settings which are high. rm gpu-config.json and then gputool --config twice to get a default (ONLY AFTER you have fixed the onboard GPU problem)

    thirdly you should look in the miner config for -tt and -tsop. There is a note near the bottom of the file which explains the miner will override your gpu-config settings for fan. If you want gpu-config to manage fanspeed you have to remove -tt and -tstop.

    personally I keep it there and look for the miner config setting for fans which is somewhere and usually by default is set to 50-100 which is too low

    and finally you have 12 gpus which is tricky to manage. what power supply do you have and are you sure you have enough wattage to run 12 GPUs?



  • hello, if i turn off the internal gpu the hashrate of gpu0 goes very low , eben when i do not use ant monitor.
    i have other rigs that are running sameoc settings and have no issure loading config file on boot.
    i use 3 * 1000w psu for 12 cards 1070

    here is my startup.sh

    GNU nano 2.8.7 File: startup.sh

    42 # The file must be exectuable. Try running it by hand by typing it in.
    43
    44 # Thank you for reading the instructions.
    45
    46 #####################################################################
    47 # GPU CONFIG
    48 # Default: 20 seconds after boot, Set the fans to 60% as precaution.
    49 #####################################################################
    50
    51 # Setup the clocks and fans according to what you edited
    52 # Step 1: run this command manually: gputool --config
    53 # it will make you a config file based on your current GPU setup.
    54 #
    55 # Step 2: nano /root/gpu-config.json
    56 # put in what you want.
    57
    58 # Step 3: Run the gputool --config again and it will apply your values.
    59
    60 # Step 4: To have it run on boot, use this command. Timing is optimal
    61 # for most GPUs.
    62
    63 sleep 30 && /opt/pimp/gputool --config
    64
    65 #####################################################################
    66 # START MINING:
    67 # Default: 25 seconds after boot, Start miner with ID 1
    68 #####################################################################
    69
    70 sleep 40 && /opt/pimp/pimp --start 1
    71
    72 # Optional: Start other miners like CPU miner and ASIC
    73 # sleep 30 && /opt/pimp/pimp --start 2
    74 sleep 90 && /opt/pimp/gpu-config
    75
    76 #####################################################################
    77 # DISABLE GPU LEDs: This can save power or turn off lights if you want.
    78 # OBVIOUSLY THIS IS FOR NVIDIA ONLY! NOT AMD.
    79 # GPULogoBrightness can take a value from 0 to 100, this affects the
    80 # brightness of the backlight.
    81 # 0 - completely off, 100 - maximum brightness.
    82 # Default: disabled, just remove the # to enable.
    83 # If no GPU specified (like default) it will assign to all GPUs in the rig.
    84 #####################################################################
    85
    86 #/usr/bin/nvidia-settings --assign GPULogoBrightness=0
    87
    88 #####################################################################
    89 # USB LCD Displays
    90 # Start the LCD display service. Optional, for USB LCD display support.
    91 # These are for any "USB LCD device" commonly used with Raspi
    92 # Example: https://www.adafruit.com/product/782
    93 # The default will cycle through CPU Load, network, etc.
    94 #####################################################################
    95 # sleep 10 && systemctl LCDd start && sleep 10 && lcdproc
    96



  • okay we made progress on this one today. when a miner is running and you try to gputool --config, it asks for a confirmation. if you put this in startup.sh the confirmation cannot be given.

    in your startup.sh, change the line AFTER the miner starts to this:

    SLEEP 20 && yes | gputool --config

    the yes | adds the "yes i want to do this even when a miner is running"

    good luck



  • oops, typos

    sleep 20 && yes | /opt/pimp/gputool --config



  • thanks for the tip. The problem was caused by calling the gputool --config command while running the miner.

    cheers


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.