Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Note: To change your forum username: login, click your avatar icon (top right?), Edit Profile. Change the "full name" field to your preferred username.

Quick Links


Trying to mine Garlicoin



  • I've been trying in vain to get SGMINER to work with garlicoin.

    The coin uses scrypt-n simliar to vertcoin

    Command line:
    ./sgminer --algorithm nscrypt --nfactor 11 -o stratum+tcp://pool.grlc-bakery.fun:3333 -u Ggnu4U2ErUxuGu9HsDH5QkZGMB1797mbK6 -p x -I 15

    All I get is hardware errors.

    Tried my hand at a config file with no luck.

    Please any pointers!

    1 {
    2 "pools" : [
    3 {
    4 "name": "Breadmaking",
    5 "url": "stratum+tcp://pool.grlc-bakery.fun:3333",
    6 "user": "Ggnu4U2ErUxuGu9HsDH5QkZGMB1797mbK6",
    7 "pass": "x",
    8 "profile": "garlicoin"
    9 }
    10 ],
    11 "profiles" : [
    12 {
    13 "name": "garlicoin",
    14 "pool-algorithm": "nscrypt",
    15 "pool-intensity": "15",
    16 "pool-nfactor" : "11"
    17 }
    18 ],
    19 "default-profile" : "garlicoin",
    20 "lookup_gap" : "2",
    21 "worksize" : "192",
    22 "failover-only" : true,
    23 "failover-switch-delay" : "5",
    24 "auto-fan" : true,
    25 "vectors" : "1",
    26 "temp-hysteresis" : "3",
    27 "temp-cutoff" : "95",
    28 "temp-overheat" : "90",
    29 "temp-target" : "75",
    30 "log" : "5",
    31 "no-pool-disable" : true,
    32 "queue" : "0",
    33 "expiry" : "1",
    34 "scan-time" : "1",
    35 "shares" : "0",
    36 "kernel-path" : "/usr/local/bin",
    37 "show-coindiff" : true,
    38 "keccak-unroll" : "6",
    39 "hamsi-expand-big" : "1",
    40 "disable-rejecting" : true,
    41 "extranonce-subscription" : true
    42 }



  • looks like you're pushing your cards too hard. set worksize to 64 and intensity to 5 and start working your way up from there. use pimp --debug to check that the settings in the config work properly.



  • Thanks for that, but still no joy.

    I keep getting "discarded cloned or rolled work" error



  • im not familiar with the coin or the algorithmn. are you sure that is set correctly? it says "nscrypt" there, should it not be neoscrypt? dont take my word for it, but that would be my guess. check the docs for the miner and see what the proper entry there should be.



  • Deffo nscrypt



  • ![alt text](0_1516750150814_sgminerhw.png image url)



  • ok, so that helps a bit. i tried mining ETH with sgminer and got tonnes of HW errors. your miner IS working, perhaps try claymore? the 1% sucks but 1% of something is better than 100% of nothing. also you can try going lower on the intensity and worksize settings until it stabilizes. personally im happy with claymore, i got more hashpower with far less hassle. worth the 1%

    another thing you can try is running pimpup from the shell and in the secondary menu rebuild the miner. it will download the latest from GIT and reinstall the miner. i hope that helps.



  • @paz Still no joy, tried a new download and all sorts!

    I can mine on windows and I used that sgminer to create a conf file:

    {
    "pools": [
    {
    "url": "stratum+tcp://pool.grlc-bakery.fun:3333",
    "user": "GeHJAVRBDDwNcWJkqfhigrQG3uugVKS61W",
    "pass": "x"
    }
    ],
    "failover-only": true,
    "algorithm": "ckolivas",
    "nfactor": "11",
    "device": "all",
    "intensity": "15",
    "temp-cutoff": "95",
    "temp-overheat": "85",
    "temp-target": "80",
    "gpu-memdiff": "0",
    "shares": "0",
    "kernel-path": "/usr/local/bin",
    "expiry": "28",
    "failover-switch-delay": "60",
    "gpu-dyninterval": "7",
    "hamsi-expand-big": "4",
    "keccak-unroll": "0",
    "queue": "1",
    "scan-time": "7"
    }

    Could it be that sgminer is not compiling correctly?



  • what is this line: "algorithm": "ckolivas",

    I doubt that is a valid entry.



  • Yeah, changed to nscrypt or script-n and nothing works.

    So frustrating, Windows works fine.



  • I was having similar issues getting ccminer to work on Garlic Coin. I switch the algo to scrypt:10 and now am mining just fine.



  • @mrwizard209 sadly no joy on Sgminer



  • @melt Would also appear to be problem with Ethos
    https://www.reddit.com/r/garlicoinMining/comments/7tmges/100_garlic_bounty/



  • Ok

    Downloaded latest image, still no joy

    The following post suggests : reinstall the AMDGPU-PRO driver with ./amdgpu-pro-install --opencl=legacy,rocm, this installs the required OpenCL libraries to make the miner work.

    https://www.reddit.com/r/garlicoinMining/comments/7uoesy/has_anyone_managed_to_mine_in_linux_with_amd_gpus/

    Where do I start?


  • Staff

    We try to implement coin profiles/pools when they are listed on a valid exchange and meet our minimum target market cap for integration.

    Garlic is not yet supported on any valid exchange.

    In the meantime, Scrypt-N is already supported by sgminer and ccminer and so PiMP does support this coin. Simply start with a valid sgminer or ccminer profile and customize it for your needs.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



© 2014-2021 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC