<- Return to getpimp.org

What are some good clock/gputool settings?


  • Staff

    Hey pimps post your settings here that you think works nice and stable and gives a nice hashrate! Thanks.

    Here are some of the things found in the development:

    Asus GTX 1070 Dual 8GB on a ASrock Fatal1ty K4 Gaming
    Stock clocks, stock pimp config = 440W at the wall for 6 (~73W per card including motherboard/cpu overhead)

    [/root]:# gputool --status
    PIMP GPU Tool v20170925 Platform type: NVidia
    NOTE: At least one miner appears to be running.
    GPU 0: (GeForce GTX 1070), Temp: 63C, Fan: 38%, Core Clock: 1961 Mhz (0 Offset), Memory Clock: 3802 Mhz (0 Offset), Performance state: 2, Power Usage: 82.6W (151W Max)
    GPU 1: (GeForce GTX 1070), Temp: 61C, Fan: 36%, Core Clock: 1936 Mhz (0 Offset), Memory Clock: 3802 Mhz (0 Offset), Performance state: 2, Power Usage: 76.3W (151W Max)
    GPU 2: (GeForce GTX 1070), Temp: 60C, Fan: 34%, Core Clock: 1949 Mhz (0 Offset), Memory Clock: 3802 Mhz (0 Offset), Performance state: 2, Power Usage: 74.9W (151W Max)
    GPU 3: (GeForce GTX 1070), Temp: 60C, Fan: 33%, Core Clock: 1936 Mhz (0 Offset), Memory Clock: 3802 Mhz (0 Offset), Performance state: 2, Power Usage: 73.2W (151W Max)
    GPU 4: (GeForce GTX 1070), Temp: 64C, Fan: 38%, Core Clock: 1898 Mhz (0 Offset), Memory Clock: 3802 Mhz (0 Offset), Performance state: 2, Power Usage: 74.8W (151W Max)
    GPU 5: (GeForce GTX 1070), Temp: 62C, Fan: 36%, Core Clock: 1974 Mhz (0 Offset), Memory Clock: 3802 Mhz (0 Offset), Performance state: 2, Power Usage: 81.1W (151W Max)
    [Agent: m171-6x1070 (Running) Total HR: [3.50Kh/s] Miners running [1] GPUs [AAAAAA]]
    [08:13 PM][Uptime: 0d 0:04][root@pimp2(10.0.0.171)]
    [/root]:#
    

    Example of XMR miner output:

    [2017-10-16 20:03:46] GPU #3: GeForce GTX 1070, 592.27 H/s
    [2017-10-16 20:03:46] GPU #4: GeForce GTX 1070, 590.46 H/s
    [2017-10-16 20:03:47] GPU #5: GeForce GTX 1070, 592.44 H/s
    [2017-10-16 20:03:47] GPU #1: GeForce GTX 1070, 591.73 H/s
    [2017-10-16 20:03:50] GPU #0: GeForce GTX 1070, 614.23 H/s
    [2017-10-16 20:04:01] GPU #0: GeForce GTX 1070, 608.31 H/s
    [2017-10-16 20:11:24] GPU #4: GeForce GTX 1070, 606.92 H/s
    [2017-10-16 20:11:24] accepted: 4/4 (diff 35.677), 1775.75 H/s yes!
    [2017-10-16 20:11:34] GPU #4: GeForce GTX 1070, 609.04 H/s
    [2017-10-16 20:11:34] accepted: 5/5 (diff 640.922), 1781.83 H/s yes!
    [2017-10-16 20:11:48] GPU #1: GeForce GTX 1070, 574.18 H/s
    [2017-10-16 20:11:49] accepted: 6/6 (diff 58.033), 1782.54 H/s yes!
    [2017-10-16 20:11:54] GPU #1: GeForce GTX 1070, 552.39 H/s
    [2017-10-16 20:11:54] accepted: 7/7 (diff 104.187), 1771.65 H/s yes!
    [2017-10-16 20:12:06] GPU #4: GeForce GTX 1070, 611.83 H/s
    [2017-10-16 20:12:06] accepted: 8/8 (diff 40.537), 1775.39 H/s yes!
    [2017-10-16 20:12:15] Stratum difficulty set to 49920 (49.92)
    [2017-10-16 20:12:24] GPU #2: GeForce GTX 1070, 574.04 H/s
    [2017-10-16 20:12:24] GPU #0: GeForce GTX 1070, 607.65 H/s
    [2017-10-16 20:12:24] GPU #3: GeForce GTX 1070, 573.49 H/s
    [2017-10-16 20:12:24] GPU #5: GeForce GTX 1070, 573.95 H/s
    [2017-10-16 20:12:24] accepted: 9/9 (diff 68.449), 3494.96 H/s yes!
    

    jada <MSI armor 1070> +150 core max and +650 mem max
    promind <1060> 90W powerlimit +100 core +650 mem, if samsung +800
    tenerifemoney (Zotac GTX 1060 6GB model) core: +65 mem +650


    meshak July-22
    "NVCOffset": 0,
    "NVMOffset": 1450,
    "NVPLimit": 100,
    "fanspeed": 100,
    "temptarget": 70
    Nvidia GTX 1070 Founders edition.
    ETH - Total Speed: 180.681 Mh/s, Total Shares: 101, Rejected: 0, Time: 00:35
    [07/22>23:08] .:meshak:. ETH: GPU0 31.959 Mh/s, GPU1 32.031 Mh/s, GPU2 32.026 Mh/s, GPU3 31.917 Mh/s, GPU4 26.235 Mh/s, GPU5 26.513 Mh/s
    [07/22>23:08] .:meshak:. claymore single mode
    EVGA GTX 1070 SC, power 100, gpu 50, mem 1250 seems to be there limit the batch I have , have the micron memory. the nvidia's have samsung which is known to push into the 9000 mhz range.


    nicksfarmnew July-22
    GTX 1070
    "NVCOffset": 0,
    "NVMOffset": 1200,
    "NVPLimit": 90,
    "fanspeed": 80,
    "temptarget": 70


    <zeus> running stable ETH+SIA w 4 GTX 1070s, 2 GTX 1060... cc150 mc400... if i bump these any higher, Claymore pukes... curious if these numbers are similar to what others have found ? result is ~28 ETH... ~21 ETH been trying to reach 30, but can't seem to find the right mix. thoughts?


  • Support

    MSI GTX 1050 Ti Gaming X 4Gb
    Samsung memory

    "NVCOffset": 150,
    "NVMOffset": 1000,
    "NVPLimit": 80,
    "fanspeed": 75,
    "temptarget": 70

    Claymore's 10.0 Dual
    12,5 MH/s Etherium
    393 MH/s Decred


  • Support

    MSI GTX 1080 Ti Gaming X 11Gb
    Micron memory

    "NVCOffset": 100,
    "NVMOffset": 500,
    "fanspeed": 80,
    "temptarget": 80

    ZCash ~780 H/s (Sols/s)


  • Support

    MSI GTX 1060 Gaming X Plus 6Gb
    Plus version is a 9Gbps memory with lower timings but 9000 MHz memory
    Samsung memory

    "NVCOffset": 120,
    "NVMOffset": 800,
    "fanspeed": 80,
    "temptarget": 80

    ZCash ~340 H/s (Sols/s)

    PS
    on this version 1060 Etherium is not profitable: without overclocking maximum 15-16 MH/s


  • Support

    MSI GTX 1060 Gaming X 6Gb
    Standart version is a 8Gb memory with standart for 1060s timings and 8000 MHz memory
    Micron memory

    "NVCOffset": 100,
    "NVMOffset": 500,
    "fanspeed": 80,
    "temptarget": 80

    ZCash ~325 H/s (Sols/s)

    =======================================
    "NVCOffset": 120,
    "NVMOffset": 800,
    "fanspeed": 100,
    "temptarget": 80

    ZCash ~330 H/s (Sols/s) - the game is not worth the candle

    PS
    ~310 H/s (Sols/s) with "NVCOffset": 0, "NVMOffset": 0



  • MSI 1070 GTX ARMOR 8 GB

    NVC "0"
    NVM "1650"
    NVP "100"
    NVF "70"
    NVT "70"

    this runs stable with XMR powerusage slight shoot outs to 113 watt/hr for the rest 80 watt/hr
    With a 740 h/s on nanopool and a temp average open regular case not a mining rig or extreme heat climate of 35 to max 41 degrees C. room temp around 20 degrees C.

    hope this helps you all out



  • MSI 1070 GTX Armor 8 GB:

    "NVCoffset":"-50",
    "NVMOffset":"950",
    "NVPLimit":"100",
    "fanspeed":"34",
    "temptarget":"70"
    

    Claymore mining Ubiq only. Temperature is about mid 60F, fanspeed is around 34%, and power is about 100W. Hashrate is around 30-31 Mh/s. I find this balance the electricity and still give good hash. If I set the fanspeed to 100, it will run at 100% regardless of the temperature (a bug in PIMP?) Three weeks ago I had a brand new MSI 1070 Armor ran at 100% fan for 2 days, one of the fans broke and stop working. Good thing I can RMA it and get a new one. Be careful about your fan speed!


  • Support

    @mosesong said in What are some good clock/gputool settings?:

    Claymore mining Ubiq only. Temperature is about mid 60F, fanspeed is around 34%, and power is about 100W. Hashrate is around 30-31 Mh/s. I find this balance the electricity and still give good hash. If I set the fanspeed to 100, it will run at 100% regardless of the temperature (a bug in PIMP?) Three weeks ago I had a brand new MSI 1070 Armor ran at 100% fan for 2 days, one of the fans broke and stop working. Good thing I can RMA it and get a new one. Be careful about your fan speed!

    If u set the fanspeed to 100, it will run at 100% regardless of the temperature. It's non a bug in PiMP. The PiMP only performs his task clearly :)



  • 5 Gigabyte G1 Gamers and 5 EVGA GTX 1070 SC

    "NVCoffset":"0",
    "NVMOffset":"1100",
    "NVPLimit":"125",
    "fanspeed":"100",
    "temptarget":"70"

    Stable for 24 hours at 30.89 MH/s per gpu



  • @blackice Thanks!
    I thought the fanspeed is the Maximum it would run in order to maintain the target temperature. I see that a lot people set the fanspeed to 100, I guess it's common? This is going to cause the fan wear out quickly not to mention the noise it would create. I'm new to mining so I'm still learning what is "normal".



  • 13 GTX 1070s mining ZEC getting a total of about 5.7 Kh/s
    NVCOffset 100
    NVMOffset 600
    NVPlimit 120
    Fanspeed 80



  • This set up had been stable for over 24 hours Any advice on the settings for the cards?
    2 GTX 1070 SC
    Dual mining ETH 30.00Mh/s | LBRY 37.00Mh/s each card
    -dcri 45
    "NVCOffset": "100",
    "NVMOffset": "1200",
    "NVPLimit": "100",
    "fanspeed": "80",
    "temptarget": "70"
    Mon Oct 30 21:00:11 2017
    +-----------------------------------------------------------------------------+
    | NVIDIA-SMI 384.47 Driver Version: 384.47 |
    |-------------------------------+----------------------+----------------------+
    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
    |===============================+======================+======================|
    | 0 GeForce GTX 1070 On | 00000000:0B:00.0 Off | N/A |
    | 80% 49C P2 100W / 100W | 2392MiB / 8112MiB | 99% Default |
    +-------------------------------+----------------------+----------------------+
    | 1 GeForce GTX 1070 On | 00000000:0D:00.0 Off | N/A |
    | 80% 46C P2 96W / 100W | 2380MiB / 8114MiB | 99% Default |
    +-------------------------------+----------------------+----------------------+



  • hi all,
    I have a lot of AMD GPUs models, i want know, What are some good clock/gputool settings in my gpu-config.json for this models:

    RX 470
    RX 480
    RX 570
    RX 580


  • Support

    MSI GTX 1050 Ti Gaming X 4Gb
    Samsung memory

    "NVCOffset": 120,
    "NVMOffset": 1000,
    "NVPLimit": 80,
    "fanspeed": 75,
    "temptarget": 70

    EWBF ZEC Miner 0.3.4b
    185 Sols/s Equihash

    GPU 0: (GeForce GTX 1050 Ti), Temp: 38C, Fan: 75%, Core Clock: 1911 Mhz (120 Offset), Memory Clock: 4004 Mhz (1000 Offset), Performance state: Max, Power Usage: 78.3W (80W Max)



  • @blackice how do you get the performance state to max?


  • Support

    @loneminer it turns on itself during a hashing.



  • @blackice

    if i use this targets for inno3d gtx 1080TI
    "NVCOffset": 100,
    "NVMOffset": 500,
    "fanspeed": 80,
    "temptarget": 80

    i will get:

    dmesg
    [ 144.127319] NVRM: GPU at PCI:0000:0a:00: GPU-92f61a79-35b6-cfb3-bc9a-f65a7e2fef69
    [ 144.127322] NVRM: GPU Board Serial Number:
    [ 144.127324] NVRM: Xid (PCI:0000:0a:00): 8, Channel 00000018
    [ 146.629169] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 148.629178] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 150.629182] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 152.629188] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 154.629189] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 156.629197] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 158.629204] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 160.629213] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 162.629213] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 164.629214] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 166.629227] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 168.151230] watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [ewbfminer:2683]
    [ 168.151233] Modules linked in: nvidia_uvm(POE) nvidia_drm(POE) intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel pcbc ppdev aesni_intel aes_x86_64 crypto_simd glue_helper cryptd intel_cstate intel_rapl_perf input_leds nvidia_modeset(POE) nvidia(POE) drm_kms_helper drm fb_sys_fops syscopyarea intel_pch_thermal mei_me sysfillrect sysimgblt mei shpchp hci_uart btbcm serdev btqca btintel bluetooth ecdh_generic parport_pc parport intel_lpss_acpi intel_lpss acpi_als kfifo_buf mac_hid acpi_pad industrialio binfmt_misc autofs4 hid_generic usbhid mxm_wmi ahci libahci e1000e ptp pps_core wmi video pinctrl_sunrisepoint pinctrl_intel i2c_hid hid
    [ 168.151258] CPU: 1 PID: 2683 Comm: ewbfminer Tainted: P OE 4.13.0-041300rc1-generic #201707151931
    [ 168.151258] Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./H110 Pro BTC+, BIOS P1.10 06/20/2017
    [ 168.151259] task: ffff9f86c50eac00 task.stack: ffffbf90413f4000
    [ 168.151381] RIP: 0010:_nv028530rm+0x13/0x40 [nvidia]
    [ 168.151382] RSP: 0000:ffff9f86d6d03bb8 EFLAGS: 00000206 ORIG_RAX: ffffffffffffff10
    [ 168.151383] RAX: 00000000001001c0 RBX: 0000000000000000 RCX: 00000000001001c0
    [ 168.151383] RDX: ffffbf905c000000 RSI: ffff9f86c6e7c008 RDI: ffff9f86cc7a1008
    [ 168.151384] RBP: ffff9f86c3bbdb70 R08: ffff9f86c9f37a48 R09: ffff9f86c3bbdb80
    [ 168.151384] R10: 0000000000000000 R11: 0000000000000000 R12: ffffffffc073b08d
    [ 168.151385] R13: 0000000000000000 R14: ffff9f86c6e7cde0 R15: 0000000000000000
    [ 168.151385] FS: 00007f9017fff700(0000) GS:ffff9f86d6d00000(0000) knlGS:0000000000000000
    [ 168.151386] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
    [ 168.151386] CR2: 0000000001ecf918 CR3: 000000022ffc2000 CR4: 00000000002406e0
    [ 168.151387] Call Trace:
    [ 168.151388] <IRQ>
    [ 168.151544] ? _nv020012rm+0x163/0x1b0 [nvidia]
    [ 168.151692] ? _nv021665rm+0xf2/0x2a0 [nvidia]
    [ 168.151818] ? _nv015992rm+0xcf/0x320 [nvidia]
    [ 168.151940] ? _nv016426rm+0x485/0x4b0 [nvidia]
    [ 168.152084] ? _nv021308rm+0xa6e/0xf20 [nvidia]
    [ 168.152233] ? _nv021118rm+0x1c3/0x340 [nvidia]
    [ 168.152376] ? _nv031263rm+0x224/0x310 [nvidia]
    [ 168.152519] ? _nv031210rm+0x211/0x400 [nvidia]
    [ 168.152662] ? _nv031210rm+0x1e0/0x400 [nvidia]
    [ 168.152804] ? _nv031211rm+0x6a4/0x810 [nvidia]
    [ 168.152946] ? _nv031295rm+0xd5/0xf0 [nvidia]
    [ 168.153089] ? _nv031297rm+0x417/0x590 [nvidia]
    [ 168.153231] ? _nv031296rm+0x51/0x160 [nvidia]
    [ 168.153338] ? _nv028766rm+0x192/0x1a0 [nvidia]
    [ 168.153396] ? nvidia_isr_kthread_bh+0x20/0x20 [nvidia]
    [ 168.153496] ? rm_run_rc_callback+0x9b/0xe0 [nvidia]
    [ 168.153553] ? nvidia_rc_timer+0x47/0x80 [nvidia]
    [ 168.153555] ? call_timer_fn+0x35/0x130
    [ 168.153556] ? run_timer_softirq+0x1db/0x440
    [ 168.153557] ? ktime_get+0x40/0xa0
    [ 168.153558] ? lapic_next_deadline+0x26/0x30
    [ 168.153559] ? clockevents_program_event+0x7a/0xf0
    [ 168.153560] ? __do_softirq+0x104/0x28f
    [ 168.153562] ? irq_exit+0xb6/0xc0
    [ 168.153563] ? smp_apic_timer_interrupt+0x3d/0x50
    [ 168.153565] ? apic_timer_interrupt+0x89/0x90
    [ 168.153565] </IRQ>
    [ 168.153566] Code: ff e8 22 b5 f9 ff 0f b7 c3 5b c3 66 66 66 66 2e 0f 1f 84 00 00 00 00 00 53 31 db 39 4a 10 76 0f 48 8b 12 c1 e9 02 89 c8 8b 1c 82 <89> d8 5b c3 31 ff e8 82 13 00 00 be 01 00 00 00 48 89 c2 31 ff
    [ 168.629227] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 170.629234] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 172.629237] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
    [ 298.780965] nvidia-modeset: Allocated GPU:5 (GPU-20c83fbb-63f1-1a5f-645a-865de8786619) @ PCI:0000:07:00.0
    [ 298.894333] nvidia-modeset: Freed GPU:5 (GPU-20c83fbb-63f1-1a5f-645a-865de8786619) @ PCI:0000:07:00.0

    everytime.
    The only OC i can set is:

    "NVPLimit": "200",  or 210, 220, etc..


  • Any good overclock settings for AMD RX570 ? This is the stock settings
    "gpu_id": "0",
    30 "AMDCoreClk": "1200",
    31 "AMDMemClk": "1800",
    32 "AMDPtune": "7",
    33 "fanspeed": "100",
    34 "temptarget": "70"



  • Zotac 1070 8gb Mini
    Neoscrypt - 875-900 k/hs per
    "NVCOffset": 75,
    "NVMOffset": 1000,
    "NVPLimit": 130,
    "fanspeed": 85,
    "temptarget": 70



  • @schagenremco Holy cow you got some good mem chips!


Log in to reply
 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Support Forum was lost, please wait while we try to reconnect.