gputool --config not applying GPU settings



  • gputool --config are not applying GPU settings for two of my GPU's.

    I tried deleting the gpu-config.json and having gputool recreate it. I tried rebooting the server several times. Power limit settings are not sticking to two of my video cards.



  • Cards are different or the same? Which setup?



  • The rig is running 10 cards on an Asus B250 Mining expert.
    It's consists of two 1080TI's, one 1070 and the rest of the cards are 1070TI's.



  • I believe I'm having the same issue. Power settings are high and gpu temp is high since the config isn't applying. Please see my info below.

    [/root]:# gputool --list
    PIMP GPU Tool v20180116
    GPUs type: NVI
     ---
    3 GPUs seen in hardware:
    01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1070] (rev a1) (prog-if 00 [VGA controller])
    02:00.0 VGA compatible controller: NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev a1) (prog-if 00 [VGA controller])
    04:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1070] (rev a1) (prog-if 00 [VGA controller])
     ---
    GPUs reported by NVidia driver:
    GPU 0: GeForce GTX 1070 (UUID: GPU-c54a907d-4485-bec2-0479-431a46030644)
    GPU 1: GeForce GTX 1080 Ti (UUID: GPU-133b640f-e524-f15f-b536-ea52a79ec231)
    GPU 2: GeForce GTX 1070 (UUID: GPU-98c46951-969a-48b1-de6d-4ba615ac7f9e)
    [Agent: xxxxxxxrig01 (Running) Total HR: [1.59Kh/s] Miners running [1] GPUs [AAA]]
    [04:29 PM][Uptime: 0d 0:04][root@pimp2(xxx.xxx.xxx.xxx)]
    [/root]:# cat gpu-config.json
    {
      "comment": "Please see https://getpimp.org for information about configuring this file",
      "gpuSettings": [
        {
        "gpu_id": "0",
        "NVCOffset": "100",
        "NVMOffset": "720",
        "NVPLimit": "120",
        "fanspeed": "75",
        "temptarget": "70"
        },
        {
        "gpu_id": "1",
        "NVCOffset": "100",
        "NVMOffset": "500",
        "NVPLimit": "200",
        "fanspeed": "75",
        "temptarget": "70"
        },
        {
        "gpu_id": "2",
        "NVCOffset": "100",
        "NVMOffset": "720",
        "NVPLimit": "120",
        "fanspeed": "75",
        "temptarget": "70"
        }
      ]
    }


  • If you disconnect all but the cards giving you trouble, can you then apply the settings?



  • On the Asus B250 mining expert I was only able to get 9 Nvidia 1070s stable any more was a real pita check the Asus site for bios updates maybe they will release one that lets us use all of the 19 slots without using p106-100 cards



  • @itservices

    Mine work when I put the "+" sign in front of the values for NVCOffset and NVMOffset.

    Try this:
    "NVCOffset" : "+100",
    "NVMOffset" : "+720",



  • @oomph

    Those cards all have very different power limits. Please make sure they are within the correct ranges.

    For example, my cards (All EVGA), this is in Watts:

    GTX 1070 Power Range: 92 - 208 Power Default: 185 Current Setting: 120
    GTX 1070Ti Power Range: 90 - 217 Power Default: 180 Current Setting: 117
    GTX 1080Ti Power Range: 125 - 300 Power Default: 250 Current Setting: 162

    -MAL

    ETA: Also make sure the section you are working in applies to the correct card. Normal output from gputool --list should be the same order in the gpu-config.json file.


  • Staff

    Make sure to remove overriding fan/temp controls from the conf/pcfg. Look in the pcfg file for examples or view the videos "setting up profiles" or "editing confs"


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2018 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.