Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Note: To change your forum username: login, click your avatar icon (top right?), Edit Profile. Change the "full name" field to your preferred username.

Quick Links


Not all fan speeds being set



  • All,

    I have 4 GPUs:

    • Gigabyte 3090 Gaming OC 24gb
    • Nvidia 3080 Founders edition
    • Gigabyte 3070 Gaming OC 8gb
    • Nvidia 3070 Founders edition

    Oddly enough, 2 of the 4 set correctly, and the others do not.

    • Gigabyte 3090 Gaming OC 24gb [Works]
    • Nvidia 3080 Founders edition [Static @30%]
    • Gigabyte 3070 Gaming OC 8gb [Doesn't work, @ 0%]
    • Nvidia 3070 Founders edition [Works]

    I verified the fans work on the Gigabyte 3070 in another computer; using their utility I can adjust the fans fine -- without it they turn off.

    I have "targettemp": 0 configured with "fanspeed": 80; however only 2 of the four take the fan speed setings.

    All four do take the NVPLimit setting as expected.

    I have tried setting the speed in miner configurations as well, to no effect on these 2 cards.

    So what can I do to force the fan speed?

    Contents of my gpu-config.json:

    "gpuSettings" : [
          {
             "NVCOffset" : 0,
             "NVMOffset" : 0,
             "NVPLimit" : 360,
             "bus_id" : "01:00.0",
             "fanspeed" : 80,
             "gpu_id" : 0,
             "temptarget" : 0
          },
          {
             "NVCOffset" : 0,
             "NVMOffset" : 0,
             "NVPLimit" : 210,
             "bus_id" : "03:00.0",
             "fanspeed" : 80,
             "gpu_id" : 1,
             "temptarget" : 0
          },
          {
             "NVCOffset" : 0,
             "NVMOffset" : 0,
             "NVPLimit" : 310,
             "bus_id" : "05:00.0",
             "fanspeed" : 80,
             "gpu_id" : 2,
             "temptarget" : 0
          }
       ]
    

    Thanks!



  • From miner.farm without the Gigabyte 3070 installed, note the 3070 founders edition at 30%:

    GPU Status Hashrate Accept/Reject HW Temp Fan Core Memory Power
    01:00 Alive 106.36 Mh/s NA NA 55C 80% 1770 9501 353.52 W
    03:00 Alive 51.71 Mh/s NA NA 52C 80% 1980 6800 181.08 W
    05:00 Alive 86.94 Mh/s NA NA 66C 30% 1590 9251 229.83 W



  • Hello dragneel1945, have you tried any of these GPU one at a time? You would have to use gputool --reset to reset the gpu-config.json file. this might help narrow down the problem to particular GPUs or PCIe lanes conflicting, or riser/cable/power issue. Thanks!



  • @badboybill I've been helping @dragneel1945 out and we've blown the file away multiple times when working through the gputool support document.

    Next is to try different risers because the card works as expected on another system running Windows & the Gigabyte utility to control the GPU.



  • Hi,

    I'm experiencing the same issue on my two rigs:

    Rig1
    GPU Status Hashrate Accept/Reject HW Temp Fan Core Memory Power
    01:00 Alive 24.48 Mh/s NA NA 54C 70% 1972 8025 118.56 W
    02:00 Alive 27.52 Mh/s NA NA 47C 80% 1875 6549 80.20 W
    03:00 Alive 22.05 Mh/s NA NA 63C 80% 1683 4158 111.43 W
    05:00 Alive 22.06 Mh/s NA NA 57C 80% 1695 4158 108.83 W
    06:00 Alive 19.63 Mh/s NA NA 56C 38% 1493 4158 79.97 W

    Rig2
    GPU Status Hashrate Accept/Reject HW Temp Fan Core Memory Power
    01:00 Alive 24.48 Mh/s NA NA 52C 80% 1935 8025 132.34 W
    03:00 Alive 22.01 Mh/s NA NA 67C 80% 1670 4158 113.39 W
    04:00 Alive 22.06 Mh/s NA NA 60C 80% 1683 4158 110.27 W
    06:00 Alive 59.84 Mh/s NA NA 62C 80% 645 9751 174.84 W
    07:00 Alive 19.66 Mh/s NA NA 59C 38% 1506 4158 80.23 W

    All my fans are set to 70% or 80%.
    Its uncanny that the last ones in my rig show slower/indentical fan speeds. I tried with other cards and its the same...38%. Replaced with new fans...the same issue. I check the fans themselves and they are clearly slower. So I forced the Power down to 80W in the hope the temps can be controlled.

    Is there a bug?

    Cheers.



  • I have a hardware solution for my rigs:

    https://www.amazon.com/gp/product/B07S4L41TN/ref=ppx_yo_dt_b_asin_title_o05_s00?ie=UTF8&psc=1

    Converts the fan plug into something you can plug into your motherboards fan supply or some other fan controller.

    Works great.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



© 2014-2021 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC