Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Quick Links

Version 2.4.2 No Boot Sector

  • My friend, because everything looks so that the recording done and your disk is ready to be placed in your rig. Set UEFI boot on and other settings like "Setting up Motherboards" guide.

  • Blackice
    I will give another shot. I've tried several times to boot after getting the results above. I have the motherboard settings correct but I will double check for sure and report back.

    Kind regards,

  • I suspect that the board does not want to see the disk. Do you connect it to the rig via SATA? How is it determined in the BIOS and do you prioritize it?

  • What helped me to create a good bootable SDD with an PimpOS image is to first format it with Rufus: https://rufus.akeo.ie/ and then use HDDRawcopy to write the image. All done on a Windows machine.
    In Rufus choose: MBR patition for BIOS or UEFI. Filesystem: Large FAT32. (under formatting options) Option Create bootable disk: Unchecked.

  • Blackice,

    I connect the SSD via USB and it is the first to boot. I think you are correct the board does not want to see the disk. After work today I am going through the bios settings again.

    Thank you for all the help. I'm sure this will get sorted.


  • info3,

    Thanks for sharing, if after my bios check it doesn't work. I will give that a try.


  • @blackice and @info3,

    I tried both your methods and nothing is working. I think I know what the issue might be, I realized today that the two SSD's I'm trying to use are SSD SCSI, not SATA. The one drive I bricked during this process was a SATA drive. I will pick one up tomorrow and give it a try and report back tomorrow evening.



  • I finally got a version 2.3 to write with a boot sector. I ejected cleanly and now the key isn't getting verified. The only solution for that is to write a new image. It has taken me a week to even get an image to include a boot sector. This is so frustrating.

    I cannot get a boot sector on 2.4.2 no matter what tools I use to write the image. I have tried everything. This upgrade so far has cost me a bricked SSD and the purchase of 2 new SSD's and I am getting nowhere. Is there something in Windows 10 that would prevent the image from being fully written to the disk?

    At this point I'm willing to pay someone to write a clean image for me. I don't know what to do, any help would be very much appreciated.

    I learned a valuable lesson here. If you have a working drive keep it and try the upgrade on a different one. Don't assume the upgrade will go as smoothly as the last time you did it.


  • For fun, here is a picture of 2.3 written with a boot sector. It booted find, just wouldn't take the key.


  • @Anjin, you had mentioned that you had just downloaded the most recent image and you were going to try to replicate the issue? Have you been able to do so and if you did, did you get the same result?

    I tried Linux Live and it did not work. I have an Ubuntu VM, however I can't get it to recognize my external drive. I am at a total loss about what to do.

    Thanks for the help.


  • Staff

    I have not been able to replicate the issue. I will say that older versions are not at this moment supported. We had to make changes to the way our infrastructure is laid out that breaks anything older than 2.4.2 for the validation phase. We are working now to come up with a way to patch around this limitation with older releases. But I cannot provide a time for when this will be complete.

    At this time, please use 2.4.2 only.

    Doctoreaz, I am having trouble parsing your last posting. 'You tried Linux Live and it did not work' Please explain that further. We do not offer a live version.

    'I have an Ubuntu VM, however I can't get it to recognize my external drive', how does this relate to PiMP OS?

  • @Anjin -

    Sorry about the confusion. Earlier in the thread you suggested, " Perhaps you could try using a Linux live distro, like UBCD, Gparted Live, or something similar", I attempted to do that and it did not work.

    The mention about the Ubuntu VM was that I was going to try and use it to burn the image to my external SSD however, I am having no luck with it.

    Again, I apologize for the confusion.


  • @doctoreaz said in Version 2.4.2 No Boot Sector:

    For fun, here is a picture of 2.3 written with a boot sector. It booted find, just wouldn't take the key.



    When you say sectors, do you mean partitions? When I write my 2.4.2 image, using the HDD Raw CopyTool, to a brand new ssd, it only creates 2 partitions. 1 is EFI and the other is the Linux "/" partition. There is no 200MB boot partition on mine. You should see 2 partitions and an "Unallocated" section when complete.


    1. Are you trying to dual boot with another OS? (not a good idea with this).
    2. When you try to boot the new image on your rig, are you selecting the UEFI device or the normal device?


    Note: After the image is written, I use GParted to extend the Linux partition to consume the rest of the disk. Although, another Mining OS competitor has a built in resize option. (hint, hint PiMPs).

  • @malucas - Thanks for the reply. Yes, you are correct I am using the incorrect term. I meant partitions. When I get the same output as you show it simply won't boot.

    1. I am not dual booting.
    2. Yes, I am selecting UEFI device. It's an asrock motherboard and I have gone through the motherboard settings several times. I will try it again, maybe I missed something.

    I will try to extend the Linux partition like you did. Thank you again for taking the time to respond to me.


  • @doctoreaz

    You are welcome.

    My motherboard has a F8 option to select boot device, and I can select it from the bios. It shows me UEFI:<DISK_NAME>.

    One item of note, I am using Windows 10 to write the image. Below is how I am able to get it to work. YMMV.

    1. I have to attach the drive via USB and wait for the chime. (I ignore any errors generated about disk needs repair, since Windows cannot read linux filesystems.)
    2. I use diskpart to clear the disk (make sure it is the correct disk, ask me how I know :( ).
    3. Before you try to copy the image to the drive, open the disk manager (right click on "My Computer" > Manage > Disk Management)
    4. Click on the drive you just cleared. It should prompt you to initialize it. Select GPT and click OK.
    5. Once that has completed (should be quick), use the HDD Raw Copy Tool to write the image. Should take about 5 minutes, if that. (Be sure to close the HDD Raw Copy Tool, else Step 6 USB will fail due to disk locking).
    6. When complete, if using USB, eject the drive. If direct connected, shut down and disconnect the drive.
    7. Then you can use GParted to extend the main partition. (I have it on a bootable PenDrive, and boot the rig with the PenDrive, after attaching the drive).


  • @Mal -

    Thanks again. I have followed the steps as prescribed and I also had a friend of mine burn it with his Linux setup. It appears it is a motherboard issue for me because it still won't boot.

    Thank you to everyone that has helped and now that I know what the proper image should look like (both of my new burns look exactly like what Mal posted) I can see that I have a MB issue to tackle. Might be time for a new one.

    Thank you again.



Want 10% more hash from your rigs?

We promise to keep your email safe and never spam you.

© 2014-2020 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC