Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Quick Links

Version 2.4.2 No Boot Sector

  • @doctoreaz Ah, that's it. Connecting a drive with usb? The drive may be locked from recording in the system. On windows 7, 8, 10 you can try the following.
    Run CMD as Administrator and use diskpart:
    Diskpart, Enter;
    list disk and find number of your disk;
    select disk N where N - number of your disk;
    attributes disk clear readonly;
    Delete all partitions and try latest DMDE again. Do not create partitions manually. Сhoose a physical disk, point the way to the image and Finish him ;)

  • Developer

    Hello DoctoreAz,
    Wanted to check-in and see if it's all resolve now, or if you have any other queries?
    Regards, Louis

  • Blackice,
    Thanks for the response. I am on the road right now. I will be home late tomorrow and will give this a try and report back straight away.


  • This has worked for me first time, every time. Start diskpart (in a command session as administrator).

    select disk <number of disk you are writing pimp to>
    create partition primary align=1024

    Write out the image with your preferred disk imager. I have used both the included "HDDRawCopy1.10Portable" and Win32DiskImager successfully. First time, 100% of the time, when I do my part and don't muck it up.

    The only difference is that Win32DiskImager seems to want a drive letter assigned. Right-click on the partition you just created (in disk manager), select "Change/Set Drive Letter" and ensure that one is set.

  • Blackie and James,

    Thank you both for your input. I tried both methods and they both failed. Here are some pics after blackice's method.

    Ran the diskpart instructions and wrote to the USB SSD. Note it satys 16 GB written to the disk with no errors.

    0_1516592093740_DMDE done.JPG

    I then eject the USB SSD.


    Unplug the USB and then plug it in again and look at disk manager. No boot sector, again. So, I decide to check the diskpart it says 13 GB written to the disk, not 16 like the app says.

    0_1516592401463_DMDE CMD Done.JPG

    I wipe the disk and step through James method.

    I step through the disk part instructions and run HDD Raw. Here are the results disk manager results after HDD Raw.

    0_1516592825967_after HDD.JPG

    Still didn't work. Is the complete size of all the sectors 31,277,232?

    So, I step through James diskpart instructions again and used WinDiskImage. Again no go with a boot sector.


    Just to be sure I check diskpart again and it only shows 13 GB and not boot sector again.

    0_1516593013134_Not 16 Gig.JPG

    At this point I am not sure what to do. I have an Ubuntu image on a VM I can try if anyone would please supply instructions. I also have a Mac I can try on, again if anyone can point me to some instructions.

    I have been down for over a week and I am losing mining time like crazy. I really need some help. I greatly appreciate the efforts so far.


  • My friend, because everything looks so that the recording done and your disk is ready to be placed in your rig. Set UEFI boot on and other settings like "Setting up Motherboards" guide.

  • Blackice
    I will give another shot. I've tried several times to boot after getting the results above. I have the motherboard settings correct but I will double check for sure and report back.

    Kind regards,

  • I suspect that the board does not want to see the disk. Do you connect it to the rig via SATA? How is it determined in the BIOS and do you prioritize it?

  • What helped me to create a good bootable SDD with an PimpOS image is to first format it with Rufus: https://rufus.akeo.ie/ and then use HDDRawcopy to write the image. All done on a Windows machine.
    In Rufus choose: MBR patition for BIOS or UEFI. Filesystem: Large FAT32. (under formatting options) Option Create bootable disk: Unchecked.

  • Blackice,

    I connect the SSD via USB and it is the first to boot. I think you are correct the board does not want to see the disk. After work today I am going through the bios settings again.

    Thank you for all the help. I'm sure this will get sorted.


  • info3,

    Thanks for sharing, if after my bios check it doesn't work. I will give that a try.


  • @blackice and @info3,

    I tried both your methods and nothing is working. I think I know what the issue might be, I realized today that the two SSD's I'm trying to use are SSD SCSI, not SATA. The one drive I bricked during this process was a SATA drive. I will pick one up tomorrow and give it a try and report back tomorrow evening.



  • I finally got a version 2.3 to write with a boot sector. I ejected cleanly and now the key isn't getting verified. The only solution for that is to write a new image. It has taken me a week to even get an image to include a boot sector. This is so frustrating.

    I cannot get a boot sector on 2.4.2 no matter what tools I use to write the image. I have tried everything. This upgrade so far has cost me a bricked SSD and the purchase of 2 new SSD's and I am getting nowhere. Is there something in Windows 10 that would prevent the image from being fully written to the disk?

    At this point I'm willing to pay someone to write a clean image for me. I don't know what to do, any help would be very much appreciated.

    I learned a valuable lesson here. If you have a working drive keep it and try the upgrade on a different one. Don't assume the upgrade will go as smoothly as the last time you did it.


  • For fun, here is a picture of 2.3 written with a boot sector. It booted find, just wouldn't take the key.


  • @Anjin, you had mentioned that you had just downloaded the most recent image and you were going to try to replicate the issue? Have you been able to do so and if you did, did you get the same result?

    I tried Linux Live and it did not work. I have an Ubuntu VM, however I can't get it to recognize my external drive. I am at a total loss about what to do.

    Thanks for the help.


  • Staff

    I have not been able to replicate the issue. I will say that older versions are not at this moment supported. We had to make changes to the way our infrastructure is laid out that breaks anything older than 2.4.2 for the validation phase. We are working now to come up with a way to patch around this limitation with older releases. But I cannot provide a time for when this will be complete.

    At this time, please use 2.4.2 only.

    Doctoreaz, I am having trouble parsing your last posting. 'You tried Linux Live and it did not work' Please explain that further. We do not offer a live version.

    'I have an Ubuntu VM, however I can't get it to recognize my external drive', how does this relate to PiMP OS?

  • @Anjin -

    Sorry about the confusion. Earlier in the thread you suggested, " Perhaps you could try using a Linux live distro, like UBCD, Gparted Live, or something similar", I attempted to do that and it did not work.

    The mention about the Ubuntu VM was that I was going to try and use it to burn the image to my external SSD however, I am having no luck with it.

    Again, I apologize for the confusion.


  • @doctoreaz said in Version 2.4.2 No Boot Sector:

    For fun, here is a picture of 2.3 written with a boot sector. It booted find, just wouldn't take the key.



    When you say sectors, do you mean partitions? When I write my 2.4.2 image, using the HDD Raw CopyTool, to a brand new ssd, it only creates 2 partitions. 1 is EFI and the other is the Linux "/" partition. There is no 200MB boot partition on mine. You should see 2 partitions and an "Unallocated" section when complete.


    1. Are you trying to dual boot with another OS? (not a good idea with this).
    2. When you try to boot the new image on your rig, are you selecting the UEFI device or the normal device?


    Note: After the image is written, I use GParted to extend the Linux partition to consume the rest of the disk. Although, another Mining OS competitor has a built in resize option. (hint, hint PiMPs).

  • @malucas - Thanks for the reply. Yes, you are correct I am using the incorrect term. I meant partitions. When I get the same output as you show it simply won't boot.

    1. I am not dual booting.
    2. Yes, I am selecting UEFI device. It's an asrock motherboard and I have gone through the motherboard settings several times. I will try it again, maybe I missed something.

    I will try to extend the Linux partition like you did. Thank you again for taking the time to respond to me.



Want 10% more hash from your rigs?

We promise to keep your email safe and never spam you.

© 2014-2020 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC