Version 2.4.2 No Boot Sector



  • Hello -

    I had Pimp up and running on 2.3.3.0. Saw that there was an upgrade and decided that I should do it. This has been a challenging decision so far.....

    I cannot get the image 2.4.2 to write correctly to my SSD. I have tried 2 different computers, 2 different SSD's and the same result. Only 2 sectors get written to the SSD no matter if I use DMDE or HDDRAW.

    I want to say now that YES, I have done clean installs and properly ejected the SSD. I have even tried to power down my PC after ejecting and still the same result.

    So, I decided to go back to 2.3.3.0 and viola, I got 3 sectors and it booted fine. However, it would not recognize my key. Went through all of those troubleshooting steps to no avail. Decided to wipe that SSD and start over and now it's dead, LOL.

    I have no idea what to do at this point. I've attached a copy of what I see in the Windows Disk manager. At this point I am thinking about wiping my last SSD and trying to do it via Linux.

    Anyone have any thoughts, ideas, words of wisdom?

    Kind regards,
    DoctoreAZ!
    0_1516163005165_noboot.JPG



  • First you need to delete the partitions and try again.



  • Hi Blackice,

    Thanks for getting back to me. I have done that several times. I am an expert at using diskpart now:) I have tried writing the image on 2 different laptops, and on 2 different drives several times. Each time I have made sure to delete the two partitions. When I had the 2.3 version I saw 3 partitions with one labeled boot.

    I made sure to use a wired connection to download the image, I did not use wireless just in case it corrupted the download. I even tried to use the current version of DMDE, all have failed. I have also made sure to properly eject the USB. I'm kind of baffled.

    Has there been any reports of image issues with 2.4.2? I've made no changes to the rig or to the two laptops (other than standard OS/application updates). I'm so bummed, it was running great.

    Any ideas other than to keep trying to write it and hoping it works?

    Regards,
    DoctoreAz



  • If you are an expert at using diskpart, maybe it help you too? https://forum.getpimp.org/topic/268/can-not-validate-license-key/20



  • I was being facetious about being an expert :) Thanks for the link, I will give it a shot.

    Regards,
    DoctoreAz



  • Welp, didn't work. Even downloaded a new copy of the 2.4.2 package, unpacked with 7-Zip and tried it again creating a GPT partition. Same result no boot sector. I honestly have no idea what to do at this point. I was mining away, I've now been offline for 3 days because of my attempt to upgrade. I really need some help. Can anyone suggest something?

    I am starting to think I am really screwed here. Why would the image not write the boot sector?

    Any help would be appreciated.

    Regards,
    DoctoreAz



  • I tried to take another swing at it. I deleted the sectors and tried converting it to GPT no go. I tried converting it to MBR no go. It just will not write the image completely. When I try it with DMDE it verifies that 16 Gig was written, when I go to disk manager it only show 13 gig written in two sectors, just like the picture above, no boot label on either of the sectors.

    I have done this at least 20 times over the last 3 days. Is there any thing I can do?

    Regards,
    DoctoreAz


  • Staff

    hmmm.... first of all, do not convert the image to anything. I just downloaded the current image and will see if I can replicate. Perhaps you could try using a Linux live distro, like UBCD, Gparted Live, or something similar?



  • Thanks for the reply. I have noticed that windows is not assigning a drive letter so I bought a new SSD, plugged it into my laptop and went to device manager, uninstalled it and rebooted, then went to disk manager and created a simple volume and it recognized the USB. I tried it again and it did not work. Does it need to be a GPT volume or a MBR?

    I will give Linux a try and see how that goes. If anyone can think of anything it would be greatly appreciated.

    Regards,
    DoctoreAz



  • One more thing that is really odd, I had no problem burning 2.3 the first time, now it won't even burn to the SSD. Maybe it's a MS update that is messing things up? I have an Ubuntu VM. Are there instructions some place how to do the install with Linux? I did a search on the forum and couldn't find any. I am a Linux amateur and could use some guidance.

    As always thanks for any help.

    Regards,
    DoctoreAz



  • @doctoreaz Ah, that's it. Connecting a drive with usb? The drive may be locked from recording in the system. On windows 7, 8, 10 you can try the following.
    Run CMD as Administrator and use diskpart:
    Diskpart, Enter;
    list disk and find number of your disk;
    select disk N where N - number of your disk;
    attributes disk clear readonly;
    exit.
    Delete all partitions and try latest DMDE again. Do not create partitions manually. –°hoose a physical disk, point the way to the image and Finish him ;)


  • Support

    Hello DoctoreAz,
    Wanted to check-in and see if it's all resolve now, or if you have any other queries?
    Regards, Louis



  • Blackice,
    Thanks for the response. I am on the road right now. I will be home late tomorrow and will give this a try and report back straight away.

    Regards
    DoctoreAz



  • This has worked for me first time, every time. Start diskpart (in a command session as administrator).

    select disk <number of disk you are writing pimp to>
    clean
    create partition primary align=1024
    exit

    Write out the image with your preferred disk imager. I have used both the included "HDDRawCopy1.10Portable" and Win32DiskImager successfully. First time, 100% of the time, when I do my part and don't muck it up.

    The only difference is that Win32DiskImager seems to want a drive letter assigned. Right-click on the partition you just created (in disk manager), select "Change/Set Drive Letter" and ensure that one is set.



  • Blackie and James,

    Thank you both for your input. I tried both methods and they both failed. Here are some pics after blackice's method.

    Ran the diskpart instructions and wrote to the USB SSD. Note it satys 16 GB written to the disk with no errors.

    0_1516592093740_DMDE done.JPG

    I then eject the USB SSD.

    0_1516592277878_Eject.JPG

    Unplug the USB and then plug it in again and look at disk manager. No boot sector, again. So, I decide to check the diskpart it says 13 GB written to the disk, not 16 like the app says.

    0_1516592401463_DMDE CMD Done.JPG

    I wipe the disk and step through James method.

    I step through the disk part instructions and run HDD Raw. Here are the results disk manager results after HDD Raw.

    0_1516592825967_after HDD.JPG

    Still didn't work. Is the complete size of all the sectors 31,277,232?

    So, I step through James diskpart instructions again and used WinDiskImage. Again no go with a boot sector.

    0_1516592946853_afterwindisk.JPG

    Just to be sure I check diskpart again and it only shows 13 GB and not boot sector again.

    0_1516593013134_Not 16 Gig.JPG

    At this point I am not sure what to do. I have an Ubuntu image on a VM I can try if anyone would please supply instructions. I also have a Mac I can try on, again if anyone can point me to some instructions.

    I have been down for over a week and I am losing mining time like crazy. I really need some help. I greatly appreciate the efforts so far.

    Regards,
    DoctoreAz



  • My friend, because everything looks so that the recording done and your disk is ready to be placed in your rig. Set UEFI boot on and other settings like "Setting up Motherboards" guide.



  • Blackice
    I will give another shot. I've tried several times to boot after getting the results above. I have the motherboard settings correct but I will double check for sure and report back.

    Kind regards,
    DoctoreAz



  • I suspect that the board does not want to see the disk. Do you connect it to the rig via SATA? How is it determined in the BIOS and do you prioritize it?



  • What helped me to create a good bootable SDD with an PimpOS image is to first format it with Rufus: https://rufus.akeo.ie/ and then use HDDRawcopy to write the image. All done on a Windows machine.
    In Rufus choose: MBR patition for BIOS or UEFI. Filesystem: Large FAT32. (under formatting options) Option Create bootable disk: Unchecked.



  • Blackice,

    I connect the SSD via USB and it is the first to boot. I think you are correct the board does not want to see the disk. After work today I am going through the bios settings again.

    Thank you for all the help. I'm sure this will get sorted.

    Regards,
    DoctoreAZ


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2018 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.