Miner.farm Crypto Currency Community Forum

Browse and post your favorite coin/crypto news, miner.farm and PiMP OS updates and announcements, mining guides, overclocking tips, and more...

Note: To change your forum username: login, click your avatar icon (top right?), Edit Profile. Change the "full name" field to your preferred username.

Quick Links


[ANN] nVidia RTX 3060Ti Overclocking Settings for ETH mining on PIMP 2.25 Running COOL


  • Staff

    Heya miner.farmers! Just wanted to get the thread going for the new nvidia cards. Reminder: nvidia 3000-series GPU require PIMP v2.25.2 or later, downloads in your account page https://miner.farm/account

    PIMP makes Nvidia really simple when it comes to setting the clocks up thanks to gputool.

    Here is the sweet spot for 3060Ti using gputool. You would generate a new gputool config file using gputool --reset and then edit it with nano /root/gpu-config.json here's the values i liked best:

             "NVCOffset" : -100,
             "NVMOffset" : 1900,
             "NVPLimit" : 130,
             "bus_id" : "01:00.0",
             "fanspeed" : 70,
             "gpu_id" : 0,
             "temptarget" : 70
    

    Using phoenixminer with ethermine pool and FLAGS are nearly default, except I removed the -tt 75 to allow gputool to keep the fan rpm steady at 70% fans, this helps the fan sleeve bearings last longer. :) Little tip.

    Looking strong and steady on miner.farm. On the graph you can see where I had it running stable and then started overclocking. While overclocking we stepped up the mem clocks while observing the accepted shares per minute and the pool side recorded hash. With the pool side delay we took our time to lock these gains in with stability each step.

    35d86c04-c6f2-446c-aa6d-f67b7c880f94-image.png

    If you were wondering "How did he check the pool side?" I'm using ethermine.org for my ETH pool. Go on the web site and put your mining address (ETH wallet) in, and it'll show you payouts and everything. Nice to see all their stats and match them against what the miner reports to miner.farm. More things to check means less errors are possible and higher reliability.

    eae358bb-3dbe-4c7e-ac42-0ec92e8ea5dd-image.png

    Thank you for all your support and if this project helped you please consider buying a subscription or a copy to help the project! We have a high server bill :O

    Post comments and questions below - don't be shy!



  • Wow, melt. Thank you for your post. This is what I am looking for right now. A big "thank you" to the PIMP OS team for the new release version of PIMP OS. This is the next thing on my schedule that I will do. My bro an I have hardware for a six GPU 3060 TI mining rig. How many 3060s have you tested?


  • Staff

    Hey 4thHorseman, sure, happy to help. I do note, I got up this morning and the miner was still running but 0MH/s, so I backed the memory clocks off to 1800. Only dropped to 58.8MH/s and running smooth and cool all day. Freezing compared to the Vega56 which is like a Hair Dryer on low :) This is the EVGA model.



  • Hello melt,

    how are you monitoring the memory temperature with Pimp OS?


  • Staff

    Hey 4thHorseman, great question. Was looking over those posts about folks having hot VRAM on some of the 3000-series. Not having any issues on this EVGA model thankfully.

    As for monitoring, I don't know if this is provided by the linux driver or not, which had us somewhat concerned that we couldn't monitor it. I did notice one of the pimp tools called gmonitor is able to monitor the VRAM utilization, at least that's something. In my case it's about 50% VRAM utilization with the -100/1800/130W setting above, and running stable and smooth.

    Here's a look at the gmonitor:

    a29af78d-e4ef-46f6-b227-1f0001cf2c9b-image.png

    For context here is how that card looks mining ETH on miner.farm:

    50f18d88-9324-4dbe-920e-ec159b0f635a-image.png

    Curious to hear what you're trying and getting on your end. Thanks!



  • Great, thank you. I will power up the new PIMP OS and give you an update.



  • Hello melt,

    I configured my gpu-config.json using your config values from above. It looks like the following:

     2    "comment" : "Please see https://forum.getpimp.org/topic/31/gputool-how-to-overcloc
       k-nvidia-and-amd-gpus for information about configuring this file.",
     3    "gpuSettings" : [
     4       {
     5          "IntelCard" : 1,
     6          "bus_id" : "00:00.0",
     7          "gpu_id" : 0
     8       },
     9       {
    10          "NVCOffset" : -100,
    11          "NVMOffset" : 1800,
    12          "NVPLimit" : 130,
    13          "bus_id" : "01:00.0",
    14          "fanspeed" : 80,
    15          "gpu_id" : 1,
    16          "temptarget" : 70
    17       },
    18       {
    19          "NVCOffset" : -100,
    20          "NVMOffset" : 1800,
    21          "NVPLimit" : 130,
    22          "bus_id" : "08:00.0",
    23          "fanspeed" : 80,
    24          "gpu_id" : 2,
    25          "temptarget" : 70
    26       },
    27       {
    28          "NVCOffset" : -100,
    29          "NVMOffset" : 1800,
    30          "NVPLimit" : 130,
    31          "bus_id" : "09:00.0",
    32          "fanspeed" : 80,
    33          "gpu_id" : 3,
    34          "temptarget" : 70
    35       }
    36    ]
    37 }
    
    
    

    32 }

    However, I had several errors:

    
    GPU 1: NVI, busid 01:00.0                                                               
    GPU 1: !                                                                                
    ERROR: Error assigning value 70 to attribute 'GPUTargetFanSpeed' (pimp3:0[fan:1]) as specified in assignment '[fan:1]/GPUTargetFanSpeed=70' (Unknown Error).                    
    
    
      Attribute 'GPUFanControlState' (pimp3:0[gpu:1]) assigned value 1.                     
    
    GPU 1: PowerLimit set to 130 W
    GPU 1: Core speed offset is -100
    GPU 1: Memory speed offset is 1800
    GPU 2: NVI, busid 08:00.0
    GPU 2: Fan Speed set to 70%
    GPU 2: PowerLimit set to 130 W
    GPU 2: Core speed offset is -100
    GPU 2: Memory speed offset is 1800
    GPU 3: NVI, busid 09:00.0
    GPU 3: ! Unable to init server: Could not connect: Connection refused
    
    ERROR: The control display is undefined; please run `/usr/bin/nvidia-settings --help` for usage information.
    ...
    ...
    

    When I start the miner with "pimp --test 1"
    GPU1 has 51 MHs and GPU 2 and 3 have 58mhs each. Could you please give me an advise?

    Thank you in advance.


  • Staff

    Hey 4thHorseman, probably bus id mismatch, can compare the bus_id's and fix them to match the output of gputool --list or just start over with gputool --reset and then change the values using nano gpu-config.json otherwise maybe a reboot would fix.



  • This post is deleted!


  • gpu --list:

    /root]:# gputool --list
    PIMP GPU Tool v20200730 
    GPUs type: Mixed 
    
    WARNING: Intel GPUs are not currently supported for mining
     ---
    4 GPUs seen in hardware ('lspci' output):
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04) (prog-if 00 [VGA controller])
    01:00.0 VGA compatible controller: NVIDIA Corporation Device 2486 (rev a1) (prog-if 00 [VGA controller])
    08:00.0 VGA compatible controller: NVIDIA Corporation Device 2486 (rev a1) (prog-if 00 [VGA controller])
    09:00.0 VGA compatible controller: NVIDIA Corporation Device 2486 (rev a1) (prog-if 00 [VGA controller])
    

    I changed the bus id to 7 but I get the following messages:

    Conf file loaded, configuring 4 GPUs..
    GPU 0: INT, busid 00:00.0
    GPU 1: NVI, busid 01:00.0
    GPU 1: ! Warning: Configuration entry '07:00.0' does not match BusID detected for this card (01:00.0) . 
    You need to update gpu-config.json with 'gputool --update' if you have changed your hardware configuration
    

    How can I fix the bus id?


  • Staff

    Did you try gputool --update like it suggests?

    You show 1, 8, and 9, not sure why you chose to change it to 7.



  • Yes I tried, but it says

    [/root]:# gputool --update
    PIMP GPU Tool v20200730 
    GPUs type: Mixed 
    
    WARNING: Intel GPUs are not currently supported for mining
    GPU count matches config, no changes made.
    

    I can try to change the fan speed manually with

    nvidia-settings -a [fan:1]/GPUTargetFanSpeed=70
    

    but it gives the same error.

    ERROR: Error assigning value 70 to attribute 'GPUTargetFanSpeed' (pimp3:0[fan:1]) as
           specified in assignment '[fan:1]/GPUTargetFanSpeed=70' (Unknown Error).
    

    I don't know why this affects MH speed.


  • Staff

    @melt said in [ANN] nVidia RTX 3060Ti Overclocking Settings for ETH mining on PIMP 2.25 Running COOL:

    Hey 4thHorseman, probably bus id mismatch, can compare the bus_id's and fix them to match the output of gputool --list or just start over with gputool --reset and then change the values using nano gpu-config.json otherwise maybe a reboot would fix.

    gputool --reset and place your values into the newly reset configuration.



  • But what are my values? Am I missing something?


  • Staff

    Step 1) gputool --reset
    Step 2) nano gpu-config.json
    Step 3) Replace the numbers in the file with numbers that work better for your card: change the core clock offset from 0 to -100, change the memory clock offset from 0 to 1800. Do not change the bus_id's but have a look at them and you'll see that they look like the bus id's that are in the gputool --list.
    Step 4) Control+X, then Y for Yes and Enter to save and exit
    Step 5) gputool --config
    Step 6) You should see correct output from Step 5.



  • I tried that 3 times, but I still get the same error:

    [/root]:# gputool --config
    PIMP GPU Tool v20200730 
    GPUs type: Mixed 
    
    WARNING: Intel GPUs are not currently supported for mining
    Conf file loaded, configuring 4 GPUs..
    GPU 0: INT, busid 00:00.0
    GPU 1: NVI, busid 01:00.0
    GPU 1: ! 
    ERROR: Error assigning value 70 to attribute 'GPUTargetFanSpeed' (pimp3:0[fan:1]) as specified in assignment '[fan:1]/GPUTargetFanSpeed=70' (Unknown Error).
    
    
      Attribute 'GPUFanControlState' (pimp3:0[gpu:1]) assigned value 1.
    
    GPU 1: PowerLimit set to 130 W
    GPU 1: Core speed offset is -100
    GPU 1: Memory speed offset is 1800
    GPU 2: NVI, busid 08:00.0
    GPU 2: Fan Speed set to 70%
    GPU 2: PowerLimit set to 130 W
    GPU 2: Core speed offset is -100
    GPU 2: Memory speed offset is 1800
    GPU 3: NVI, busid 09:00.0
    GPU 3: ! Unable to init server: Could not connect: Connection refused
    
    ERROR: The control display is undefined; please run `/usr/bin/nvidia-settings --help` for usage information.
    
    GPU 3: PowerLimit set to 130 W
    GPU 3: ! Unable to init server: Could not connect: Connection refused
    
    ERROR: The control display is undefined; please run `/usr/bin/nvidia-settings --help` for usage information.
    
    GPU 3: ! Unable to init server: Could not connect: Connection refused
    
    ERROR: The control display is undefined; please run `/usr/bin/nvidia-settings --help` for usage information.
    

    It doesn't matter which values I use, it's always the same error.

    Maybe it has something to do with:

    ERROR: The control display is undefined; please run `/usr/bin/nvidia-settings --help` for usage information.
    

    ?



  • Hey melt, i slept over it and today it works!

    I have a gigabyte b250 fintech and I changed the primary grafics conf to pci 1. Maybe this solved my problem? Anyway, thank you for supporting. All three 3060 TI founders are running smooth with 58.x MHs. Later, I will attach the fourth founder and give it a 24 H run try.



  • My rig runs fine now with three GPUs. I just added the fourth GPU and again, I get the same error but now for the fourth GPU.

    GPU 2: Memory speed offset is 1800
    GPU 3: NVI, busid 09:00.0
    GPU 3: ! Unable to init server: Could not connect: Connection refused
    
    ERROR: The control display is undefined; please run `/usr/bin/nvidia-settings --help` for usage information.
    
    GPU 3: PowerLimit set to 130 W
    GPU 3: ! Unable to init server: Could not connect: Connection refused
    
    ERROR: The control display is undefined; please run `/usr/bin/nvidia-settings --help` for usage information.
    
    GPU 3: ! Unable to init server: Could not connect: Connection refused
    
    ERROR: The control display is undefined; please run `/usr/bin/nvidia-settings --help` for usage information.
    

    I tried your steps and rebooted the system several times, but for the fourth GPU it just won't work.

    What seems strange to me is that in fact it seems to be GPU 2 which has not the settings applied (runs only with 51 MHs) but not GPU 3 as I would addume, due to the error.

    Eth speed: 227.171 MH/s, shares: 4/0/0, time: 0:00
    GPUs: 1: 58.533 MH/s (2) 2: 51.511 MH/s (0) 3: 58.567 MH/s (0) 4: 58.561 MH/s (2)
    Eth: New job #67416e79 from eu1.ethermine.org:4444; diff: 4000MH
    Eth: New job #97881e40 from eu1.ethermine.org:4444; diff: 4000MH
    Eth: New job #a2761a90 from eu1.ethermine.org:4444; diff: 4000MH
    Eth: New job #7a42b8a6 from eu1.ethermine.org:4444; diff: 4000MH
    Eth speed: 227.163 MH/s, shares: 4/0/0, time: 0:01
    GPUs: 1: 58.531 MH/s (2) **2: 51.508 MH/s** (0) 3: 58.568 MH/s (0) 4: 58.557 MH/s (2)
    GPU1: 49C 70% 130W, GPU2: 57C 30% 130W, GPU3: 49C 70% 130W, GPU4: 52C 30% 130W
    GPUs power: 518.6 W
    
    

 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



© 2014-2021 Miner.farm | By Miners, For Miners | Portable Instant Mining Platform, LLC