Cant set fan speed.. Nvidia EWBF



  • I have EVGA 1070 ftw's. My fans constantly run 100% no matter what I try. If I use gputool and set fan speed in gpu-config.json to any value (i've tried as low as 10 and as high as 100) it will not actually affect my fan speed. Im using the Nvidia ewbf zcash miner, and in the miner config it says if I remove the '--templimit' flag it will let gputool control the fans. If I remove that flag it still has absolutely no affect on fan speed. Ive also tried using the --templimit with a negative value to set a fan speed percentage similar to how claymore works, but no affect. Also, when I change the fan speed value in the gpu-config.json and save the file I use the 'gputool --config' to apply the newly configured values and it echos off what I changed the values to but no matter the value i set fan speed to, it always says 60%. but my fans are roaring at full speed.

    Any help will be appreciated. My gpus stay cool enough in my basement and I dont want to replace fans if I can help it.



  • you could try using a third party tool called amdgpu-pro-fans which also triggers alot of nvidia cards

    (omit sudo if you are logged into shell as root)
    AMD PRO GPU FANS
    sudo apt-get install git
    git clone https://github.com/dominilux/amdgpu-pro-fans
    cd amdgpu-pro-fans
    chmod +x amdgpu-pro-fans.sh
    Usage:
    sudo ./amdgpu-pro-fans.sh -s [speed 0 - 100]



  • the gputool sometimes doesn't set the fan correctly after you change the json file. At least that happen to me. Here is what you need to do (or at least try).

    Let's say you have fan speed of 34 in your json file, when you run gputool --config, it may or may not change the fan speed.
    RUN gputool --config again, this time you should see the fan speed reduce by 2%,
    RUN gputool --config again, this time the fan speed reduce by 2% from last value.
    ..... keep running gputool --config until it reach the number you specified in the .json file.
    From this point on, your json file should set the fan speed correctly every time you run or reboot.

    Every time I change the .json file, I may or may not have to keep running gputool --config in a rows.



  • @mosesong this is a feature of the driver. It raises the speed perfectly, but does not want to lower without a kick. Therefore, when changing the config with a decrease in the speed of the fans, reboot is recommended. This is similar to the protective function.

    @imthematador which version of the PiMP?



  • A reboot seemed to work. I ended up taking the '--templimit ' flag out of the EWBF config and set my fan speed with gputools and reboot. Works fine. Keeping the cards at a cool 51C. Thanks!


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2017 PiMP LLC. All rights Reserved.

Looks like your connection to PiMP Forum was lost, please wait while we try to reconnect.