Welcome to the PiMP OS and Miner.farm forum.

Stuck on screen that shows IP



  • I installed Pimp 2.4.2 and completed the setup. It is now stuck on a screen that says:

    Key <key> validated.
    Thank you very much for.....
    Machines IP is:10....

    There is no command line or UX like on my previous version. Was the UX removed in the latest version?



  • exact same problem for me. Everything was working great yesterday.



  • I installed pimp-2.4.2-all and am having the same issue.... The thing is I rarely use the GUI. I just ssh into the machine... But it would be nice to have a desktop. Is there a projected time line for pimp-2.4.3-all? I am using 2 MSI RX 580's .

    Anyone else out there seeing this issue?



  • Solved it for me..Had no access at the machine itself but ssh works great.
    After I shelled in I ran the following commands and rebooted. Now I have desktop again...
    Hope I didn't screw anything up in the process. Will keep you guys updated.

    apt-get install --reinstall ubuntu-desktop
    apt-get install --reinstall lightdm
    sudo apt-get install compizconfig-settings-manager
    DISPLAY=:0 ccsm &



  • Thanks michaelbtolbert and redFred5 !!

    You solved my Desktop problem.
    I used mobaXterm and these commands:

    apt-get install --reinstall ubuntu-desktop
    apt-get install --reinstall lightdm
    sudo apt-get install compizconfig-settings-manager
    DISPLAY=:1 ccsm &



  • This is what happens when the system is configured not to have a desktop.
    edit your gpuvars via shell. You want to change the line export DISPLAY=0 to export DISPLAY=1

    However, my advice is dont use gnome (the desktop gui) at all, and learn how to use pimp via ssh from another machine only. the desktop gui really is totally unecessary



  • I use almost exclusively ssh to get to my rig but when I was tweaking my GPU''s VBIOS it was nice to have a DE to work in. It is a pain to scp rom files back and forth while doing this. But otherwise I totally agree and I dont even have a monitor on the rig most of the time.



  • why not use VNC then? or if not VNC, install teamviewer?



  • I found I have the same problem.after I did the install and added one of my gpu’s. It boots to the desktop with the onboard video and no gpu’s connected. when I add a gpu it will not load the desktop. I can ssh to the machine but after setting up the miner profile for sgminer.eth.conf with the same settings as my first rig no joy. Only mines to nanopool but when I go to look at the stats on the pool no worker and no stats. I can live with running it from ssh but it would be nice if it would mine also. I tried the all the suggestions in this thread with no success. Next stepI will be an install from an older version and then do an in place upgrade.



  • you need to separate your issues. desktop or no desktop is unrelated to your miner not registering on the pool. if you can get a miner into the air, your system is working. if it's not reg on the pool, you've mostly likely done something wrong in the config.



  • Thank you for your response. Yes they are seperate issues and I probably could have indicated that more clearly but the fact is I have no GUI desktop when gpu’s are connected. I have a mining problem, which is a seperate issue. I did indicate that the mining profile was setup the same as my first working rig. Both rigs are registered and minerfarm is registered on both. I see both rigs in my farm and they both show they are connected to a pool and working. Except the new rig with the Desktop issue(unrelated) will not connect to us1.ethermine.org. Shows dead in in my farm. When I go to nanopool (which it now defaults to) to view my stats there are no active workers. I did confirm my wallet 4 times. Hopefully the extra details help. At this point I am not sure what to do so I am going to try changing the port the miner profiles use and if that does not work delete the profile and start over. Any other ideas or suggestions I will appreciate.



  • If it shows "DEAD" then it worked, the GPUs ran way too hard, and they self destructred the thread. it still seems like a config issue to me. Be wary that these following items need to be carefully configured. When I added zcash the default settings blew my machine up and it would restart every time it even started. You need to back those numbers down to something really low and increment up bit by bit by trial and error. Below is how I got my zcash maxed out before restarts. Below that is what I suggest you start by:

    My zcash:
    "intensity" : "21",
    "gpu-threads" : "1"
    "worksize" : "32",

    Starting settings:
    "intensity" : "8",
    "gpu-threads" : "1"
    "worksize" : "8",



  • also make sure you rm gpu-config.json, and renew it and dont change any OC until you have a working miner profile



  • This post is deleted!


  • This post is deleted!


  • Thanks. I did not know that “Dead” indicated it worked but the gpus were working to hard. Now it is starting to click.



  • This post is deleted!


  • @laroche-genie-it said in Stuck on screen that shows IP:

    Thanks michaelbtolbert and redFred5 !!

    You solved my Desktop problem.
    I used mobaXterm and these commands:

    apt-get install --reinstall ubuntu-desktop
    apt-get install --reinstall lightdm
    sudo apt-get install compizconfig-settings-manager
    DISPLAY=:1 ccsm &

    Did not help me.



  • This worked thanks for posting the solution if it was an Nvidia rig I would have left it headless but with amd it is easier to bios mod the cards with the DE
    do you have the process to BIOS mod without the DE if so can you post it

    apt-get install --reinstall ubuntu-desktop
    apt-get install --reinstall lightdm
    sudo apt-get install compizconfig-settings-manager
    DISPLAY=:1 ccsm &



  • @benjaminhamdorf I have asus z270a + rx580, no NVIDIA.
    Do not know what is DE and BIOS mod do you mean.
    On these rig with 2.3.30 work perfect, with 2.4.1 and 2.4.2 desctop deos not start.


 



Want 10% more hash from your rigs?



We promise to keep your email safe and never spam you.



Copyright (c) 2012-2018 PiMP LLC. All rights Reserved.