There is no problem. Need a board with UEFI. But you can try older versions of the PiMP. 2.1 for amd, 2.3.30 for nvidia.